Jump to content

[Flash Drive] Downloaded application, created new folder, moved application but it lost +x and now I can't set it.

Recommended Posts

Hey all,

    I created a folder on my flash drive (/boot/config/custom), then I downloaded the text editor application Micro, extracted it, and it worked just fine when it was in /root. I used it to edit the /boot/config/go files to symlink from /boot/config/custom/micro to /usr/local/bin/micro and a few other things, like ohmyzsh, etc. When I rebooted, I noticed that micro no longer had execute permission, so I went into my custom folder and tried to chmod +x, but nothing happened. I had another script in there which I edited with nano and saved just to make sure it was writing changes, which worked fine, but I still could not change it.


    I saw something mentioned about using a user script to do things, as trying to set +x from config/go didn't work, so just to test I created a user script and tried to set +x on micro from there, but still nothing. I am running out of ideas here, unfortunately. It seems that some of the other things I did have worked, such as symlinking the ohmyzsh folder, .zshenv file, (which then specified ZDOTROOT, etc), to the root directory, but I still can't run Micro. Does anyone have any recommendations?




Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...