MacOS BigSur VM stuck on login screen background with gpu


7 posts in this topic Last Reply

Recommended Posts

So i installed bigsur and it works as it should, with vnc. When i add my quadro K600, which should be supported, it boots until i come to the login screen but i only can see the background and nothing else... nothing to actually login... keyboard works on boot...

 

any idea what the problem is?

Link to post

Are you following dortania instructions?

https://dortania.github.io/GPU-Buyers-Guide/modern-gpus/nvidia-gpu.html#kepler-series-gtx-6xx-7xx

 

Try to add in your config.plist, boot args:

shikigva=40 shiki-id=Mac-27ADBB7B4CEE8E61

 

Append them if you have others, follows example:

 

	<key>NVRAM</key>
	<dict>
		<key>Add</key>
		<dict>
			.......
			.......

			<key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
			<dict>
				.......
				.......

				<key>boot-args</key>
				<string>shikigva=40 shiki-id=Mac-27ADBB7B4CEE8E61</string>

 

Link to post
25 minutes ago, ghost82 said:

Are you following dortania instructions?

https://dortania.github.io/GPU-Buyers-Guide/modern-gpus/nvidia-gpu.html#kepler-series-gtx-6xx-7xx

 

Try to add in your config.plist, boot args:


shikigva=40 shiki-id=Mac-27ADBB7B4CEE8E61

 

Append them if you have others, follows example:

 


	<key>NVRAM</key>
	<dict>
		<key>Add</key>
		<dict>
			.......
			.......

			<key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
			<dict>
				.......
				.......

				<key>boot-args</key>
				<string>shikigva=40 shiki-id=Mac-27ADBB7B4CEE8E61</string>

 

 MacOS already thinks its a macpro 15.1, should i switch that to a imac 14.2?

Link to post
6 hours ago, architektur23 said:

did a fresh install and the mac as an imac 14.2 and it works great with the quadro k600! thanks!

now i have to figure out how to get rid of that boot screen at the start, so it boots right away...

 

Sorry for the delay. I never played with shiki but I think you don't need to spoof the whole vm to imac 14,2: shiki-id should spoof to imac 14,2 only for the gpu.

Anyway, if it works and you are satisfied, it's ok.

what boot screen are you referring?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.