Can Unraid Support ESXi VMDK disks when running in a VM?

4 posts in this topic Last Reply

Recommended Posts

Lots of great Howto's on how to run Unraid as a VM in ESXi, but they all seem to be based on passing through an HBA card to the VM. My use case is to build a small Unraid VM on my ESXi server to use for testing purposes only.  (My Production Unraid host is a a dedicated server). For that, I just want to use ESXi storage from my datastore rather than put an HBA card in with its own disks.. 


I set up a vm with a few virtual disks based on Ubuntu32 and used PlopKexec to boot off the USB stick I had passed through in vmware. Everything boots up fine, but when I login into the Unraid UI and look at the MAIN page none of the virtual disks I provisioned in Esxi appear as devices to Unraid..


I've tried using different SCSI controllers like LSI SAS, Vmware Paravirtual, Buslogic etc as the emulation in ESXi but no joy. Also tried adding disks as SCSI thick provisioned as well as IDE but same result. Also tried changing the disk type from 'dependent' to 'indepedent' but that didnt have any effect or the VM didnt boot.  I reduced the disks down to just 1 disk just to see if that made any difference as well.. it didn't.. And just for good measure, tried also to play about with the SCSI bus sharing options between physical, virtual and none.. but no joy there either..


I must be missing something obvious here.. Any help appreciated.. 




Edited by jagz707
omitted text
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.