Jump to content
We're Hiring! Full Stack Developer ×

Change docker allocations on custom bridged network


Recommended Posts

TLDR: Cannot get the port customizations to stick on Jellyfin container despite no conflicts with IPs or ports.


Version is 6.9.2, installed a couple days ago.

I've opted to omit the syslog as this seems like a very specific issue and I have no errors reported anywhere at all (other than a Legacy PCI stubbing error from FixCommonProblems, which is in use due to annoyances with my IOMMU groups).

No overclocking of any sort, no real hardware modifications to speak of.

It does work properly with a default install of the container as well.


Starting the issue discussion with relevant hardware, I have a quad SFP+ NIC of which two ports are being used by Unraid.


The first one, eth0, is dedicated to Unraid with a single docker set to use bridged mode (the SpaceInvaderOne custom icons one). Bridging and teaming is disabled for eth0.

The second, eth4, has teaming disabled but bridging is enabled. I have it shared between VMs (DHCP) and docker (static IPs).
Jellyfin is using a static IP with no conflicts on IPs or ports (the static IP is outside the DHCP range and has been validated as unused previously), and I did have Jellyfin working on the default ports.

Since I am giving Jellyfin a dedicated IP, I would like to be able to use port 80/443 for hosting it, but docker would rather give me the finger, as nothing I've done has impacted this one bit.

I will say that if I swap the networking to bridged (which defaults to eth0 for some reason even though bridging is disabled on it), then I can, indeed change the port (it shows up under docker Allocations) though this would probably break my link to Unraid itself. Once I swap the network adapter back to br4, the ports go right back to where they were.

 


Using br4, the allocations read as follows:
jellyfin     br4     0.0.0.0     8096, 8920

 

Swap to bridged:
jellyfin     bridge     10.10.10.10     80, 443, 1900

 


Updating the container settings does nothing in template authoring mode, nor does it seem to give me access to anything relevant to the issue. Even editing the system.xml and network.xml files in /appdata/jellyfin has no impact, and rebooting the server didn't help.


Any input would be appreciated, as this is severely annoying and doesn't make any sense to me. Thanks!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...