Jump to content

Red X, disabled drive alert


Recommended Posts

Hello! I recently got an alert that one of my dives was disabled. My server was relocated not long ago, so I'm hoping something simply got jostled loose. The connections appear okay, but I re-seated them anyway. My search of the forums has not brought up anything quite fitting my setup, and all links to unraid troubleshooting appear to be dead, I guess there were some pretty major changes to the website.

 

I have attached my diagnostics for the drive from before I rebooted. I haven't done anything since re-checking the connections, as I wasn't sure if there was something more I should do before attempting to rebuild the drive. Thanks for any insight!

ST4000DM004-2CV104_ZFN02B9J-20210901-1752 disk8 (sdi) - DISK_DSBL.txt

ST4000DM004-2CV104_ZFN02B9J-20210901-1752 disk8 (sdi) - DISK_DSBL.txt

Link to comment

It will take several hours to do an extended test on 4TB. You should disable spindown on that disk or the test might get interrupted.

 

Looks like you were about 1:39 into your monthly parity check when disk8 started to get read errors, so Unraid tried to write the emulated data back to the disk to fix it and when that write failed it disabled the disk.

 

10 minutes ago, ReverendDan said:

I have since rebooted

Thank you for getting the diagnostics before reboot.

 

22 minutes ago, ReverendDan said:

My search of the forums has not brought up anything quite fitting my setup

I didn't notice anything unusual about your setup. Can you elaborate?

  • Like 1
Link to comment

I was following some instructions to remove and re-add the drive to have the parity rebuild the drive when I realized that I had done nothing to ensure the integrity of the drive. And rather than risk making things worse, I decided to stop and ask for help.  Better late than never, but I probably should have asked sooner.  Sorry to make things more difficult.  I appreciate the help!

Link to comment

Just wondered if you had mounted it as an Unassigned Device. If you mount it read/write instead of read-only, it would be slightly out-of-sync with parity.

 

Ordinarily, a disk gets disabled when a write to it fails, and since the failed write updates parity so that write can be recovered, the disabled disk is out-of-sync.

 

But in this case it looks like a failed read during parity check caused a writeback to the disk, so it may not be out-of-sync or even need rebuilding.

 

Do you think there is any possibility that anything tried to write to the disk since the parity check began? If anything wrote to the emulated disk then the physical disk is out-of-sync and has to be rebuilt.

  • Like 1
Link to comment
1 minute ago, ReverendDan said:

Perhaps I should replace the drive with a larger one anyway.

Rebuilding to a replacement is always the safest approach since it keeps the original in case there are any problems rebuilding. Often people won't want to buy a replacement though so they rebuild to the same disk.

 

2 minutes ago, ReverendDan said:

I could run some preclears on this drive after the fact to test it. 

You should definitely not preclear the original until you are satisfied with the replacement/rebuild.

 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...