Jump to content



Recommended Posts



I'm wondering if someone could lend a hand.  I'm currently running Unraid 6.9.2, and the Docker Service has failed to start.  I was rebooting my server and got a power surge while the system was powering down.  When the server came back up the Raid had to be rebuilt.  Afterwards the some of the applications in the docker were not working correctly.  For example Plex wouldn't load all folders to the library.  After deleting Plex and trying to re-add it to the docker.  The docker just quit all together.  That was about a week ago.


I've read through a few of the forums, and I've attempted the move of the data on the cache to the raid by using the mover, then the stopping of the Docker via ENABLE DOCKER then deleting the docker.img, changing the Docker vDisk location.  After the move of the shares back to the cache and the DOCKER location change or change back to what the location was before the delete.  I still have not had any luck.  I have  even tried  getting into the terminal and trying to start services that way.  with /etc/rc.d/rc.docker start.  I receive the "no image mounted at /var/lib/docker when I try to start it via terminal.  I've attached screenshots and a diagnostic to this particular post for reference.   I'm not super savvy with this unraid build up so I might ask a few dumb questions. 




Link to comment

Thanks for the help.   I ran the "Checking and fixing drives in the webGui" and the "Running xfs_repair" sections from the link you sent me.

The drive is still shows up as disabled.  Does this mean that I'm not able run my docker because of one disk being disabled?  Should I just remove that one disk from the array?


I've also attached the final results of the disk checks, xfs_repair, current docker settings, and diagnostics.  

Could you please let me know how to proceed?


Docker Settings.PNG


Docker Fail.PNG

tower-diagnostics-20210926-0604.zip disk5 CHECK v.txt disk5 CHECK nv.txt

Link to comment

Let's swing back to the disks in a bit.  What about this?


Sep 25 20:51:04 Tower root: Fix Common Problems: Warning: Deprecated plugin serverlayout.plg
Sep 25 20:51:06 Tower root: Fix Common Problems: Error: Possible Hack Attempt on Sep 25
Sep 25 20:51:11 Tower root: Fix Common Problems: Other Warning: Unassigned Devices Plus not installed
Sep 25 20:51:11 Tower root: Fix Common Problems: Warning: Setting up of authorized keys possibly found in go file
Sep 25 20:51:11 Tower root: Fix Common Problems: Warning: Possible mining software being installed in go file


In particular, the last 2 items are extremely worrisome.  Your go file is a mess, is indeed hiding xmrig and is not something you would have put there your self.  Return it to default

# Start the Management Utility
/usr/local/sbin/emhttp &

and also remove any port forwarding to the webUI itself (except for MyServers if you're using it), give yourself a nice root password and if you've done it, remove the server from your router's DMZ.

Link to comment

I'm a novice at this stuff.  So you're saying to add the !/bin/bash command into the Terminal?  I know this a script.  That's about it.

I just read a similar post where you told someone to add the /usr/local/sbin/emhttp & on the flash drive.  Is that the next step I should be taking?


My server isn't  sitting in a DMZ, and port forwarding (PLEX) was disabled on the modem about 6 - 8 weeks ago.  I initially did not have a root password, but have since added a strong one to root about a month ago.  I now see that I have several login failures to my server.  


I've also used the terminal to try to find the xmrig mining software that is might be running.  I've attached photos again.

I didn't see anything about a xmrig in that folder of the mining software.


Thanks again for your time and patience.




Login Attempts.PNG

Management Access.PNG

Lost idiot.PNG

Link to comment

Community Developer


Posted 20 minutes ago

Edit /config/go on the flash drive (Notepad is fine) and change the contents to what I put in there and reboot.


But you also have to investigate why it got changed in the first place (probably due to you basically opening up the server to the internet with little to no security)


Okay I've found the file.  You're right.  There is a lot of crap running I don't' know about  including a mining software set to use 25% of my CPU.  I've adjusted accordingly and locked down my firewall.  I now see a lot of denies from public IPs trying to use SSH, and Telnet to enter my server private IP in the logs of my firewall.  


Now that I have this file.  I would assume that I erase all go File.txtthat is under the /usr/local/sbin/emhttp &.  Would that be correct? 

My question is how do I go about deleting the information and adding it back into the flash?  Am I supposed to run this script in a particular location?



Link to comment

go (2).txt


I found this older post from you and erased the unneeded data from the go file.  The new go file is attached. 


After the reboot the Docker status is NOW RUNNING!!!!   Thanks for your help Squid.  

Is there any additional measures you think I should take with this server?  I've locked down my firewall as much as possible.

Any advice on this disabled drive?  


Thanks again for all of your help


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...