Jump to content

6.9.2 Plex and playing movies buffering,..


Recommended Posts

Hi all, Not sure if this is the right place to ask the question, so mods feel free to move it to the correct page.


I have a stable working Unraid build (Gigabyte Technology Co., Ltd. X79-UP4, Intel® Core™ i7-4930K CPU @ 3.40GHz, 32 GB Ram DDR3, NVIDIA GeForce GTX 1060 3GB  PCIe Gen (Max): 1 (3)  Lanes (Max): 8 (16)).

And am mainly using my unraid for Nextcloud and as a Plex Media Server.  

All dockers and apps are updated to the latest version. I am using Plex inc's own Docker and using the GPU to trancode movies if neccessary, but as I am on the same (internal) network, I don't really need to transcode - or so I thought.


I have had issues with movieplayback for some time (buffering being the major issue). So I moved from an old NAS to Unraid, as I thought that was the issue, but it wasn't, I changed from the Popcorn Hour C200 (and 300) to PS3 and Raspberri Pi and am now using a PS4 that I have on loan for testing.  In the meantime, I thought it might be down to the network or the cables, so I changed all cat5e to new cat5e cables and went from ASUS network (AC5300, 2 AC68u and AC86u) to a Unifi UDM Pro SE with all unifi devices.  I moved my unraid server and UDM to the same room where I am playing the movies and connected them directly, and usually this works pretty well and we can watch a movie without buffering, but I am still sometimes getting buffering issues.


Like yesterday, I wanted to watch a 4k movie (77.9 Mb/s), which was buffering, so since I have the trancode function set up, using the GPU, I wanted to test for transcode at 1080p, 20 Mb/s, still buffering issues. (On the PS4, wired with Ethernet cable) I also tried transcoding at 10 Mb/s, but that didn't work either.  Because I was affraid of these issues, I already ripped the movie to 1080p at 3.6 Mb/s using a program on my computer and put that in the Plex library  too, surely that should play fine? It didn't, it was buffering every +- 20  seconds or so. Very annoying!

I remembered that Unraid was performing a parity check, so I stopped the parity check, but that didn't seem to make any difference (but in stopping the parity, I did see that the GPU was working and Plex showed as an app, so that was good).  Pausing the movie and waiting for some time, did seem to work a little and the buffering issues only came back after a few minutes of playback.  As a test, I stopped the movie on the PS4 and went on the Raspberry Pi 4, which is also wired. First tried the 4k movie but that didn't even want to get going, so I tried the other version at 3.6 Mb/s), but that was even worse as the PS4.


Maybe irrelevant, but my movie share is set to Use cache pool : Yes. But not sure the limiting factor is the HDD speed. My cache is an SSD (non M.2, as my Mobo isn't supporting that).


So, I clearly have tried about everything I can think of to make the movies play smoothly and was even looking at buying the PS5, which luckily is sold out everywhere, as I am not convinced now that playback will be smooth...

When I play movies from my Plex when we are visiting friends through their network on for example the Raspberry Pi 4, it usually runs smoothly, even on the Google TV/Chromecast TV 4k on Wifi.  I assume this is because I set the upload speed of external devices to 8 Mb/s?


My questions are - 

1. Anything I am missing or what I haven't thought of yet?

2. Any settings I should change to make it run smoothly?

3. Which movieplayers are you using for smooth playback of movies?

4. Since my unraid build is in the same room, I wonder if making a VM or something on the unraid and connecting that directly to my amp/projector would be possible? So essentially using the moviescreen as my screen of WIN and playing through the GPU of the unraid? Or is that not possible?


When playing the 4k movie on my desktop (it seems to not buffer), the load on the GPU is :




CPU load



Sorry for the loads of text, but wanted to paint a picture which has everything I tried and my setup...

I also attached my diagnostics. If it helps, the movie was playing from about 20.30 last night until around 23h. And now (from 10.30 on the 4k version on my desktop, that is without issues).


Any help is immensely appreciated!


Link to comment

Can't you use Direct Streaming? If the Playstation 4 is capable of playing 4K directly then it shouldn't need to transcode. I have 4 AppleTv's in my house and I use direct streaming so their is no need to Transcode anything. 


I don't use 4K since most of my content is ripped to 1080p so I can't truly comment on 4k content. 

Link to comment

Hi Kizer, thanks a lot for your message.  I did try to play 4k directly, but it is buffering every few seconds then... As stated in the original post, the stream is 77,9Mbps for the movie.

I usually play 1080p, as most of my content is in 1080p anyway.  My amp is an PIONEER SUSANO SC-LX90, which I bought when it first came out, it is amazing, but only plays up to 1080p. Since I can see the playback just fine (except for the buffering issues), I know it is not that (wouldn't make sense that my amp would make the PS4 buffer, right?).


But even when transcoded to 20 Mbps, it won't run it, not even a ripped version of the same movie, at 1080p, 3,6Mbps.

I am wondering if I can use the unraid build in a VM (or something) to play the movies? If not, Can I buy for example a Nvidia Shield Pro? Or should I just ditch Unraid altogether and move to Synology for example?  I am at my witt's end why it can't playback files. 4k is clearly the future, so if I would change my setup, I want to make sure I can actually play 4k content..


Thanks for your reply, any help is greatly appreciated!


Link to comment
  • 1 month later...

In the meantime, I have bought an Nvidia Shield Tv Pro, which seems to do the job. Only at the very end of a 4k movie (@77.9Mbps), the buffering issues began.  Still not sure why I am having these issues, but happy it is not on every movie right now (although I haven't had much time to test lately).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...