Jump to content

[Help] Cache Drive Error

Go to solution Solved by JorgeB,

Recommended Posts

Hi everyone,


I had 2 cache drives and had a cache drive fail the other day. I took it out and added a new 500GB SATA 3 drive and now it's looking like this:




But now I'm seeing an error in my other previous SSD:




I ran a Smart Extended Test and it said everything was OK (log attached) but looking at the Attributes section I think I saw something worrying:




The thing is, I have no idea what this means.


So I guess my questions are:

  1. What is this?
  2. How do I fix this/What should I do?


Could anybody help me, please? Thank you so much.



More context below:


I was using two cache pools:


  • One 500GB NVMe SSD for Appdata and the Docker image. This would use the cache only (I'll call it Appdata Cache).
  • One 1TB Sata III SSD for storing data from qBitorrent and some other stuff. This would be written to cache and later moved to the array when it was full or close to full (I'll call it Data Cache)


The idea was to have the docker image and the appdata in the faster drive - the Appdata Cache - and for the qBitorrent stuff I would use a different ssd for cache which would be moved to the array later.


I also had the CA Backup plugin making backups to the array everyday.


I was having some critical temperature warnings in my Appdata Cache - the nvme ssd - and eventually it had some sort of error. Stupid as I was, I didn't save any logs and rebooted the system.


After getting nowhere trying to detect what it could be, I stopped the array, shut the system down, took out the nvme disk and added one 500gb sata ssd I had laying around. Upon rebooting I eliminated the Appdata Cache Pool and stuck to only 1 pool, the Data Cache pool, with two diferent sized Sata III SSDs (1TB and 500GB).


I moved the Docker image path to the Data Cache Directory and ran the CA Backup Restore. Rebooted the Device and reinstalled the previously installed apps.


This last part seemingly worked well and I retrieved almost everything, with exception of Nextcloud which now shows an internal error (likely some sort of database issue, I don't know I haven't looked into it yet) and Immich which was essentially reset.


Now I noticed this in the pictures above.



Link to comment
32 minutes ago, AGuyInTheWrongRoom said:

Should I be at all worried with #1 Raw Read Error Rate which has a mention of pre-fail under type?

Negative, that's just the attribute type.


33 minutes ago, AGuyInTheWrongRoom said:

Also, shouldn't my Datacache pool have more space than just 750GB?

It doesn't have 750GB, default is raid1 (mirror) so it can only mirror the smallest drive, look at the used and free space, if you want to use the full capacity you can convert the pool to single profile, but will lose the redundancy.


  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...