Jump to content

Cache drive failure - what to do?

Go to solution Solved by JorgeB,

Recommended Posts

Saw a bunch of 'BTRFS error' today, mostly "BTRFS warning (device nvme1n1p1): direct IO failed ino 189208 rw 0,0 sector 0x443da678 len 4096 err no 10". Not sure why but seemed like the drive disconnected randomly. 


Tried rebooting the server and my 'nvme0n1' drive in my cache pool was shown as 'Missing', NOT the nvme1n1 I saw all the errors for. Rebooted into the BIOS, drive was detected okay, showed no errors, booted back into Unraid and it was showing again, and no smart errors.


Started array in maintenance mode and ran a Check Filesystem Status and had pages and pages of



At this point I don't know if I can trust either drive. Any advice would be appreciated for how to resolve this. Scared to start the array and make a backup of everything in case it screws up the data on there. **In theory** it should all be backed up already, but I'd rather not need to put that to the test...


Should I even trust this device again? Or jusbrave_2tQDWtWUCJ.thumb.png.7cb1cd02040b87876e508b70c7b2b5cb.pngt RMA and get a new one, or both?


Thanks in advance


Edited by zipt
fixing details
Link to comment
  • Solution

Device dropped offline, this is usually not a device problem, try this, on the main GUI page click on the flash drive, scroll down to "Syslinux Configuration", make sure it's set to "menu view" (top right) and add this to your default boot option, after "append initrd=/bzroot"

nvme_core.default_ps_max_latency_us=0 pcie_aspm=off


append initrd=/bzroot nvme_core.default_ps_max_latency_us=0 pcie_aspm=off

Reboot and see if it makes a difference.

Link to comment

@JorgeB Thanks for the helpful advice, really appreciate it.


I've added that in, but I'm not sure that would be the cause. It's been running fine for almost a year now so I'd be surprised if that was the issue, but I guess I'll see how it goes


I've started the array and everything seems to be working correctly. Figured I'd run a scrub as well for good measure but looks okay

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...