Jump to content

Reallocated sector | disabled cache drive

Go to solution Solved by JorgeB,

Recommended Posts

So this morning I got this error: Unraid Skynetcache disk SMART health [5] Warning [SKYNET] - reallocated sector ct is 24. Fast forward a couple hours and I get this: fstrim: /mnt/skynetcache: FITRIM ioctl failed: Input/output error.


I logged in and noticed my drive dropped offline, but I can’t figure out why. I’ve uploaded my diagnostics too. 

it’s worth mentioning I’ve also been having intermittent issues with my /mnt/mediacache drive falling offline too. 


Link to comment

skynetcache1 dropped offline:


May 25 04:26:47 Skynet kernel: ata1: hard resetting link
May 25 04:26:52 Skynet kernel: ata1: softreset failed (device not ready)
May 25 04:26:52 Skynet kernel: ata1: reset failed, giving up
May 25 04:26:52 Skynet kernel: ata1.00: disable device
May 25 04:26:52 Skynet kernel: ata1: EH complete


Because it dropped there's no SMART, but this is usually a power/connection problem, check/replace cables and run a correcting scrub.

Link to comment

So I rebooted, tried several cables, data and power, tried different data ports and the reallocated sector count just kept climbing, and then a udma error started popping up. I swapped this with another ssd in the machine, and it still had issues while the other ssd was fine, so I think it’s safe to assume it’s the drive failing. 

I pulled the drive from the pool and am running the pool with one drive. If I stop and add a new ssd (240gb vs the current 256gb) can I just start it and do a scrub? 

Link to comment
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...