Jump to content

Problem creating ZFS mirror cache

Go to solution Solved by JorgeB,

Recommended Posts

I have looked at space invaders tutorial and believe I followed that quite well - I did the following steps - create a new cache pool (name cache, zfs, mirror, two devices) and assigning two empty (no filesystem) disks.


When I start the array the disks are expectedly shown as unmountable. I  specify that I want to format unmountable array disks but this does NOT result in them getting partitioned/formatted instead it finished more or less immediately with no error message and the disks still "unmountable".


I can add that I previously have had a BTRFS cache pool working perfectly on the same hardware and that I have a non-cache ZFS pool that was created without any issues. The hardware have worked perfectly up to now so I think the risk of hardware problems is very low (recently did extensive RAM test when motherboard was new, server have ECC memory etc).



What am I missing?  


Edited by NAS-newbie
Link to comment

Mine reads "1 group of two devices" and this is ok right?


I can actually mention that about a week or so ago I managed to create a ZFS cache pool (I tried several things then also before it worked like first formating the disks for ZFS before adding them, leaving them empty etc.) so not sure how I did it to finally succeed but then I used "default settings" and was burned by same thing as customer in the referenced thread i.e. I got RAID0 (not a good default) and that was the reason I had to recreate the pool again (after all the usual steps to empty it etc) but now it does not work again and with these correct settings I can again figure out how to make it work.... 

Edited by NAS-newbie
Link to comment
  • Solution
21 minutes ago, NAS-newbie said:

now it does not work again and with these correct settings I can again figure out how to make it work.... 

If you read the thread the problem happens if you select the filesystem/pool type before assigning the devices, start over and chose the fs/pool type only after assigning the devices.

  • Like 1
Link to comment

Sorry missed that "root cause" and yes it was indeed the problem - must say it is really unexpected and odd that this makes a difference - I would even go so far as saying the other (non-working) order is the more intuitive than the one that work....
To avoid more users having this problem I would really try fixing this and please also change the default - at least for a cache pool and probably even in general on UnRAID I would guess an alternative with redundancy is by far the most likely the desired (and the one with the least "catastrophes" risk if selected by misstake). 

An odd thing I noticed that even with my RAID0 cache pool the shares placed on it (cache only) was shown as "green" (that I interpreted as "protected") even though they was in reality highly insecure to a single disk failure. Due to this I did not notice the problem until I realized that the size of the cache array was to large for using mirror...

Edited by NAS-newbie
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...