Jump to content

new motherboard, one nvme slot not showing in unraid

Recommended Posts

upgraded my cpu, motherboard, and ram, and added a few more nvme drives. 1st boot, my VM cache drive was missing, and logs showed errors similar to the ones in the attached logs. 


Attached Logs are from today and are after I swapped the vm cache with a new drive. new drive does not show in unraid, vm cache is now visible so it appears to be specific to that motherboard slot. The new drive and the vm cache both appeared in the bios in both positions and all 7 of my drives pass the bios quick smart test. 


3 of my drives are in the motherboard slots, 4 are in a asus hyper pcie card. I have a 2nd pcie card on the way so I'll pull the drive out of the slot that isn't working and put it in the pcie card when it arrives and all should be functional. 


Just wanted to see if anyone sees anything in the logs that I don't know how to interpret that could confirm a dead slot, or advise if I have missed something. 


2 of my motherboard slots share pcie lanes with some u.2 slots but there's not settings to turn off the u.2, and I assume that both slots would not work if this was the issue. Just odd that it shows up in the bios normally and unraid just isn't loading it in. 


Link to comment

Can't find any settings that disable the slot so i'm guessing it's a bad slot.


But. things have since gotten worse. now I can no longer get unraid to boot. most of the time I get to the unraid boot screen and it hangs on bzimage or bzroot. If I let it sit for 5-10 minutes it continues to either show a kernel panic, cannot mount fs error, or I just get a list of errors like the previous attachment. 


Have tried updating bios, tried a new flash drive with a backup, and new flash drive with fresh install of unraid. going to try removing all my pci devices and nvme drives to see if i can narrow down the issue to a device. 


little more context. new build is a 3975wx threadripper pro with 8x32gb 2666 ram, asus ws pro wrx80e sage.

Link to comment

I was starting to think that; tried removing different configs of ram and in different slots, reseated the cpu last night


Just narrowed it down to either 1 of 3 nvme drives or my hyper nvme card. 3rd slot on the motherboard still does not work but I'm back to being able to boot with those 4 removed. Now just trial and error to get each of my cache pools back up.


Actually starting to wonder if it's because I have a mix of gen3 and gen 4 drives on the hyper card. Just now realized I was mixing them so maybe it's seeing the gen4 and setting them all can causing the issue. going to test forcing gen3 for the whole slot for now. 

Link to comment

Hyper card with all 4 slots filled, mixed with gen3 and 4 with the motherboard forced to gen 3 and it's working. I don't need the extra speed but it is frustrating that this is what caused the headache. The hyper card has gen3/4 compatibility all over the marketing so I either have a bad card or my setup just doesn't play nice. 


Either way, it's running and I feel better about all the new hardware not being too bad. bummer about the 1 slot, but I don't know that it's worth the trouble of getting a rma. Guess I'll ask them and maybe they'll point out if i'm missing a setting somewhere to enable it. 


Thank you for the help @JorgeB!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...