Jump to content

repeating update problem & disconnections


Recommended Posts

Hi everybody,

As per Title i've got 2 problems that i'm gonna ask you help me for. 

 

TL;DR

1️⃣ Server is offline. Can't update without reinstalling from backup, it happened more than 1 time already, screen down below.  Can you help me? 

2️⃣ random disconnections, realtek interface but the problem didn't appear before (and i can't install the drivers now without the server online). Could be widespread on LAN. Could be connected with problem 1. I have no clue. Excluded tailscale and vpns from causes & MACVLAN not configured, docker is set IPVLAN. Help?

 

1) Repeating update problem:

Every time i update my server i can't access it afterwards no matter how much time i wait. The only way is to format the usb and copy all the contents from a previous backup back in, then it always -strangely- seems to be upgraded: version number is updated in the dashboard and everything works as expected ( the second problem may or may not be connected with this, read point 2 ).

But of course it's a pain to know that everytime it's the same story, and moreover my piKVM shows this, which seems... not fine: 

255265092_Screenshot2024-01-17alle14_35_30.thumb.jpg.360c999482321dbcfdb72249d3d0b9a3.jpg

The screen you see it's 20 minutes after the last -failed- update 6.12.4 to 6.12.6 and it's very similar -if not the same-  to what i've always seen after an always unsuccessful update. This happened since forever since my first unraid install ( 6.12.5 or .4)

- First and foremost: Correct way to get the server back up? Do i reinstall from backup as i always did or now it's the time to intervene?

- Is there a way -like in windows recovery- to tell the system to check for errors and autocorrect them OR a way to reinstall fresh without losing my 300+ hours spent last year in optimizations, configurations and automations?  i'd prefer to kill myself than have to configure recyclarr,radarr,tdarr and the two sonarr instances, + vpns and all dockers back. no way in hell i'm gonna do that.

Please PLEASE save my mental health guys, i know you can do that.

 

2) Recently i very often suffered from random disconnections, which seemed to disrupt other devices on the same network too ( it's on my grandparents network, they got the juicy FTTH ). They have a technicolor router and zyxel gpon interface which are buggy and shitty, but i verified that they worked no problems before my unraid server installation there.

I got a realtek interface and i've seen that in the changelog says that it may be the problem but:

  •  in the past worked without problems  ( i can't pinpoint when exactly the problem arose ) 
  •  in the past the problem solved itself ( well, i tinkered with the server a bit and seemed to have solved it then ) but then it arose again. It may be a router configuration problem since seems to be widespread on the LAN but i still kinda doubt it. There may be a lot of explanations on why the internet wasn't working, one of which was my misconfiguration of qbittorrent, one of course is because grandparents aren't trustworthy in the figuring-problem-regard and another one was that all the fiber apparatus may have gone nuts. A lot of reasons for a very generic problem with no easy way to diagnose it ( nor time, honestly ).

In the past i thought about vpn/tailscale problem but i excluded it having tested all the possibile configuration of those on/off in both my unraid server and pivkm subnet tailscale router. It can't be the macvlan problem too since i recently moved back to ipvlan with no success.

 

If you read all of it thanks you, truly, i know the second problem may be hard to diagnose but it really made the server unusable. 
Still the first problem is more urgent so i'll eagerly wait for your answers.

 

I'm not an english native speaker so forgive my errors or strange phrases and thanks you again for your time.

Edited by lory995
Link to comment

No idea what the 1st issue could be, never seen it before, you could try recreating the flash drive, backup the current one first and then redo it and just restore the bare minimum, like the key, super.dat and the pools folder for the assignments, also copy the docker user templates folder, if all works you can then reconfigure the server or try restoring a few config files at a time from the backup to see if you can find the culprit.

 

For the 2nd issue, enable the syslog server and post that after the problem, together with fresh diagnostics.

Link to comment
  • 3 weeks later...

TL:DR:
1st issue= didn't have the time
2nd issue=attachments as requested.  It happened 8 february 2024 at 4:47~4:48 pm. (in italian format: 08/02/2024 at 16:47 ~ 16:48 )

 

Hi Jorge, taking the server back online was low priority and it took me a long time but here i am now.

 

1st issue:

In regards of the first problem i described i simply did as usual without any long-term solution; in these first months of the year i don't have much time so if it was a relatively algorithmic solution process, meaning someone had a list of intructions for me to follow, i could have found the time but not an exploratory phase with the server offline.

 

2nd issue:

As described in TLDR, but i'm gonna add that looking at the syslog i've noted something regarding the connection at ~16:23 but i don't know what happened at that time.

Other information are:

- It happens almost always at least a couple of times when i try to stream content from plex/jellyfin. Nowadays i've found other way to consume content because it's unbearable.

- It happens on his own too. while i'm not using the server.

- My server is not local, but i connect trough tailscale over internet as stated in the first post.

   - For this reason i didn't yet try to update the realtek drivers. 

     my NIC as per system devices:

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

- when the problem arises, if i try to connect to the dashboard via browser it doesn't say "can't connect" or something but it seems like the server "answers" but does not load the webpage. ( it's the same for all the other addresses on the subnet ).  

 

Thanks you again for your time, hope to hear good news soon. 
 

 

 

 

unraid-syslog-20240208-1615.zip unraid-diagnostics-20240208-1653.zip

Edited by lory995
Link to comment
5 minutes ago, lory995 said:
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI

There shouldn't be any issues with this NIC, issue is only with the 8125, though Realtek Linux drivers are never great, you can try installing the Realtek driver plugin to see if there's any difference, the NIC is losing the link multiple times:

 

Feb  8 16:22:18 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Down
...
Feb  8 16:22:32 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Up - 1Gbps/Full - flow control off
...
Feb  8 16:22:51 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Down
...
Feb  8 16:23:10 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Up - 1Gbps/Full - flow control off
...
Feb  8 16:23:16 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Down
...
Feb  8 16:23:20 Unraid kernel: r8169 0000:22:00.0 eth0: Link is Up - 1Gbps/Full - flow control off


If the driver doesn't help, and I doubt it will, it can be an issue with the NIC, switch, cable, etc

Link to comment

Thank you for your answer jorge, but as i've written above that's not the time when i had the problem and strangely enough when i have it nothing shows up in syslog. To confirm i've kept using the server until the problem showed up again and again and, in fact, nothing showed up in syslog ever. 

I've installed the drivers anyway and it seems to work better now? i don't know may be placebo. 

Anyway since the problem seems so large and no one can give me any direction i'll tinker on my own and i'll post if i'll have updates.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...