Jump to content

(6.12.6) New to Unraid. How to transfer my 4TB plex library to array? (Solved)

Go to solution Solved by trurl,

Recommended Posts

Hi all,

I am very new to Unraid. I have watched a few videos and have read most of the documentation, however I could not find information on the best practices of transferring files from somewhere to the array.


My setup:

Unraid OS on a Beelink S12 pro with DAS (Orico 4-bay) connected through USB 3.0 with 2 exo16 16TB hdd in it. (1 will be parity, the other 1 array)

My files are in another 4TB external hdd enclosure, also USB 3.0. 

I have tried transferring over the network (windows pc with files on WIFI) using a share created for my files just to test it out. Transferring speed of 1 file is around 5MB/s. 


Then I came here to search for help, also google, but could not find any definitive solution and finally decided to ask my own question. What would be the fastest way of doing this? Can I mount this 4tb external hdd into my Orico bay and use it temporarily to transfer the files to my array? If I connect my windows pc by ethernet, would the speed improve? Can I connect my 4tb external hdd to my beelink and use its windows OS to transfer the files to the unraid folders?

Edit with solution: unassigned devices solved my issue with speed by mounting it and transferring while connected to my mini-pc on another USB port.

Edited by Kauemacedo
Link to comment
  • Kauemacedo changed the title to (6.12.6) New to Unraid. How to transfer my 4TB plex library to array?
28 minutes ago, trurl said:

However, USB not recommended for array or pools for many reasons.


Thanks for the recommendation of the plugin, I will take a look into it. 

Is there any other way of configuring Unraid with my setup (I really wanted to use this OS)? If USB is a bad idea, would it be better to just use Linux (like Ubuntu) instead, considering my mini-pc + das configuration? 

Link to comment
  • Kauemacedo changed the title to (6.12.6) New to Unraid. How to transfer my 4TB plex library to array? (Solved)

Some implementions of USB->SATA/SAS may not give

  • consistent or unique disk identifiers, making it impossible for Unraid to keep track of disk assignments (or even assign a disk).
  • SMART reports, making it impossible for Unraid to track disk health
  • standard disk size, so a disk you want to use as parity might appear to be smaller than another array disk, and so can't be used as parity.

each of these can also make it difficult to migrate the disks to other hardware with Unraid.


Also, parity operations require accessing all disks simultaneously. If all the disks share a single connection then it might not perform well.


And, USB may disconnect, which will make the disk inaccessible, causing Unraid to disable it since it becomes out-of-sync with the array. This will require rebuilding the disk to make it in sync again. Might even be a frequent occurrence.


One way to avoid the disconnect problem is to not have a parity disk, since there is nothing for the disk to be in sync with, so no need to rebuild. Of course, also no way to rebuild.


Some don't experience these problems, but we don't get to hear much about those.


One thing that can help avoid some of these problems is to only use enclosures that support UASP.


If you post your diagnostics we might be able to tell if your setup has some of these problems.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...