Jump to content

Server locks up when trying to start array

Go to solution Solved by JorgeB,

Recommended Posts

So recently my NVME SSDs started droping off line I was able to move most of my appdata off of it just fine and now that I have rebuilt my docker containers and now after a reboot it wont start the array.  After many reboots and testing things it shill wont mount.  I'm out of ideas.  Here is the diag file, I was not able to make one after a reboot if it tried to auto start.  I was able to boot into safe mode and make one.


Link to comment
  • Solution

Zfs pool is crashing, see if it mounts in read only mode:


zpool import -o readonly=on newcache


If successful you can then start the array, the GUI will still show the pool unmountable, but the data will be under /mnt/newcache, you can then try to backup anything important and then reformat the pool.

  • Thanks 1
Link to comment

I got the array started.  I have backed up the data, and its doing a parity check.  It will take about a day and a half to complete.  After its done I'll remove the zfs pool since there is ether something wrong with my drives or the motherboard, like I said all 3 would just drop off randomly. Thank you so much for the help! I was at my wits end.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...