Jump to content
We're Hiring! Full Stack Developer ×

Server is restarting every day. (SOLVED)


Recommended Posts

My first Unraid build and having some issues.  My server restarts every day.  This is causing parity to run constantly.  I built this server to host my Plex client and it looks like that may be the issue.  It was restarting in the middle of the night around 3am.  I noticed that Plex was running system tasks at 2am.  I changed the times in Plex to 11am and got a server shutdown a little after 12pm.  The server restarts on its own but goes right to doing a parity check since it was a bad shutdown.  What is causing this?  I ran this hardware for 3 years zero issue in a win 10 system as a server.  

 

Jan 21 12:04:45 Doghouse sshd[1823]: Received signal 15; terminating. 

 

I have seen this in my system log a few times.

doghouse-syslog-20240122-0127.zip

Edited by Peso_washers
problem solved
Link to comment

The server restarting by itself is nearly always hardware related with most likely culprits being thermal (e,g. CPU overheating) or PSU struggling.

 

The syslog in the diagnostics is the RAM copy and only shows what happened since the reboot.   It could be worth enabling the syslog server to get a log that survives a reboot so we can see what happened prior to the reboot. The mirror to flash option is the easiest to set up, but if you are worried about excessive wear on the flash drive you can put your server’s address into the Remote Server field.

Link to comment

It's the syslog-previous that comes with the diags, assuming the server crashed on the previous boot, if that was the case, unfortunately there's nothing relevant logged, this usually points to a hardware issue, one thing you can try is to boot the server in safe mode with all docker/VMs disabled, let it run as a basic NAS for a few days, if it still crashes it's likely a hardware problem, if it doesn't start turning on the other services one by one.

Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • Peso_washers changed the title to Server is restarting every day. (SOLVED)

I am having a similar issue with my 2 recent identical hardware builds.  Which makes me think this is a container issue, not a hardware issue. I can fire up all my containers and once I fire up Plex my Unraid gui freezes and I have to hard reset my computers. I have deleted and rebuilt the docker image on both systems. My next step is to add the plex app back.   I have emby running on my secondary system with no issues.....yet (fingers crossed). I have been a plex user for 10+ years it's tough to walk away.  

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...