Jump to content

Appdata not a dataset even though it's on a ZFS cache pool drive

Go to solution Solved by JorgeB,

Recommended Posts


So I had some issues with my chache drive (single ZFS cache pool) which resulted in having moved all items (specifically appdata and system) to the array, then erasing reformatting the cache drive to ZFS (it was in this format already).

I then moved all the files (mainly appdata and system) back to the ZFS Cache drive.


After installing the ZFS Master plugin, I cannot take snapshots of the appdata and system data, as it's stating these are not datasets.

When running the user script from SpaceInvader the error also confirms this:

Error: cache/appdata this location exists, but it's not a ZFS dataset. Please select a dataset not a folder as the source


From doing as much research as possible, I believe this has happened because I used the unbalance app to move the data to the drive, which apparently doesn't create data sets.


So I guess an option would be to move all the folders to the array, but using the CAMover and then back to the cache drive again? Would I need to erase it in between?

Alternatively, I do get an option, (might be because I enabled destructrive mode for ZFS Master) when clicking on Actions for Appdata and System > Convert to Dataset.

Would that work or should I try the CA Mover, or any other suggestions?

Many thanks



Link to comment
  • 1 month later...
On 3/1/2024 at 12:22 PM, JorgeB said:

That won't create a dataset, it would have if you had used the mover for example, like you mentioned the plugin can convert it to a dataset for you, or use the mover to move to the array, then back to cache.

Thanks. I ended up just using mover, which worked. Apologies for the late reply

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...