How To Determine NIC Speed


11 posts in this topic Last Reply

Recommended Posts

Hey All,

 

How do I determine what my NIC on my NAS machine is connected to my router at speed wise?  It should be 1 GB but each computer seems to max out at 100MB even though the windows Machines say they are connected to my router at 1 GB.

 

Thanks!

Link to post

Hey All,

 

How do I determine what my NIC on my NAS machine is connected to my router at speed wise?  It should be 1 GB but each computer seems to max out at 100MB even though the windows Machines say they are connected to my router at 1 GB.

 

Thanks!

If it isunRAID you are referring to as your NAS, type

ethtool eth0

Link to post

The only way I know is to look up the manufacturer's specification for the hardware and compare with the specification for the drivers supplied with the Operating System.

Using manufacture-specific unix commands you can find out the current configuration (if there is one) of each Ethernet card but not the full capabilities.

Link to post

Thanks Joe.  That did the trick.

 

Oddly it says I am connected at 1GB which is odd since I can't seem to get past 100MB while copying to the machine.

 

Are you confusing Gigabit (Gb) for Gigabyte (GB)?  1 Gigabit is equal to 128 Megabytes.  Routers and switches measure transfers in bits and not bytes, I assume that you have a Gigabit NIC and Router/Switch.  With a gigabit NIC I would expect to see about 100 MB/s.

Link to post
  • 8 years later...

I just had a look at this and I am not sure how to read it, as when I do data tranfers I am only getting wound 10mb/s on a 1GB card.

so can someone please inform me if my card is set to 1GB and if not then how to set it. as I have a 1GB network and it would be nice to send data the Max speed.

 

Settings for eth0:
        Supported ports: [ TP AUI BNC MII FIBRE ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
                                             1000baseT/Half 1000baseT/Full 
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

 

Link to post
17 minutes ago, chris_netsmart said:

        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 

This shows the supported speeds, including gigabit.

 

18 minutes ago, chris_netsmart said:

Speed: 100Mb/s

But this shows it's only linking at 100Mbits, try a different cable or switch/port.

 

Link to post

the cable I am using is Cat6 and the switch is a Netgear GS108 and it is plug into the 6th port.

looking it at it only has one light. so I have moved it to a different port and this also gives me one light, so it looks like a drive / nic settings issue.

if this is the case then is there a easy way to set the nic to 1GB ?

image.png.e03f39a4eb6ce526da132b88d56bca56.png

 

Edited by chris_netsmart
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.