Jump to content
NAS

P5B-VM DO - USB boot option goes away when HDD installed

14 posts in this topic Last Reply

Recommended Posts

Using base build from the wiki.

 

With all components installed except the physical hard drives i can select USB lexar drive to boot from. Boots quickly with no problems.

 

However if I add hard drives to the Supermicro cards the BIOS forgets that i want to boot from USB and trys to boot from SCSI-0 by default. Normally this would be fine as i should be able to go and change the boot order.

 

Thing is Lexar is no longer in the the bootable device list.

 

If  I go to the general Hard Drive list in the BIOS the Lexar is still in there but its right at the end.

 

Its as if once the list gets to long the BIOS just pushes options off the end.

 

This is indeed a conundrum anyone got any ideas?

Share this post


Link to post

That behavior is not that unusual... Just choose the flash drive from the end of the hard drive list.

 

Many BIOS will "help you" by resetting the boot device every time you add a new hard disk.  In our cases, we really don't want its help.

 

If you cannot boot the flash drive from its entry in the Hard-Disk list, then use the HP formatting tool and try once more.  It resets the geometry on the flash drive to look like a removable hard disk.

 

More detailed instructions are in the Wiki: http://lime-technology.com/wiki/index.php?title=USB_Flash_Drive_Preparation

 

Joe L.

Share this post


Link to post

The first thing I had to do with my P5B VM DO was to update the BIOS.  The installed BIOS was very old and didn't even properly support my CPU.  I would suggest making sure your BIOS is 100% up to date, and do the "Settings to default" thing, and then try again.

 

If you got the P5E VM DO, make sure to check Tom's post about how to update its BIOS.  (There is a link to his post in the "Best of" wiki, "Hail to the Chief" section.  See link in my sig.)

 

If you have a P5B VM DO, you should configure the USB as a removable disk, not as a HDD.  And configure to boot off of the removable, not off of the HDD.  (Not sure about the P5E as I don't have one - but might be similar.)

 

Although I was able to boot off the USB as a HDD, when I added my 10th HD the BIOS no longer showed the USB drive as a HDD.  (I think 10 is the max it will show)

 

I only have the one removable - and it boots off it perfectly no matter how many HDDs and different controllers I add.

 

 

Share this post


Link to post

A success story.

 

The shipped BIOS was 801 so i flashed it to 1002. This was trivially easy using the inbuild flashing tool.

 

This however did not fix the problem. The Lexar USB was still in the list of Hard Drives (which is NOT the list of boot devices it is a differernt menu item). The "Boot Device Priority" bios list had 4 random devices.

 

The fix in the end  is easy though. In the List of Hard drives (the option immediately below the "Boot Device Priority" menu item) you can change the order of disks. Select the USB Lexar and make it device 1. Immediately it replaces the SCSI boot option in the "Boot Device Priority" and unRAID will boot.

 

I will add this to the Base Build document now.

 

None of my other drives are recognised but thats another problem for another thread should I not find the solution myself.

Update: By changing IDE SATA to AHCI all my drives became detected. Updated the wiki.

 

Thanks all

Share this post


Link to post

Glad you are up and running.

 

You might want to look at my post below again, and set up your USB as a removable and not as a HDD.  It's not a problem until you add more drives and you lose the ability to pick the USB as the bootable HDD.

Share this post


Link to post

...It's not a problem until you add more drives and you lose the ability to pick the USB as the bootable HDD.

 

It seems the magic number of drives is 12 on the P5B. Once you get to that as you predicted you cannot select the USB from the list and therefore cannot boot.

 

I reformatted the key using the correct HP tool but for the life of me I cannot get any menu choices for Removable Media. I am sure ive seen this option somewhere once during this adventure but I cannot make it happen again.

 

Interestingly if you press F8 during the BIOS boot sequence you are presented with a list of every drive of all types on your system to boot from. There is no 12 limit on this menu. The downside of this is even with a working USB flash install it hangs when you choose USB boot from this menu.

 

The ASUS manual doesn't seem to help me here as its written with a view to normal users.

 

So my quandary is how do I get the P5B to see the flash usb as removable media. Any ideas?

Share this post


Link to post

NAS -

 

I powered my server down and checked the settings for you.  Hope this helps.

 

You should not have had to reformat the USB stick.

 

The bolded item below is most likely your problem.

 

Advanced

- USB Configuration

---- USB Functions ENABLED

---- Legacy USB Support AUTO

---- Port 64/60 Emulation DISABLED

---- USB 2.0 Controller Mode HISPEED

---- BIOS EHCI Hand-off ENABLED

---- USB Mass Storage Device Contiguration

-------- Device #1 {your USB drive type should be listed here}

-------- Emulation Type FORCED FDD (options are Auto, Floppy, Forced FDD, Hard Disk, CDROM)

 

Boot

- Removable Drives

(make sure your USB is at the top of the list - otherwise move it to the top)

- Boot Device Priority

(make sure your USB is at the top of the list - otherwise move it to the top)

 

Good luck!

Share this post


Link to post

Don't know if it's helpful or not, but I found that the only way I could get my key to appear high enough on the hard drive boot selection list when loaded with harddrives on my AB9 was to use a specific USB socket, presumably the "number 1" slot ?

 

8)

 

Share this post


Link to post

Gents thanks for all the advice. The Mrs is having a music-a-thon this now so downing the server to try wouldn't go down to well. :) Will try in the AM.

 

It really surprises me how such a simple thing has escaped MB bios coders this really shouldn't be complicated but perhaps i dont know enough to fully comprehend how complicated the back end is.

 

bjp999 thanks for doing this for me its really appreciated.

Share this post


Link to post

 

The bolded item below is most likely your problem.

 

Advanced

- USB Configuration

---- USB Functions ENABLED

---- Legacy USB Support AUTO

---- Port 64/60 Emulation DISABLED

---- USB 2.0 Controller Mode HISPEED

---- BIOS EHCI Hand-off ENABLED

---- USB Mass Storage Device Contiguration

-------- Device #1 {your USB drive type should be listed here}

-------- Emulation Type FORCED FDD (options are Auto, Floppy, Forced FDD, Hard Disk, CDROM)

 

Boot

- Removable Drives

(make sure your USB is at the top of the list - otherwise move it to the top)

- Boot Device Priority

(make sure your USB is at the top of the list - otherwise move it to the top)

 

Good luck!

 

And we have a definitive winner.!

 

Why i wasnt seeing the removiable drive option is that once you have set the USB to "Forced FDD" you need to save the changes and allow the BIOS to reboot. Once this is done you get the Removable Media Menu and the abilty to make the boot order changes required. This was why i wasnt seeing it as during experiments i never saved and rebooted every time.

 

Now i can add and remove disks without haveing to alter the BIOS.

 

Superb thanks all ! ;D

Share this post


Link to post

Interesting.  My computer has a floppy drive so the removable menu was always there.  I did not have to do a reboot. 

 

Good info for future users.

Share this post


Link to post

Interesting.  My computer has a floppy drive...

 

That explains alot actually. I have a floppy but since its a slimline one i forgot to order a cable so its not fitted. Explains alot though. Knowing that the settings should be like this setting up the BIOS is now trivial. So so happy. :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.