[SOLVED] Replacement motherboard with WOL

Recommended Posts

I'm currently running two servers with ASRock 880GMLE ATX AMD 880G motherboards:



In a bid to cut my electricty bill I'm sorting out all my computers for sleep and wake on LAN. After testing and google search I've come to find that WOL will not work on these motherboards.


Can someone advise me on what I should replace them with to get at least the same features with proper WOL?


I want to use my current CPU, fans ,RAM and PCI/PCIe cards if possible. I'm open to a new processor if need to.

These are the attached cards:






Link to comment

Got it working with a lot of playing about with boot order and priority etc.

Also got it to sleep and then appear to wake although no GUI or shares were available, so nearly but not quite yet.


Managed to mess up my other unraid box during testing though. Better sort that one now too. The things we do for awesome cheap storage  :)

Link to comment

....glad you got it to boot.


Also got it to sleep and then appear to wake although no GUI or shares were available, so nearly but not quite yet.


I don't quite understand.

...did it wake up all by itself?...you need to disable "resume from RTC/timer event" or similar in the settings

...or did you wake it up on purpose and the GUI and shares did not show?...but NIC was up and running?...can you telnet/ssh into it after the resume?...


Link to comment



I asked it to sleep. I checked the server and I just noticed the fans weren't spinning. I didn't look any further into to it at the time as the GUI wouldn't load and the fans were off.

When I sent the WOL packet the fans started up again and I thought I was in business but it never actually woke from sleep and worked.


I'm gonna try again tonight.

Link to comment

I made sure resume from RTC/timer event was disabled and "S3 sleep only" was set.


Told it to sleep and the fans went off and the power LED slowly flashed like it was sleeping.

I noticed was no LAN lights on either.


I sent the WOL packet, the fans whirled up, the LED came on full, LAN lights lit up but it wouldn't display the GUI, wouldn't ping and no video output from the VGA. Tried mashing the keyboard but nothing worked. Had to flick off the power switch and start up again.


Link to comment

...AFAIU in this thread, the issue is cross motherboards, maybe an unRAID issue. ?


I am using that ASUS board for almost two years now, with sleep/resume cycles only...meaning that I never powered it down physically since then....but I am using Debian Wheezy.

My NAS is a 24bax norco-like case..running a M1015+ intel RES2CV240 expander with it....it runs completely headless.

I use a WoL-GUI from my Router or automatically when my HTPC powers up (with xbmc) and a script to send it to sleep (which uses the pm-suspend command).

Manually I use WebMin to do the admin stuff.

Link to comment

Looks like it may be another issue altogether.


I got a Intel Pro 1000 NIC PCI card off ebay. I noticed other people having success with this card so thought it's one to try.

Installed the card, disabled the onboard LAN. Booted the server, ran ethtool eth0 and it reported 'g'.

Able to access GUI and ping fine.

Spun down the drives and hit sleep in the GUI.

Server went to sleep just like it has before but this time LAN lights stayed on. So far so good.


Sent WOL packet, server spun up fans, LAN lights flashed a bit, HDDs spinning up but...

No video out from the VGA, no GUI, won't ping again!


I'm getting fed up of this now. I don't have to do a parity check because I attempt it with the array offline but every other time I try it I have to prepare a fresh USB install of unRAID as it gets corrupted shutting it down.


I wonder if it's a PSU thing. I'm having the what seems to be the exact same issue with a completely different mobo.


So whats next?


My syslog is attached.


Should I take this somewhere else in the forum?


Link to comment

...looks like your thread goes unanswered  :(


I don't know what APM/ACPI version/libs/kernel come with unRAID5, as I retired my licenses long before that.

You can try and find the proper settings and tools for getting pm-suspend working, as this is what works with my vanilla debian wheezy setup and that board.

But I figure this won't be a lot of fun.

Link to comment

I nearly gave up on this but that had a few thoughts on fault finding and spent a few hours on it.


I needed to be sure it wasn't my unRAID USB drives. It was a long shot but I've updated, added unmenu, got stuff wrong and had them about 4 years now. I tried a new install of unRAID on a spare USB drive. Installed Dynamix Sleep plugin and it still had the same issue.


Next step was unplug everything on the server except ethernet and power. Remove keyboard, PCI fan control, 2 port SAS card and 2 port sata card and tried it again...it worked!!


One by one I tried adding them back, sleeping it and waking it. It was the 2 port SAS card that 8 of my hard drives connect to was stopping WOL from working properly. Granted I still don't get a VGA video signal on wake but I don't care about that.


I removed the Intel NIC from the server and tried it with just the mobo's onboard LAN sleeping/waking and it worked fine ;)


I put the Intel NIC in my other server using the old mobo that wouldn't wake and that sleeps/wakes too :)


For now I'm sleeping the smaller server and shutting down the big when not in use. I'm quite impressed how quick they wake up and start working. With all my computers using WOL I'm saving about £1.50 a day!


I just need to find a PCI card with either 8 sata ports or 2 SAS ports that doesn't effect the waking.


The mobo you suggested was fine. Thanks for your support FP!

Link to comment

Wow....good thing that you worked doggedly on this.  8)


Well...you need/want a PCI based SAS card....really?  ???

AFAIU from your syslog, your current card is a PCIe x4.

Edit: OK, saw your other post...you're using an AOC-SASLP-MV8 ..so PCIe is what you want to replace...


I am using a M1015/LSI 9211-8i (PCIe x8) flashed to IT-mode in that board...works everytime.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.