[DOCKER] ps3netsrv

Recommended Posts

  • 10 months later...

Just wondering if anyone has any suggestions.  I'm having some issues using the shawly build.  I'm able to run it and connect to it, but no directories or files seem to be visible from multiman.  When I browse to the net0 host the directory is empty.  However when I try and create a directory it does get created on the server, but is still not visible from multiman.

Link to comment
  • 2 months later...

Well, I came here looking for the solution to make ps3netsrv work at first it didn't work and after reading the github repository I came to share what worked here.


I'm using OMV (open media vault) based on debian and through the portainer I made a stack based on what is in the shawly repository and which is below. Adapt to your use and user.
version: '3'
    image: shawly/ps3netsrv
      - TZ=America/Sao_Paulo
      - USER_ID=1000
      - GROUP_ID=100
      - 38008:38008
      - path/to/ps3games:/games:rw
Now for the explanation, create a folder named 'ps3netsrv' in the directory of your preference and be aware that the same user who owns it that folder has to be placed in the USER_ID and GROUP_ID part which can be achieved through 'id -u user' and 'id -g user' (replace user with the owner of the folder you just created) (to find out the owner, navigate to the folder by cmd and type ls -l).


I used it on a ps3 hen 3.0.3 with webMAN 1.47.35 I did the procedure to put the source and restarted. After that it didn't show up right away so I updated the games list and finally the shared folder with the games appeared.


Hope this helps!

Edited by diego_loiola
Link to comment
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.