Jump to content

Docker SAL and Postgres-SAL


ryan8382

Recommended Posts

We use this SAL product at work and I wanted to set it up at home.

https://github.com/grahamgilbert/docker-sal

 

I have setup my own github repo (https://github.com/ryan8382/unraid) for it and have the containers installing however the way the application is written it is looking for --link postgres-sal:db. I have tried to put that in extra parameters section but then it gives me an error.

 

dc359c8eaff38537701fdcc16056a32eb33f63cb651983f5cd301e8414eab5b8

time="2015-05-24T21:04:09-05:00" level=fatal msg="Error response from daemon: Cannot start container dc359c8eaff38537701fdcc16056a32eb33f63cb651983f5cd301e8414eab5b8: Child IP '' is invalid"

 

The command failed.

 

I had tried to change the postgres-sal container to use host from none on the networking then it gave me a different error.

 

root@localhost:# /usr/bin/docker run -d --name="Sal" --net="bridge" --privileged="true" -e DB_NAME="sal" -e DB_USER="admin" -e DB_PASS="password" -e TZ="America/Chicago" -p 89:80/tcp -p 8443:443/tcp -v "/mnt/user/appdata/sal/plugins/":"/home/docker/sal/plugins":rw -v "/mnt/user/appdata/sal/settings/":"/home/docker/sal/sal":rw --link postgres-sal:DB macadmins/sal

time="2015-05-24T21:05:57-05:00" level=fatal msg="Error response from daemon: Conflicting options: --net=host can't be used with links. This would result in undefined behavior."

 

The command failed.

 

I'm still learning how to use docker so any help would be great. Once i get this working i want to get a puppet server container.

 

Link to comment

This is the github repo.

https://github.com/ryan8382/unraid

 

As for the linking it looks to be correct. I'm using the default name that the other person used. I'm wondering if there is something up with docker on unRaid. I have tried setting this up on a Ubuntu box and it works no problems.

 

are you starting the postgres container first ?

 

if it isn't started there is nothing to link to. i've linked containers in unraid before and apart from some issues with the webui regards right clicking icons (which i believe is fixed) , it works.

Link to comment

I'm not an expert with this but I think there is a bug somewhere. I have setup a VM on unRAID running ubuntu with Docker and used the same  commands that they use which is the same thing that i moved into the unraid XML format. It works no issues.

 

I then took the same command at CLI and changed the ports and I get the same error that i posted originally. This is the command I ran.

 

docker run -d --name="sal" -p 89:8000 --link postgres-sal:db -e ADMIN_PASS=pass -e DB_NAME=sal -e DB_USER=admin -e DB_PASS=password --restart="always" macadmins/sal

 

FATA[1534] Error response from daemon: Cannot start container b110ce17ad81237a4b1a40f7a49fe761243dfafac07467be07808acb660a5dc5: Child IP '' is invalid

 

I'm going to continue to play with it but this should work.

Link to comment

there's no bug, i believe that because one of your containers is set to host as the networking type with no port specified that it's trying to allocate port 80, which it cannot do because that's the unraid webui port.

 

it doesn't fail when in a VM because the VM doesn't have port 80 allocated because it's an entirely different IP address from your unraid host.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...