VM creation error


Recommended Posts

Thank you for your quick reply.  I have done a little poking around and hoping you can see something in the attached lspci output.  I did see a bios setting that allows me to change the primary video card slot (the radeon is currently in slot 5 and the primary is slot 2), could a controller be blocking it? Please share any ideas you have.

Have u tried squids suggestion?

Link to comment

yes I tried the ACS override as well as moving to a new slot (attached lspci info) 


internal error: early end of file from monitor: possible problem:

2016-01-17T17:21:07.921012Z qemu-system-x86_64: -device vfio-pci,host=0f:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: vfio: failed to set iommu for container: Operation not permitted

2016-01-17T17:21:07.921043Z qemu-system-x86_64: -device vfio-pci,host=0f:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: vfio: failed to setup container for group 15

2016-01-17T17:21:07.921052Z qemu-system-x86_64: -device vfio-pci,host=0f:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: vfio: failed to get group 15

2016-01-17T17:21:07.921064Z qemu-system-x86_64: -device vfio-pci,host=0f:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: Device initialization failed

2016-01-17T17:21:07.921076Z qemu-system-x86_64: -device vfio-pci,host=0f:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: Device 'vfio-pci' could not be initialized



also tried the nvidia card which is now device 42: same failure


Link to comment

looks like you suggested. am attaching the conf file also.


tmpfs on /var/log type tmpfs (rw,size=128m,mode=0755)

proc on /proc type proc (rw)

sysfs on /sys type sysfs (rw)

/dev/sdc1 on /boot type vfat (rw,noatime,nodiratime,umask=0,shortname=mixed)

/dev/md1 on /mnt/disk1 type xfs (rw,noatime,nodiratime)

shfs on /mnt/user type fuse.shfs (rw,nosuid,nodev,noatime,allow_other)

/boot/config/plugins/dynamix.kvm.manager/domain.img on /etc/libvirt type ext4 (rw)



Link to comment

If it helps my computer specs are a Z800 with a GT 720 as the main and a Radeon 6670 for the passthrough.


Model: Custom

M/B: Hewlett-Packard - 0AECh

CPU: Intel® Xeon® CPU E5620 @ 2.40GHz

HVM: Enabled

IOMMU: Enabled

Cache: 256 kB, 1024 kB, 12288 kB

Memory: 49152 MB (max. installable capacity 96 GB)

Network: eth0: 100Mb/s - Full Duplex

Kernel: Linux 4.1.15-unRAID x86_64

OpenSSL: 1.0.1q

Link to comment

You need to add a new version of the qemu.conf file with all the needed vfio groups added.

Here is the needed info for it:



I would also suggest you pass through the audio device of your graphics card also, as there have been reports lately about instability problems when only passing through the video part.

Link to comment

I tried the new qemu and still got the same error. I have tried passing with and without the audio. Any other ideas? Should I install an older version of unraid?

Edit your syslinux (main > flash > syslinux configuration).  A few lines under the line "menu default" you'll see the word "append".  Add a space after that word and type the following:




Apply the changes and reboot your system.  Report back if that works.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.