Jump to content
Sign in to follow this  
cyberstyx

Solved issue with unRaid 6.2 and Win10 VM hanging during Anniversary upgrade

5 posts in this topic Last Reply

Recommended Posts

I troubleshooted this and found the solution, so I 'm writing this down in case someone finds it useful.

 

After upgrading from 6.1.7 to 6.2 I also edited the VM configuration and changed the VNC GFX but also the USB Mode from 2.0 EHCI to 3.0 XHCI.

 

The VM functioned properly until it auto-updated itself to the Anniversary edition. At this point after restarting it stopped at 35% and completely hanged, while the CPU shows a continues 100% activity.

 

I changed the CPU to another non-used one for troubleshooting, it stayed again at 100% while Windows Update stayed at Getting Things Ready at 35%.

 

There was no possibility to safe boot, repair, revert or anything like that.

 

In the end I edited the config file again and changed USB mode from 3.0 to 2.0. I also changed the Machine Type from i440fx.2.3 to 2.5 (a new option in 6.2? ) as well as the two CDROMs from IDE to SATA. But I am guessing that the USB Mode did the trick.

 

It is still a bit strange as Win10 booted just fine and operated for a few days without problems with "the new hardware".

Share this post


Link to post

But do you have the update installed or did it restore the original version?

 

I just had the anniversary edition install and to get it to happen I had to disable all the pass-through devices and remove all the assigned cores and just assign core 0. This worked and then I put everything back.

Share this post


Link to post

Yes I have the anniversary edition now. I could not revert back to any previous version even if I could as the VM was not working (could not get into safe mode and booting from Window's ISO and trying any possible option in troubleshooting was not working).

 

Yes, I had one VCPU for that during all my tries. It 's also in the official manual when upgrading a host with Win10.

 

The only setting that seemed to matter, at least in my situation, was to change the USB mode from 3.0 back to 2.0.

Share this post


Link to post

The only setting that seemed to matter, at least in my situation, was to change the USB mode from 3.0 back to 2.0.

 

There is a known issue with Windows updates and having USB devices plugged in -- not for everyone but some computers will not update if there are USB devices plugged in.

 

This only impacts one of my computers but as long as I had the wireless keyboard / mouse plugged in the circle would just spin for hours. Eventually I googled it and found other people discussing it. Removed the USB device and update continued immediately. Possibly changing the type of USB has a similar impact.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this