Jump to content

(Solved)Hard Drive Disappeared on reboot. Not missing


Recommended Posts

I rebooted and one of my hard drives was no longer showing up.  When i try to pick it from the drop when re-assigning disks it keeps  showing as not installed.  I bought another hard drive and precleared them both, yet i am still not able to re-add the drive.  It is not showing as missing just not installed.  This is a 5 TB drive that i have about 3.5TB data that I really dont want to loose.  Any ideas?




Screen Shot 2018-07-19 at 8.31.17 PM.png

Screen Shot 2018-07-19 at 8.32.57 PM.png

Link to comment

I can't see why it's not working, there are no errors on the syslog and the disks are correctly detected, I would recommend redoing your flash drive and trying again:


-backup current flash

-re-format it

-copy only you key and super.dat from the backup, both on and to the config folder


Try again, if it works reconfigure the server and/or copy the remaining settings.

Link to comment

Here is the part that is bothering me..

I am using the same disk for most of my drives 

Currently in array               "TOSHIBA_HDWE150_*** - 5 TB (sde)"

New Disks after preclear "TOSHIBA_HDWE150_*** - 0 B (sdf)"

This preclear was with the latest plugin version.  Running again with Preclear.bjp.sh "Version 1.17  - Remove rogue comments in script."  to see if it makes a difference.  with command ./preclear_bjp.sh -W -A -f /dev/sdc



I am also using Dynamix SCSI Devices to rename my drive.


Both of the new drives are showing the same  0 B all the other ones in the array are showing 4 TB or 5 TB. 


Looking at the Super.dat file I see where the first letter of the Toshiba Drive that dropped is clipped.  Reading OSHIBA_HDWE****. (using atom only mac) Comparing it to an older version of the super.data it is not Clipped on the letter "T".  Rolled back the super.dat file but still no different..

Link to comment

Just to followup on this.  i loaded a new config to another usb drive and booted.  Had issues with the SSL folder not allowing me to get to the web page.  However after copying the SSL folder over to the new drive, i was able to get into the web site and verify that all drives are appearing correctly.  Plan now is to get as much of the data off the parity that i can and then use the new USB drive going forward.  Still have not figured out why the old usb/config is not allowing me to add new drives..  

Link to comment

Ok I have found the reason, it is a plugin named dynamix.disk.io.  It is causing all my unmounted drives to read 0 bytes available when i try to add them to the array. Removed that plugin and I am now in the process of rebuilding the original USB drive and raid.



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...