Jump to content

SMB bind network interface

Recommended Posts

Hello all,


I have 4 network interfaces out of which 1 interface is in Management VLAN and the other three are bonded via LACP. I would like to bind the samba service to the bonded interface. I added the following to the SMB extra conf page but doesn't seem to be working.


bind interfaces only = yes
interfaces = lo br1

Tried bond1 and br1, both did not work. Any advice?



Link to comment
  • 1 year later...

How many IP addresses are assigned to Unraid, and what do you get when you run

# netstat -lntp | grep smbd

You should get kinda like

tcp        0      0 *               LISTEN      30554/smbd
tcp        0      0*               LISTEN      30554/smbd
tcp        0      0 *               LISTEN      30554/smbd
tcp        0      0*               LISTEN      30554/smbd

which should only list your IPs to the bound interfaces.


In my case I have two interfaces and smbd is only bound to br0 and lo; but then again I only one IP assigned to Unraid, so the other VLANs need to use the router to reach Unraid, even it was a local container or VM (unless the VM is Linux and I'm using Plan9 mounting)

Link to comment
tcp        0      0   *               LISTEN      10359/smbd          
tcp        0      0   *               LISTEN      10359/smbd          
tcp6       0      0 :::445                  :::*                    LISTEN      10359/smbd          
tcp6       0      0 :::139                  :::*                    LISTEN      10359/smbd  


Thats what I get. Strange thing is that none of my actual ip's show up. I have 3 nics that are attached to my machine. 1x pcie 10g and 2 onboard gbit. I have my 10g set as eth0, one of the other gbit set as eth1 and the eth2 is set as port down. 10g nic and 1g nic I have docker services running on both devices and can confirm that data is flowing on the respected nic.


Below is my samba settings

ntlm auth = yes

#Unassigned devices share includes
   include = /tmp/unassigned.devices/smb-settings.conf

#use samba on 10g network only
bind interfaces only = yes
interfaces = lo eth0

however when I look at the dashboard at the network activity and start a large file transfer I do not see it going through my 10g but the 1g nic. I have tried switching eth0 and eth1 and the traffic follows the 1g nic.  

Edited by gagefox
Link to comment
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...