Jump to content

Installpkg for sg3_utils in 6.5.3 - corrupt?


Recommended Posts

I'm using a Lenovo SA120 with unraid to house disks.

In prior versions, I installed the slackware sg3_utils package (http://sg.danny.cz/sg/sg3_utils.html) using installpkg. I would then run AndrewX192's excellent utility to turn down the fans (they ramp up to full speed with any power cycle and have to be manually turned down) - this script is located at https://github.com/AndrewX192/lenovo-sa120-fanspeed-utility


I have tried downloading the sg3_utils package from slackware, from the sg3_utils homepage, etc but every time I try to install it I get the message:


installpkg sg3_utils-1.42-x86_64-1.txz
Verifying package sg3_utils-1.42-x86_64-1.txz.
Unable to install sg3_utils-1.42-x86_64-1.txz:  tar archive is corrupt (tar returned error code 2)

Which is bull because I tried this with my old copy of the package and new ones downloaded elsewhere (see above). Everything gives me this message. I can decompress and un-tar the file using command line utils and see the files in there. I've tried debugging the installpkg script but I can't see where it's getting stuck.


Can anyone help me either find a good copy or figure out how to get this installed? We're going deaf with the fan noise. Thanks!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...