Jump to content
Sign in to follow this  
r1sk

[SOLVED] CRC Errors with new LSI card - [Unraid 6.6.6]

4 posts in this topic Last Reply

Recommended Posts

Hi, 

 

I've just upgraded my unraid setup , with a new motherboard / CPU / memory and SATA Controller (LSI card).

Previously I had enough SATA connections on my board but now I had to move to a LSI Card to be able to connect all of them to my system.

 

I've noticed that increase CRC errors only on the drives connected to the LSI card, the rest of the hard drives were ok.

I did read somewhere in the forum that the cards can get hot an its a good idea to put a fan on them , I've done it and the errors are still appearing.

Also in one of the threads they mentioned that it might be related to cross talk between the SATA cables, i've tried to spread them around as much as possible but since the LSI card has 2 mini-SAS connectors they can be really separated too much.

 

I've attached the diagnostic file, but looking around the log, didn't find anything suspicious, one thing I was concern is , if my LSI card is on the right firmware.

 

other then the CRC errors I see another 2 issues that I'm not sure both of them are related

1. very slow parity check,  and I guess while running the parity check the CRC count is rising.

2. can't manage to create a new ubuntu VM , its getting stuck while trying to install it.

 

I didn't attach any SMART reports since from my understanding CRC errors are not hard drive specific issue , especially when all of them are getting errors and not just one.

 

let me know if any additional information is necessary.

  

 

Thanks,

Alex.

tower-diagnostics-20190127-1822.zip

Edited by r1sk

Share this post


Link to post
1 hour ago, r1sk said:

one thing I was concern is , if my LSI card is on the right firmware. 

It's not:

FWVersion(20.00.00.00)

There are known issues with this firmware, you should update to 20.00.07.00, though not likely to fix the CRC errors, if it's not cables/backplane it's likely the controller.

Share this post


Link to post

thanks!, it actually did the trick.

no more CRC errors and the parity check is back to its normal speed.

 

 

Share this post


Link to post

I had the same problem,  flashed with the 20.00.07.00 firmware and the errors have stopped.  Came across this thread after, unfortunately, changing cables and PSU. 

 

 

Edited by io1901
typo

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this