Jump to content
Sign in to follow this  
Dtrain

New User need some help

12 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi there,

i am testing unraid right now ...

The Idea is to have an "all in one PC"

Hardware used:

1920x TR4

X399 Taichi ASROCK

128GB RAM

4x10 TB HDD (2 Parity 2 Data)

4x 500 GB SATA SSD as Cache

2x Intel Optane 280 GB one PCI Slot one U2 Slot

2x NVME 500GB

 

My Requirements are pretty basic, but since i have bought all hardware to use within  ESXI (cant get it to work with ESXI )  i am trying Unraid now need some assistance:

 

Windows with NVME + Intel Optane and GPU Passthrough  = only working for one Boot .. see Descriptions below ..

Fedora with NVME + Intel Optane and GPU Passthrough  = only working for one Boot .. see Descriptions below ..

 

thanks to the outstanding Videos from Spaceinvader one !

 

 

and then the most confusing part is to a Setup Solarisih

 

 this is used a a rock solid Backup Box

 

Solaris with NVME + Optane + LSI Controller Passtrough ( ZFS Box for BACK UP) = fail ?

 

LSI

IOMMU group 16:[1000:00c4] 09:00.0 Serial Attached SCSI controller: Broadcom / LSI SAS3224 PCI-Express Fusion-MPT SAS-3 (rev 01)

 

 

Detail Info for IMMOU Groups etc could be found here... since it use the same Mobo.

 

 

 

Thank u !

 

 

 

 

Edited by Dtrain

Share this post


Link to post

So your issue is, all the VMs are working fine except of a Solaris install with a NVMe + Optane + LSI controller passed through?

 

Small hint, i don't have the same board as yours but my AsRock Fatality x399 also has a U.2 slot and if used, one of the 3 M.2 slots are disabled. And the way how the devices are split in it's own groups are depending on the BIOS versions as well as the settings you make in the BIOS and in Unraid itself (ACS Override). Are more detailed description on what isn't working might be good for people helping you. Errorlogs, screenshots or the diagnostics might help.

 

And also noted, you have 2 NVME and 2 Optane. If you pass them through your first 2 VMs (Windows, Fedora) and the VMs are running, you can't use them in another VM.

Share this post


Link to post

Hello bastl,

thanks for ur help.

The  NVME and Optane are splitted thats not an issue at all, refering to spaceinvaders one Video.

(As long the splitted devices are not running in different VM's at the same time )

 

The Second NVME + Optane i want to use exklusive for the Solaris VM.

 

I could not any template for Solaris nor i am capeable as a noob to create my own template in unraid....

 

 

Share this post


Link to post

Have you tried to use a standard Linux template? At which point you're stuck? Starting the VM? Getting a output to VNC? No device to install it to? Installation errors?

Share this post


Link to post

Getting slowly there using a Linux template,.,

 

No disk found ... ( of course as need to learn how to passthrough  NVME + Optane)

and then finaly the LSI ,,

 

thanks

Share this post


Link to post

Set your drive not as VirtIO. Try SCSI or SATA. I guess solaris don't have the VirtIO drivers.

Share this post


Link to post

Realy a pain in the ass this is,,,

cant get it to work, hopefully somebody will share his expierence here with me

Share this post


Link to post

If you don't give us detailed information what you already did and what exact problems you run into I doubt someone can help you.

Share this post


Link to post

yes true...

i am kind of lost now, as i do not want to interrrupt the parity build... / 60% done

 

I am facing various problems with the VMs

 

First of all Windows:

Passtrough NVME + OPtane do work .... until the first reboot,

then i am stucked within a loop (CD Rom Boot all the time)

 

1th thing i did, edit vm xml and added : <boot order='1'/>

 

This did not help whereever i put the line.. several Errors

Then after approx 30 Reboots i figured out that afer a reboot the config file of VM XML does not interact somehow with the KVM BIOS Emulation

It is reverted each time to Boot from CD

 

So far i press F2 to get into the VM Bios an there i can change Boot Order to NVME

 

Any Idea how to Fix this ?

 

Share this post


Link to post

The Windows VM is getting there...

the Failure with the Boot Loop could be fixed with this help

 

Now need to figure out how to passthrough my VGA Card (NVIDIA P6000)

 

Share this post


Link to post

Check the following video and maybe search his channel. You will find a looooooot useful stuff there.

 

Share this post


Link to post

The Error 43 is still there, can get it to work tried all methods shown in videos and even here in the Forums.

I have a NVIDIA P600 Quadro, i think it is time for a new VGA Card but witch one ?

As i do not play games but need a 4k Resolution as i use a TV as Monitor (HDMI)

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this