Jump to content
chris_netsmart

Virtualizing unRAID on Proxmox 6.0.4

27 posts in this topic Last Reply

Recommended Posts

Having issues, I have following the post from Brnson, but I think I am missing something.

 

here are the steps I followed

 

On 7/30/2019 at 12:51 PM, Benson said:

 

Step almost the same, but I think best should be prepare unraid USB stick first then unplug it before prepare Proxmox.

 

Below are some detail

 

1. Unplug well prepare Unraid USB, best ( not must ) confirm it can boot in UEFI mode.

2. Install Proxmox to harddisk, make IOMMU enable.

3. Replug Unraid USB

4. Create VM

 

1.PNG.ca60dd40d096a226c1e8491703191141.PNG

 

4a. Tweak ( Some step may not necessary )

- Click CD/DVD drive, remove it

- Click Hard Disk, detach and remove it

 

2a.PNG.c68eafa41578a10c58a77ccb2e7f5f0f.PNG

 

- Add phyical disk controller and physical Unraid USB stick

3b1.PNG.acecab05038118b61a3e3a173d8b37b2.PNG

 

3b2.PNG.605a2322eae1a4e9d37ade6e1ebea853.PNG

 

3b3.PNG.b9a879ae3c307970d154d9993dc0d09e.PNG

 

4b. Tweak

- Edit boot order, only retain CD-ROM  in boot device_1

2.PNG.cda82af0be3091bff6c7d3fe891a1c6a.PNG

 

 

That's all.

 

so the steps I have takes.  I have created a Test UNRAID USB pen drive. - all works with no issues with a 4TB Hard Drive for storage.

I then installed Proxmox onto a 1TB HD.

so far so good. 

then I followed Bensons steps and here is where the fun starts. I will post each step. in the hope someone will see my mistake.

 

First I check the I have IOMMU Groups

image.png.d5cf69dae37283b0852528c37895c471.png

 

then I created the VM

 

image.png.8e39ae4d083e4f4067255b9476d2fdab.png

 

I did't choose of OS as I was thinking that as I am passthrough my Unraid Pen drive, I will not need to set this up

image.png.465c93172d5600a45fb01115db80e7f3.png

 

working my way through

image.png.cc86d17da4af5baf8a5d66267cad5841.png

 

image.png.96a85ec218d7845bee24303367c3bd6c.png

 

image.png.2045f25dc3b9f5a27714e5f7977698cc.png

 

image.png.be39e34a572843e87d4ff1acf3debb1d.png

 

image.png.dcd1d5022ca30a91db1198c0b2cac118.png

 

and it build OK then I when through and remvoe the CDROM and Added the Unraid Pen Drive.

  

when adding the PCI Controllor I am getting the following --  No Ideal How to resovlve this at the moment

image.png.dc40d1ee45fab96eec2a9fa46b9700b6.png

 

image.png.34371ea193bc8fc1626846a0e8b3d5f5.png

 

then I confirm my boot order

image.png.4bfa10690979281a63368c76a71212a3.png

 

but when I start my VM, then I am getting this 

 

TASK ERROR: KVM virtualisation configured, but not available. Either disable in VM configuration or enable in BIOS.

 

and here is my Hard Spec

image.png.57e0c8a9623f96ce1abb55fb98063999.png

 

Share this post


Link to post

You try in new B450 platform

 

1st don't add PCIe device 18:00.0 it is groups 12 with other devices ( SATA controller ? If it is a controller which connect PVE harddisk then you can't passthrough it )

2nd don't add PCIe device 1f:00.0, it is groups 13, ( GPU ? )

3rd boot order change to CD-ROM as device_1, 2 & 3 set to none

4th you haven't show you add Unraid USB or not

 

Then check Unraid USB boot or not, if negative, screen dump VNC ( console ) and final VM profile and IOMMU device name.

Edited by Benson

Share this post


Link to post

I know I did something silly.

 

thanks benson,

I have gone through and completed steps 1, 2 and 3.

 

I have also recheck my USB

Capture.PNG.1877338818371ba326e7f750fcba00d6.PNG

 

and now when I run the VM, I am getting this error

()

Task viewer: VM/CT 100 - Console

OutputStatus

Stop

VM 100 not running
TASK ERROR: Failed to run vncproxy.

 

my VM Set up.

Capture.PNG.9d8a24838521675cf39631f80e53b7e9.PNG

 

bit confused, what do you mean by IOMMU device name

Edited by chris_netsmart

Share this post


Link to post

** Pls reboot physical machine first, because you have passthrough the GPU **

After start the VM, click "hardware" tab then back to "console" tab again and check.

 

Pls also double check in BIOS, virtualisation already enable.

 

 

And, not relate the vncproxy error, pls remove EFI disk, and disable Network device's firewall .

 

3 hours ago, chris_netsmart said:

bit confused, what do you mean by IOMMU device name

Pls screen capture as below for ref. too

3b1.PNG

Edited by Benson

Share this post


Link to post

ok I done as request and here is a snip shot of my VM

image.png.1f75e05033bf04f967efb75fe9338211.png

 

I have then powerup up my VM and I got the following screenshots

image.png.5f5691ff61f5cf7f1aeae4c91c7b82a4.png

 

image.png.ae6b8dcd0e510adf4a90e63d8c38564f.png

 

and lastly can you confirm which IOMMU  I should choose

image.png.15dcf25673db7aee70c20ccb3aad9e8b.png

Share this post


Link to post

VM can start, then remain booting issue, why "Unuses disk" & "Hard disk" still there ??

 

And don't know why showing  "USBest Technology ......" ( Unraid USB ? ) not found,  pls reconfirm the USB port haven't change. 

 

 

Edited by Benson

Share this post


Link to post

my mistake

image.png.3c864a9ff96edb58f6eea7c3f07fbd38.png

 

still getting the same issue, as above.

it looks like it can't see the USB Device "Unraid Pen Drive"

Edited by chris_netsmart

Share this post


Link to post

 

17 minutes ago, chris_netsmart said:

and lastly can you confirm which IOMMU  I should choose

This will be last, you shoud success bootup Unraid USB first.

Edited by Benson

Share this post


Link to post

confused ?

3 minutes ago, Benson said:

 

This will be last, you shoud success bootup Unraid USB first.

would it be easier if I give you access to my workstation, via Team Viewer ?

Share this post


Link to post
1 minute ago, chris_netsmart said:

confused ?

would it be easier if I give you access to my workstation, via Team Viewer ?

Sorry, not suitable and I haven't Team Viewer.

Unraid booting success ??

Share this post


Link to post

OK, let me think.

 

Unraid USB stick UEFI boot mode enable ? or your may set VM to SeaBIOS/i440fx and try.

1.PNG.42486306cd2119c4cfa1820bce3eaada.PNG

Edited by Benson

Share this post


Link to post

changed to SeaBios, and it looks like it is booting into Unraid ;-)

 

ok we have Booted into Unraid with no issues, but there are no hard drivers or M.2 SSD

Edited by chris_netsmart

Share this post


Link to post
9 minutes ago, chris_netsmart said:

ok tried setting the machine to I440FX - the same

when to BIOS to change to above suggestion, and saw this

image.png.b8cc4d8c20f93c84193ecd06077e7ccc.png

If Unraid already config UEFI boot enable, that's it. You won't found my VM config need add EFI disk too.

Edited by Benson

Share this post


Link to post
6 minutes ago, chris_netsmart said:

changed to SeaBios, and it looks like it is booting into Unraid ;-)

OK good, anyway you should take more care on all mention step, many uncessary fault.

 

Last, you just need passthrough the disk controller ( Unarid disk which connect, not include PVE disk ), but the controller must in standalone groups.

i.e. FCH SATA controller, it is standalone in group18 ( But I never try that succes or not )

 

image.png

 

Edited by Benson

Share this post


Link to post
3 minutes ago, chris_netsmart said:

ok, so for example I will need to get my GeForce GTX into it's only group.

and also for any SATA controllors, like the on board ports

 

Yes, otherwise need tweak the iommu parameter as your URL link provide, GPU passthrough usually not easy.

Edited by Benson

Share this post


Link to post

ok thanks. 

 

I will play around with this evening. and see how far I get.

 

thanks for your help

Edited by chris_netsmart

Share this post


Link to post

How did you mange to force Proxmox to usb boot at first? 

 

The only workaround for me to boot Unraid at the moment is, hit esc during boot and manually select usb boot.

Share this post


Link to post

You can edit VM XML and add "boot order" line under the USB

 

 

Share this post


Link to post
46 minutes ago, jaddel said:

How did you mange to force Proxmox to usb boot at first? 

 

The only workaround for me to boot Unraid at the moment is, hit esc during boot and manually select usb boot.

Found a solution:

 

Download Plop Boot loader: https://www.plop.at/en/plopkexec/download.html

Extract the .iso from the package. 

Upload it to Proxmox isos : https://sumguy.com/proxmox-iso-upload-method/

 

Add IDE CDROM to your VM with the iso.

 

 

Share this post


Link to post
4 minutes ago, Benson said:

You can edit VM XML and add "boot order" line under the USB

 

 

how does that apply for Proxmox? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.