Jump to content
Tubey

Shares are open using a VPN tunnel

4 posts in this topic Last Reply

Recommended Posts

I use OpenVPN on PFsense to access my shares at home while I am away.  But, the shares do not ask for authentication (user name and password) like they do when I am on my LAN at home.  I have a VPN username and password that logs me in but that username and password is not setup in UnRaid.  I thought it would ask me for my username and password to access my shares.  Is the security issue on the VPN side or UnRaid side, or do I have a lack of understanding of how shares work on a VPN?

Edited by Tubey

Share this post


Link to post

I guess the login username and password on the computer that are running the OpenVPN client must be the same as the username and passwod  on your UNRAID, otherwise this wouldn't/shouldn't work without you being asked for credetials.

Or if you were prompted for credetials the first time you accessed yoor UNRAID on the OpenVPN connected computer and selected to save the credentials, then you would not get prompted again. 

The OpenVPN tunnel username and password doesn't have anythig to do with this. 

Edited by gberg
  • Like 2
  • Thanks 1

Share this post


Link to post
On 12/4/2019 at 10:53 AM, lucy said:

Are there any other settings to configure on the server/firewall in order for the network drives to just connect like they would internally through the vpn?

If there is a firewall setup to only allow connections from your local LAN you must also allow the devices from the remote LAN to connect.

Share this post


Link to post

Update: I forgot to mention that this only happens on my IPhone 7, whether on the local network or the VPN. Computers, require a login.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.