Jump to content
Max

Docker Code 403 & VM io Error (Solved)

7 posts in this topic Last Reply

Recommended Posts

Everything was working fine up until like half an error ago than all of a sudden my vm was stuck and i noticed that half of dockers that were running at that time also stopped all of sudden than when i tried launching them back i ended up with execution error code 403 and now when im trying to launch my im getting back this error -- "Hook script execution failed: internal error: Child process (LC_ALL=C PATH=/bin:/sbin:/usr/bin:/usr/sbin HOME=/ /etc/libvirt/hooks/qemu 'Windows 10 New' prepare begin -) unexpected exit status 126: libvirt: error : cannot execute binary /etc/libvirt/hooks/qemu: Input/output error"

im attaching my diagnostics with this post.

please help me figure out how to fix this and how can i prevent it from happening again in the future.

unraid-diagnostics-20200116-0128.zip

Share this post


Link to post

It appears that your cache drive dropped offline (or dropped dead) which is resulting in havoc.  Reseat the cabling to it

Share this post


Link to post
13 hours ago, Squid said:

It appears that your cache drive dropped offline (or dropped dead) which is resulting in havoc.  Reseat the cabling to it

if a had not ran that fix common problem plugin, i would have said that that cant be as i was still able to access all my data that was their on my cache drive and under unraid's main page all my drives were active and normal but as i did i know it had something to do with my cache drive as fcp plugin reported two errors and both were about my cache drive.

1. Error --  my cache was read only or completly full

2. error -- unraid was unable to write to docker.img ( we can conclude that this error popped up cause of first error.)

my cache wasn't even half full at that time. so i thought that maybe unraid isn't detecting my cache drive's capacity properly so i rebooted my server and since then its been like 17 hours and 20 minutes and so far everything is working normally, as it should. All my dockers are up and running and my vm's are also working now.

so dont know what really happened.

fortunately one thing is for sure, that my cache didn't dropped dead on me.😅

Share this post


Link to post

@Squid hey something similar happened today as well everything was working fine and boom all of sudden my vm is stuck and all my dockers stopped only this time unraid was reporting that their were updates available for all my dockers which is weird but i know that i think this issue happened yesterday at the same time it today and my server is scheduled to auto update all my dockers and plugins at this time.

which lead me to believe that it might has something to do with ca auto update applications plugin.

Share this post


Link to post

Possibly because of 

17 hours ago, Squid said:

It appears that your cache drive dropped offline (or dropped dead) which is resulting in havoc.  Reseat the cabling to it

and your solution was to

 

3 hours ago, Max said:

rebooted my server

which didn't actually address the issue

Share this post


Link to post
1 minute ago, Squid said:

Possibly because of 

and your solution was to

 

which didn't actually address the issue

okay i will try that, as you know better, im sorry i forgot to attach today's diagnostics report im attaching it to this report.

the only thing that i dont get if its cable how its was able to run all fine and only crashed when it was auto updating my dockers.

unraid-diagnostics-20200117-0007.zip

Share this post


Link to post
On 1/17/2020 at 12:37 AM, Squid said:

Possibly because of 

and your solution was to

 

which didn't actually address the issue

thanks man, its been working great ever since i reseated my sata cable for cache drive, which i should have done the very first time u told me to😅. stupid me.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.