Jump to content
Wisnaeme

Drive does not spin down: Error reported: SG_IO: bad/missing sense data

3 posts in this topic Last Reply

Recommended Posts

Hi,

When trying to spindown the drives I have one that just refuses and throws an error. Any suggestions?

I see some historic posts on this but they all say it was fixed and mostly related to removable USB HDD's. This is internal SAS.

 

Logs and details below:

 

Unraid:

Version: 6.8.3 

 

Controller is: Serial Attached SCSI controller: Broadcom / LSI SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] (rev 03)

Drive is: 
[1:0:0:0]disk HGST HUS726040ALS211 BD05 /dev/sdb 4.00TB
SCSI Devices

[0:0:0:0]disk /dev/sda 8.08GB

[1:0:0:0]disk HGST HUS726040ALS211 BD05 /dev/sdb 4.00TB

[1:0:1:0]disk HGST SDLL1DLR480GCDA1 X130 /dev/sdc 480GB

[1:0:2:0]disk ATA WDC WD30EFRX-68E 0A82 /dev/sdd 3.00TB

[1:0:3:0]disk ATA WDC WD40PURZ-85T 0A80 /dev/sde 4.00TB

[1:0:4:0]disk ATA WDC WD30EFRX-68E 0A80 /dev/sdf 3.00TB

 

System Log:
Jun 29 06:59:15 ADAM emhttpd: error: mdcmd, 2723: Input/output error (5): write
Jun 29 06:59:15 ADAM kernel: mdcmd (66315): spindown 1
Jun 29 06:59:15 ADAM kernel: mdcmd (66316): spindown 2
Jun 29 06:59:15 ADAM kernel: md: do_drive_cmd: disk2: ATA_OP e0 ioctl error: -5
Jun 29 06:59:15 ADAM kernel: mdcmd (66317): spindown 3
Jun 29 06:59:16 ADAM emhttpd: shcmd (277): /usr/sbin/hdparm -y /dev/sdc

Jun 29 06:59:16 ADAM root: SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 18 00 00 00 00 20 00 00 c0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Jun 29 06:59:16 ADAM root:
Jun 29 06:59:16 ADAM root: /dev/sdc:
Jun 29 06:59:16 ADAM root: issuing standby command

Jun 29 06:59:17 ADAM emhttpd: error: mdcmd, 2723: Input/output error (5): write
Jun 29 06:59:17 ADAM kernel: mdcmd (66318): spindown 2
Jun 29 06:59:17 ADAM kernel: md: do_drive_cmd: disk2: ATA_OP e0 ioctl error: -5

Jun 29 06:59:18 ADAM kernel: mdcmd (66319): spindown 2
Jun 29 06:59:18 ADAM emhttpd: error: mdcmd, 2723: Input/output error (5): write
Jun 29 06:59:18 ADAM kernel: md: do_drive_cmd: disk2: ATA_OP e0 ioctl error: -5

Share this post


Link to post

Hmm. Thanks.
I was sure the other server had SAS powerdown capability. I'll need to check later.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.