Jump to content
botteur

Création nouveau NAS (maj).

33 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Bonjour à tous !

Cela fait quelques années que j'ai un NAS maison qui tourne sous OpenMediaVault et j'étudie actuellement la possibilité de passer sous UNRAID !

 

Avant de passer le cap j'ai 2 questions auxquelles je n'ai pas encore de réponses :

 

1. Est-ce qu'une fois la 1ère grappe raid faite, est-ce que je peux rajouter autant de disques que je souhaites par la suite ? Je veux dire que simplement je branche un nouveau disque dur dans le nas, je fais ajouter dans unraid et hop c'est fait ... ou c'est plus compliqué que ça ?

 

2. Est-ce que je peux utiliser plusieurs disques de tailles différentes ? Actuellement j'ai des disques WD Red allant de 3 à 8To, est-ce que je peux tout cumuler sans soucis ou est-ce que j'aurais des pertes d'espaces ?

 

Merci d'avance pour vos réponses !

Edited by botteur

Share this post


Link to post

Bonjour,


1. Oui sans souci, juste une recréation de la parité

2. Oui mais le disque de parité doit être le plus gros et son espace sera perdu (un peu comme Synology avec son SHR). Si tu as 2 disques de 8 To et 2 de 3, tu auras donc 14To de dispo

Share this post


Link to post

Bonjour,

pour le premier point, si tu fais un format ou preclear, je ne suis même pas certain qu'unRAID fasse un recheck de parité vu que tous les secteurs sont à 0.

A confirmer tout de même.

Share this post


Link to post

Ok, merci pour ces réponses !
En fait voilà un peu le projet que j'ai en tête, sur base de mon ancien pc je pensais faire un nas sous unraid avec pour commencer :

- 1 ssd de 1to en cache

- 3 hdd (WD Red) de 12to dont 1 pour la parité.
- Ensuite rajouter au fur et a mesure les disques de mon anciens nas à savoir des WD Red allant de 3 à 8to

 

On m'a déconseillé les hdd de 12to à cause des risques et du temps que cela prendrais à créer la grappe. Qu'en pensez vous ?

Si cela fonctionne comme le SHR, je peux m'attendre à avoir une répartition comme montrée sur la photo ci-jointe ?

2020-07-09_20-01-57_firefox.png

Share this post


Link to post

Oui exactement le même fonctionnement (sauf la vitesse car Unraid ne découpe pas les fichiers pour accélérer les transferts)

Share this post


Link to post

Pour moi, ça ne marche pas tout à fait comme le SHR.

Tu as toute la capacité de tous tes disques, sauf celui que tu utilises en parité (ou les deux).

 

Dans le cas que tu montres, ça tombe bien, mais si je fais la même simulation avec un petit changement (un 10To à la place d'un 12To), avec un SHR tu perds bien plus de capacité.

 

image.thumb.png.9151cfbb275b25c0a27cbba78ee728ff.png

Share this post


Link to post

Il y a deux versions du SHR, sur la v2 comme ta photo oui on perd mais sur la v1 on ne perd pas tant que ça ...

C'est chiant  j'ai pas encore trouvé le moyen de faire tourner unraid sur une machine virtuelle pour faire des test :/

Share this post


Link to post

Oups, tu as raison, je raconte des bêtises.

Je traînais une vieille config d'essai dans les menus du configurateur.

Share this post


Link to post
Posted (edited)

Salut.

Bon comme c'est pas vraiment possible de faire un unraid sur une machine virtuelle, j'ai bricoler un pc pour pouvoir le faire tourner et apprendre à maitriser le soft avant d'y aller avec la machine définitive.

 

Attention les yeux !

8ucciuRt.jpg

 

Ensuite pour le montage, j'ai d'abord monté le ssd de cache avec un disque de 2to, ajouter un second de 2to pour la parité et ensuite j'ai ajouté 2 autres disques de tailles différentes pour voir un peu le comportement général tout en y transférant des données au fur et à mesure.

 

Première grosse bonne surprise pour moi (car ce n'était pas clair pour moi), aucunes données perdues à chaque ajout de disques ! J'étais persuadé qu'il allait tout me formater à chaque fois pour la création du raid ^^

Par contre, comment cela se passe pour répartition des données entre chaque disques ? Car j'ai encore transféré des trucs et c'est toujours le même disque qui est chargé et rien est copié sur les autres. Est-ce que tout se fait automatiquement ou alors j'ai des options à cocher ?

 

 

2020-07-13_12-45-44_firefox.png

Edited by botteur

Share this post


Link to post

Là pour le moment je suis en train de voir le fonctionnement de Docker et autant pour Emby / Plex ça passe vraiment tout seul, autant pour MariaDB & Nextcloud je galère comme pas possible :/
Pourtant sous OpenMediaVault j'avais vraiment aucuns soucis mais là je vois vraiment pas ce que je fais de mal ... et j'ai toujours le même message d'erreur à la création du compte sur Nextcloud ... donc si vous aviez une idée pour moi avancer ...

 

 

2020-07-13_14-00-40_firefox.png

Share this post


Link to post

Je suppose que tu as suivi le Tuto de SpaceInvaderOne pour la création de la base sous MariaDB ? Il semblerait que l’accès à la base de données soit refusée. Revérifie bien que tu as bien les autorisations sur la base et avec l’user. 

Share this post


Link to post

Non pas vraiment, pour le moment j'y vais "à l'instinct" lol
je vais aller voir ce que le tuto raconte :)

Share this post


Link to post

Bonsoir !

J'ai une question au niveau du matos ! Pour le moment tous mes disques dur classiques sont branchés sur une carte sata pci-express. Si je suis amené à changer cette carte par une autre et que je rebranche tous les disques dans le même ordre, je perd tout (raid, parity, données & compagnie) ou cela ne change absolument rien unraid va reconnaitre mes hdd normalement ?

 

Merci !

Share this post


Link to post

J'attends toujours des pièces pour me lancer moi même alors les autres me corrigeront si je dis des bétises.

Normalement, unRAID fonctionne avec les numéros de série des disques, si tu changes de matériel ça ne devrait poser aucun problème.

 

Dans le doute, je te conseille tout de même de bien noter quels disques sont en data, parity, cache, etc.

En cas de soucis, tu n'auras qu'à le ré-assigner de la même façon et tout devrait rouler. Pour la parity, je crois qu'il faut différencier parity1 et 2 (mais tu n'es pas concerné).

Share this post


Link to post

Ok :)

Sous OMV ça fonctionnait comme ça, j'espérais que bcp qu'il en soit de même pour unRAID :)

Share this post


Link to post
Posted (edited)

Bonjour,

Je rencontre un petit soucis avec les docker, sur ma machine test j'avais pu installer tous les docker que je voulais mais ici sur ma machine définitive quand je veux en ajouter un il n'y a absolument rien dans l'onglet template et je ne comprends pas pourquoi. Pourtant il me semble avoir rien oublier ...

 

2020-07-24_09-36-48_firefox.png

 

2020-07-24_09-33-57_firefox.png

 

2020-07-24_09-32-59_firefox.png

Edited by botteur

Share this post


Link to post

De mémoire, il faut que tu passes par Community Apps pour générer les Templates (ou à la main via add container mais du coup c est à toi de tout paramétrer)

Share this post


Link to post

Désolé du HS mais c'est quoi ton theme FF Botteur ? J'aime beaucoup :D

Share this post


Link to post
59 minutes ago, Alex.b said:

Désolé du HS mais c'est quoi ton theme FF Botteur ? J'aime beaucoup :D

Voilà :D

 

 

2020-07-24_18-04-30_firefox.png

Share this post


Link to post
9 hours ago, Balooforever said:

De mémoire, il faut que tu passes par Community Apps pour générer les Templates (ou à la main via add container mais du coup c est à toi de tout paramétrer)

 

Alors j'ai fais quelques test et j'ai un début de solution. Quand je mets l'adresse ip de mon serveur en dhcp, les templates ça fonctionne super bien, aucuns soucis ! mais une fois que je passe en ip static, y'a plus rien qui marche ....

Share this post


Link to post
 
Alors j'ai fais quelques test et j'ai un début de solution. Quand je mets l'adresse ip de mon serveur en dhcp, les templates ça fonctionne super bien, aucuns soucis ! mais une fois que je passe en ip static, y'a plus rien qui marche ....
Bon visiblement c'est mon routeur qui faisait de la merde. Je l'ai reset et flasher sur DD-WRT et plus de problèmes !

Envoyé de mon OnePlus 6T en utilisant Tapatalk

Share this post


Link to post

Petite maj concernant l'avancement du projet.

Un truc qui me saoule pas mal, quand je vérifie mes "vieux" disques dur via le smart sous windows (via crystaldiskinfo), ça me met que mes disques sont OK !
Une fois sous unraid ça me met des erreurs dans tous les sens ! Enfin j'exagère c'est surtout une en particulier mais du coup comment savoir si ils sont fiable encore un moment ou pas.

 

 

2020-07-29_09-56-00_firefox.png

Share this post


Link to post

Il me semble que les erreurs CRC sont plutôt des erreurs dans la communication, soucis de connexion ou de contrôleur. Tant que ça n'évolue pas ça devrait aller.

Mais j'attends toujours ma mémoire pour installer unRAID pour la première fois alors tu vois bien mon niveau d'expertise. 😁

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.