[Support] FoxxMD - ozwdaemon


10 posts in this topic Last Reply

Recommended Posts

Application Name: ozwdaemon

Application Site: https://github.com/OpenZWave/qt-openzwave

Github Repo: https://github.com/OpenZWave/qt-openzwave

Docker Hub: https://hub.docker.com/r/openzwave/ozwdaemon

Template Repo: https://github.com/FoxxMD/unraid-docker-templates




ozwdaemon is a docker container for running the OpenZWave MQTT Adapter as well as a web GUI for managing your z-wave network with ozw-admin. In layman's terms this container can do the following:


  • Connect to your z-wave dongle and provide a website for managing your z-wave network
  • Bridge your z-wave network to an MQTT server (send z-wave events as messages and consume MQTT messages as z-wave commands)


ozwdaemon vs zwave2mqtt



More technical details can be found here


Which Should I Use?


  • If you want to use z-wave in conjunction with Home Assistant you should use this container as it is being developed alongside HA with the new z-wave integration
  • If you need the latest openzwave versions (going forward) you should consider this container as openzwave maintains it. zwave2mqtt will need to update their node wrapper translations before upgrading versions.
  • If you already use zigbee2mqtt and manage your network outside of HA (EX with node-red w/o HA integration) you should consider using zwave2mqtt as the message format will be resuable from your existing flows









Template Configuration:

  • MQTT Host -- IP Address of your MQTT server
  • USB Z-Wave Device -- The path on host (unraid) where your USB/serial device (z-wave dongle) is located. 
  • USB Path -- Environmental variable for the container path to the USB/serial device (z-wave dongle). This tells qt-openzwave where to look for the device in the container. It should be the same as USB Z-Wave Device
  • Web UI Port -- (Optional, default: 7800) The port to be used for accessing ozw-admin (for managing the z-wave network and MQTT connection)
  • MQTT Port -- (Optional, default: 1883) The port to connect to your MQTT server on
  • MQTT User -- (Optional) Username for MQTT authentication
  • MQTT Password -- (Optional) Password for MQTT authentication
  • Zwave Network Key -- (Optional) Existing key for your z-wave network. If not included secure inclusion is not possible.
  • ozw-admin Port -- (Optional, default: 1983) -- Port to access ozw-admin interface if using ozw-admin desktop GUI
  • Config -- (default: /mnt/user/appdata/ozw) -- Volume ozw will use to store configuration and log data


For Home Assistant


After setting up ozwdaemon and verifying your network is running follow the instructions for the new openzwave integration. Your devices should be discovered automatically shortly after the integration is added.

Edited by FoxxMD
Link to post
  • 2 months later...



I restarted my server yesterday and ozwdaemon has since refused to start up. It is giving me the following error log (attached). I couldn't find anything when try to google the status code 254. So far I have tried restart the MQTT/ozwdaemon docker and re-enter the username/password, but nothing worked.


Link to post

@jfoxwu These two issues are similar to what your logs look like: #165 and #163. Can you confirm that the IP address you are using for MQTT ( is actually an MQTT server and is reachable?


Also, are there any further details in files located in the folder you have mapped to Config? (default folder is at /mnt/user/appdata/ozw/logs)

Edited by FoxxMD
Link to post

@FoxxMD, thank you for the reply.

I have double checked the IP address, and it is correct. How do I check if the MQTT server is reachable or not?


I don't see ozw folder in my appdata share. The docker's configuration is shown in the attached picture. I don't find any filed to map the Config folder like other dockers I had. Is this something I need to add manually? Or am I looking at the wrong place?


Edited by jfoxwu
Link to post

@jfoxwu you can test if MQTT is reachable by using the MQTT integration in your Home Assistant instance (listen to '#') or by using one of the commandline tools show in the docs (if you install them on your machine)


for the config volume...oops! Somehow that went overlooked in my CA template for this. I have updated the template...you can wait for CA to update the template and then use the new one or go ahead and create it yourself. it should look like this:



Container Path: /opt/ozw/config

Host Path: /mnt/user/appdata/ozw


I also misspoke in my last post -- you'll want to look in /mnt/user/appdata/ozw/logs for more detailed information.

Link to post

@FoxxMD, thank you for the assistance. It is working now.


Upon inspecting the log, it seems like the problem was not being able to connect to MQTT due to incorrect username/password.

I re-entered the username/password in the MQTT/ozwdaemon dockers several times but that did not fix the problem.

I ended up having to delete everything inside "passwords.mqtt" file and start fresh.

Link to post
  • 2 weeks later...
  • 4 weeks later...

It happened again. After server reboot, ozwdaemon cannot start back up again. I have attached the logs here.

Going through it, it seems like some old zwave device is stuck in the stick and causing problems. Can someone please help verify this? Perhaps I need to factory reset the stick?


Link to post

Can someone provide a template for what the Network Key setting should look like when spinning up the container? Specifically the item indicated in red in the screenshot. Should the format be 



0x00, 0x00, 0x00...


Edited by Rick_Sanchez
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.