Jump to content
  • [6.7.2] no NICs in VM using OPNsense (FreeBSD)


    peter76
    • Urgent

    I am running my Firewall (OPNsense, based on FreeBSD) in a VM on UNRAID using Network Bridges as virtual NICs.

    Using previous versions of OPNsense (versions <= 19.1.10_1), NICs were recognized correctly, if and only if I set machine to Q35-2.6.

     

    Problem:
    Using latest Version of OPNsense (Version 19.7), NICs aren't recognized any more, so I had to set my Firewall back to older Version to run (using a Backup of vdisk1.img).

     

    some testing I did:
    Creating a new VM using OPNsense-19.7-OpenSSL-dvd-amd64.iso, two existing Bridges as virtual NICs results in same behavior: NICs aren't recognized in VM.
    Testing different types of machine (Q35-2.6, Q35-2.11, Q35-3.1) always results in having no NICs in VM.

    Atteched there are Screeshots of my Testing-VM and the diagnostics.zip.

    test3of3.png

    test2of3.png

    test1of3.png

    tower-diagnostics-20190728-2149.zip



    User Feedback

    Recommended Comments

    Does FreeBSD support your adapter?

     

    I've used versions 19.1 and 19.7 of OPNsense using an intel nic with no problems.

    Share this comment


    Link to comment
    Share on other sites

    You probably need to set the type of card they are emulated as.

    Share this comment


    Link to comment
    Share on other sites

    @GHunter
    I'm also using INTEL NICs on my bare metal unRAID, but the NICs aren't passed through to the VM, they are emulated. So it should not matter if oder if not FreeBSD supports my INTEL adapters ??

     

    @saarg

    Where can I set the type of card? I can't find a option in the GUI.

    Note: using the older Version of FreeBSD/OPNsense I don't have to set a type.

    Edited by peter76

    Share this comment


    Link to comment
    Share on other sites

    Sounds like you're running nested virtualization. I can't help if that's the case and it's unsupported by LT. Doesn't mean it won't work of course. Good luck.

    Share this comment


    Link to comment
    Share on other sites

    no no no - it's not nested, have a look at my screenshot in my first posting..
    I use the Bridge of unRAID as it is suggested in GUI for creating a VM.

    Share this comment


    Link to comment
    Share on other sites

    The option to set which card it's emulated as is either in the advanced menu, toggle the switch in the top right corner of the template, or edited in xml view.

    Thinking about it, the toggle might just be switching between template view and xml view these days.

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.