chalboly

Moderators
  • Content Count

    28
  • Joined

  • Last visited

Everything posted by chalboly

  1. I have the latest version of OpenCore and SecureBootModel is disabled, unfortunately the VM hangs while updating to Big Sur. I've tried both upgrading from within macOS and booting from the installer. It hangs when the system restarts and I need to force stop the VM, the boot picker does not show any other option but again boot into 10.5.7. When using the installer, it just hangs after about 10min into the installation. Any ideas what may be happening? The guide says for VMs ForceSecureBootScheme=true may be necessary, but only if SecureBootModel is enabled, either way I'm not sure where else
  2. Thanks for the info. I just tried to update but it keeps saying an error occurred.
  3. So safe to update to Big Sur with latest OpenCore version?
  4. So, can we say that one can update from Catalina to Big Sur Dev Beta with the latest OpenCore and Kexts injected with OC? I don't have kexts to manually install and have SIP enabled on my VM.
  5. Gracias por el update @SpencerJ, estoy revisando y agregaré comentarios.
  6. @SpencerJ @Kuton Había olvidado hacer submit de los comentarios, ya los deberían ver en el link del PR.
  7. He revisado el PR de @Kuton y me parece todo bien, sólo hice algunos comentarios para considerar unos cambios. @SpencerJ Seguiré revisando.
  8. Thanks for trying it out! I don’t think it’ll work until there is official support with Opencore. One of the new features of macOS 11 is a signed system volume, similar to iOS, I hope that doesn’t affect anything in the hackintosh world (beside the transition to a custom silicon).
  9. Hola @SpencerJ, La traducción que hiciste está excelente, sólo recomendaría los siguientes cambios: Se podría agregar "de red" para interfaz en la primera oración, sólo para ser más específicos: Creo que suena mejor decir "con el resultado del comando" en vez de "salida", esto se aplicaría en las siguientes: Por último, creo que se puede usar otra traducción para "CPU thread pairings" en vez de "pares de hilos". No estoy seguro cual sería la mejor pero voy a revisar:
  10. 10.15.5 here, updated from 0.5.7 to 0.5.9 with no issues. New version seems to have few KVM-QEMU related fixes based on the release notes. There is also a new supplemental update to 10.15.5.
  11. Any successful update to 10.15.5 yet? Making a backup now but I'm still on Opencore 0.5.7, I was waiting on next Monday's release.
  12. Is it possible to expose system temperatures (CPU, NVMe, etc) to macOS? My main concern is the NVMe temp readings, as I'm passing through the entire device and can't see temp info in Unraid.
  13. Thanks @david279. I can see you have all the support files my installation is missing, are you using MacPro7,1 as well?
  14. Can you guys check if Dictionary or Voice Control (Accessibility in System Preferences) is working for you? I just noticed my installation is missing several assets in /System/Library/AssetsV2, no dictionary is installed except Wikipedia, so functions like Lookup (right click a word and select Lookup) does not work. I compared the content of this folder to the ones on my MacBook Pro and Mac mini, and the VM is missing a lot of asset files. What is also strange is that any attempt to download or fetch new dictionaries from Apple, or enable Voice Control which requires downloading a
  15. Thanks for pointing that out! I had an old firmware and just updated to the latest version, was able to boot to macOS and no more timeouts. Will continue to test and see how the VM performs.
  16. I also have a Samsung 970 Evo Plus, but in my case I can't boot without that kext. The device seems to time out at book, and when using the case I can boot but sometimes I it panics and it has do to with IONVMeFamily.kext. Would you mind sharing your XML? Have you enabled any other specific quirks in the Opencore config?
  17. Are you using the NVMeFix kext? I am trying to passthrough my NVMe drive and though I can boot macOS, it sometimes panics at boot or the VM crashes while on use. I had to go back to passing through the drive as a Virtio block as it is more stable than directly using the NVMe.
  18. Yes, I replaced the boot files on the EFI partition, added OpenRuntime and removed FWRuntimeServices and updated my config.plist, used OCConfigCompare. There are several new keys I needed to add and two or three that I had to remove. Make sure to remove those old keys, otherwise it won't boot. It is working for me, I still have Target set to 83 and it is booting.
  19. @Leoyzen @ghost82 I am running 0.5.7 and have Target set 83.
  20. @limetech That's the latest firmware I found too. Thank you!
  21. Is it possible to uncompress the file system, add the file and recompress?
  22. @Leoyzen Thanks, I just tested with a USB Bluetooth device, based on the same chipset BCM920702 which is supported without additional kexts, but the same issue persists. There is audio dropouts when connected to Bluetooth headphones, Continuity works sporadic and Apple Watch unlock does not stay connected to the watch. There are a lot of errors in the logs about this. My Wi-Fi is natively supported (BCM4360). I also moved the USB Bluetooth right next to my devices using an extension. The signal did not improve much (checking with Bluetooth Explorer), and had the same issues, so not sure what e
  23. @Leoyzen I decided to just pass through a different USB controller (ASM1042A) and is working fine. Bluetooth is internal USB on my motherboard so I'm just passing through the USB device, works without any patches except that I am having issues with connected devices. If I use AirPods they disconnect after a while or have audio dropouts. Apple Watch unlock works for a moment and then disconnects. Handoff is also intermittent, so something seems off. Do you know if SSDT patching is required? Map the virtual USB ports correctly depending on the SMBios?
  24. My current VM is unable to automatically update the firmware for a built-in USB Bluetooth device I'm attaching to the VM, the solution to this would be to inject the updated firmware when Unraid boots and start the VM with the firmware already updated. However, Unraid does not seem to be able to update it on its own as the firmware is missing: Apr 3 14:31:37 Tower kernel: bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0b05-180a.hcd failed with error -2 Apr 3 14:31:37 Tower kernel: Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0b05-180a.hcd not found I can't manuall
  25. @Leoyzen Unfortunately it does not seem to be supported by USBInjectAll.kext. What is strange is that I can see the controller and the devices connected, this controller is internal and the only device is the Bluetooth, but this is not detected at boot but rather later when in macOS and when I open the IOregister app. Of course Bluetooth does not work because it can't be patched by BrcmPatchRAM at boot.