betaman

Members
  • Posts

    535
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

betaman's Achievements

Enthusiast

Enthusiast (6/14)

2

Reputation

  1. Not really...I was rallying off your firewall’d comment! Perhaps you just meant the VPN containers themselves, but I was looking for some guidance on the best configuration given my use case?
  2. As a former privoxy user, are you saying my best path forward is the following: use case: *arr dockers, kodi using Privoxy and possibly enabling Emby for remote viewing Bind all *arr dockers to DelugeVPN, bind NZBget to DelugeVPN, still run Kodi thru DelugeVPN privoxy, and I’m not sure on the last one so wondering if it influences my decision at all since I need Kodi and Emby to talk to each other as well.
  3. Haha, I’m in the same position and also looking for a push! In my case, I want to be sure this is the best method for Emby (remote viewing) and Kodi with a VPN (currently using privoxy via DelugeVPN). Between wiregaurd, Jackett etc, I feel like there’s more than a couple ways to skin this cat!
  4. Doesn’t really answer your question as to why you can’t get NZBgetVPN working but with some recent changes, it might be worth looking into binding non-VPN comtainers to a VPN container. In this case, Deluge or Jackett seem be the most popular. This would allow you to use the non-VPN version of NzBget with a VPN.
  5. I had a similar issue testing a Privoxy connection and was relying on the test connection button in Sonarr (Radarr and Lidarr have same). The test always failed so I rolled back the DelugeVPN docker and the test still failed. I was like wtf, then I cleared my queue of downloads and tried to manually initiate a download to see if the *arr dockers would pass to NZBget and sure enough they did but the test connection still fails! I guess the moral of the story is don’t rely on on the connection test and try a download first before thinking it doesn’t work.
  6. Yes, but short of installing Jackett (which I tried but none of my indexers are listed), when I bypass internal addresses then my NZBgetVPN doesn’t work with *arr apps (or at least I thought it didn’t because of false negative on Sonarr connection test). It’s probably worth having SpaceInvader post a tutorial for us morons that can’t get things working correctly without rolling back DelugeVPN. There’s so many options on how to connect now that even if I’m willing to change my configuration (which I am), I have no idea which is best for my use case (ie *arr apps, NzBget and Deluge with VPN, Kodi with VPN currently using Privoxy and possibly remote access viewing for Emby which I haven’t really tried but did look into Wireguard and was lost). 🤷🏼‍♂️ Edit: didn’t realize I wasn’t running binhex Sonarr docker. Migrating over to it solved my (test) connection issue.
  7. Privoxy user here and rolling back DelugeVPN worked for me. The weird part is I still get an error from Sonarr that it can’t connect but it’s working fine?! also, for 6.9 users, what happened to the shortcut to a docker log on the docker tab?
  8. No worries. Yeah I’m just using Privoxy thru DelugeVPN. In theory, NZBgetVPN should behave just like DelugeVPN except that binnex doesn’t manage a version of it...
  9. Ok, so I pulled the latest docker image for DelugeVPN and manually added “VPN_OUTPUT_PORTS” env variable. I set value to port of NZBgetVPN (6789) but still can’t connect to it inside of the *arr containers?
  10. Yeah, binding nzbget to DelugeVPN was going to be the next thing I tried. @Rollingsound514: I also suggest replacing tower with your IP address. The only other thing that’s different with Jackett is there doesn’t appear to be a setting for ignoring your local IP addresses. I had the same issue as you gave with Jackett with Radarr/Sonarr/Lidarr until I added my local IP range to the ignore list in the proxy settings of these dockers. Ultimately, I think we’re in the same boat and should bind these dockers to DelugeVPN.
  11. Sorry, this is a little over my head. Are you saying there’s a no_proxy env variable in NZBgetVPN? Attached is how I have Radarr (and Sonarr/Lidarr) setup to use Privoxy thru DelugeVPN. To get it working with the latest version of Deluge, I had to include my server address in the ignored addresses list. Then I was able to connect to both my indexers and the Deluge download client from within each docker. However, with these settings I lost the connection to NZBgetVPN from within the dockers using Privoxy.
  12. My server address is 192.168.1.71 so I was using 192.168.1.0/24 as my LAN_IP setting in both DelugeVPN and NZBgetVPN. With the DelugeVPN update, you’re right that ADDITIONAL_PORTS env variable is not my issue but it is in fact being used by Binhex for DelugeVPN when binding other dockers to Deluge network. I added this variable AND set dockers (ie Sonarr, Radarr, Lidarr etc) to ignore my internal ip addresses under proxy settings for each since I’m using privoxy. The latter is what enabled these dockers to connect to Deluge as a download client but now I’ve lost NZBget functionality (meaning the dockers can’t connect to it as a download client but I can access the webui of NZBgetVPN with VPN enabled).
  13. Sorry, thought you were using Privoxy. If you’re using Jackett then net binding to Deluge is probably your best option.
  14. Anyone here using NZBgetVPN along with DelugeVPN? I’m using privoxy for Radarr/Sonarr/Lidarr etc thru DelugeVPN and I’m able to connect to my indexers and DelugeVPN through each docker (after putting my server address in the ignore list) but now NZBgetVPN isn’t able to connect since the update to DelugeVPN. I assume this issue is related to the one referenced prior about dockers “outside the VPN” communicating with dockers inside it but then again, I’m using privoxy so not sure it’s the same issue? Can anyone confirm? Bungy (docker creator for NZBgetVPN) is asking about my network LAN_IP setting but this hasn’t changed (ie UnRAID server is 192.168.1.71 and LAN_IP setting is 192.168.1.0/24).
  15. You set the ignored address in the proxy settings of the dockers using the proxy (eg Sonarr, Radarr etc). DelugeVPN doesn’t need any change. As far as your server IP, just give it a static IP from your address range. I reserve the address in my router and set UnRAID to always assign the same address under network settings.