B4rny

Members
  • Posts

    13
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

B4rny's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Did you clone and build the container as described in the description?
  2. Hi @Reziem nice to see that someone is dealing with Misskey. Glad you got it working. As I had written, the template and the description are not ready yet. I got it to work, but my profile pictures, for example, didn't load either. I haven't even bothered to look at the search function. That would probably still be important. Unfortunately, I haven't had the time to look into it further. And I won't be able to do it this week. Thank you for that, I'll see if I need to include it. I haven't had much to do with PostgreSQL so far, and the database has been driving me crazy with the last few templates. If you don't adjust the permissions of the folder, it was previously not possible to upload images to Misskey. chown -hR 991:991 /mnt/user/appdata/misskey/files/ I guess that's the problem here too. Even your logs don't say permission denied. Can you try changing the permissions if you haven't already? https://github.com/misskey-dev/misskey/issues/9564#issuecomment-1382743169 Otherwise, at the moment I don't know what else to do, but you could just ask on GitHub. The template uses the official image. I'll deal with it again when I have time.
  3. Got it. My description was wrong. You have to create the file that's getting created as a folder. So instead of creating a docs-config.yaml you have to create a docs-config.local.yaml https://github.com/codex-team/codex.docs/blob/main/docker-compose.yml I updated the template description.
  4. That's no template update. The Notice was there all the time. What could I improve so that you read the description before you click install?
  5. Thank you for clarification. That's something I can work with. You have to use a chromium based browser. I will update the Template. https://github.com/toeverything/AFFiNE/issues/1199#issuecomment-1447556131
  6. Blaze is a file sharing progressive web app(PWA) that allows users to transfer files between multiple devices. I've already tried to create a template myself, but I failed at the frontend. There are 2 options which are the Client and Server separately and the combined version. The combined version would be much better for the community applications. I have no problems with the separated version and the instructions from noted.lol. But I am not able to get the combined version working. But this version would be much easier to use for other users. https://hub.docker.com/r/akashhamirwasia/blaze The Environment variables are a little hidden as a toggle under Build process. I think it's a useful application that some users would like. If you get the template working. Thank you!
  7. How am I supposed to help with this? You don't even say which template / application. Check the logs. That's probably the best advice I can give you.
  8. Hi, the memos template contains the original repository. The project is not that old, so I would guess you can do the following. Install the docker container and then stop it Copy and paste the old SQLite DB into the new directory (overwrite the new one) Start the container If there are errors you will see them in the Logs and you can ask at Github for help. If you don't delete the old folder with the SQLite DB, you should always be able to roll back to the old version. So it would be a good idea to backup the DB.
  9. Templates Affine Github: https://github.com/toeverything/AFFiNE Demo: https://app.affine.pro/ Documentation: https://community.affine.pro/ Answer Github: https://github.com/answerdev/answer Demo: https://app.affine.pro/ Documentation: https://answer.dev/docs/ Check the Environment Variables. CodeX Docs Github: https://github.com/codex-team/codex.docs Demo: https://docs-demo.codex.so/about-this-demo Documentation: https://docs-demo.codex.so/getting-started Short Guide: Create a docs-config.local.yaml before you install the docker container. Link the docs-config.local.yaml to the docs-config.yaml like the example configuration variable inside the template. Memos Github: https://github.com/usememos/memos Docker Hub: https://hub.docker.com/r/neosmemo/memos Misskey Github: https://github.com/misskey-dev/misskey Documentation: https://misskey-hub.net/en/docs/install/docker.html Guide: See template description Rallly Github: https://github.com/lukevella/rallly Github Selfhosted Topic: https://github.com/lukevella/rallly-selfhosted Documentation: https://support.rallly.co/introduction If you limit access, you should also limit the allowed email addresses, otherwise anyone can register. Gmail SMTP settings: Every secure / TLS settings to "true", port "465" and login with app password. SerpBear Github: https://github.com/towfiqi/serpbear Docker Hub: https://hub.docker.com/r/towfiqi/serpbear Documentation: https://docs.serpbear.com/ Short Guide: Install the container and change all Variables (user, password, secret, api key). Create a free 3rd party scraping account, for example at ScrapingAnt. Open the SerpBear settings, choose your scraping provider and paste the api key. ScrapingAnt rejected my .de subdomain. ScrapingRobot is working fine for me. Maybe you have to test some offered providers yourself. Guide to add the Search Console: https://docs.serpbear.com/miscellaneous/integrate-google-search-console Stirling PDF Github: https://github.com/Frooodle/Stirling-PDF Swing Music Github: https://github.com/swing-opensource/swingmusic Guide: See template description
  10. I think you missed setting up WebSocket. Without, Vaultwarden doesn't sync instantly, and you have to relog or sync other Applications manually. Maybe it was just me, but when I check my Browser Console (F12 > Console), I had multiple WebSocket errors. After a bit of research, I found this, and it worked. The first entry has nothing to do with the WebSocket and just blocks external /admin access. I think that's also a good idea. The Port 3012 is the WebSocket, so don't change it. Go to the Proxy Host inside Nginx Proxy Manager and add this to the Advanced Tab. location /admin { return 404; } location / { proxy_pass http://<ip>:<port>; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; } location /notifications/hub { proxy_pass http://<ip>:3012; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; } location /notifications/hub/negotiate { proxy_pass http://<ip>:<port>; } Or if you want to use the Custom locations Tab, here's what it looks like. When you now refresh Vaultwarden, log in to your vault and check the Browser Console (F12 > Console), there should be no red error and something like this. [date] Information: WebSocket connected to wss://<domain>/notifications/hub?access_token=<token> Anyway, thanks for all your videos. I learned a lot from your channel. Without you, I wouldn't be using Unraid today.
  11. Ja gut, mit Netzwerken muss ich mich eindeutig noch etwas mehr beschäftigen. Das war mir so nicht bewusst. Nichts, der läuft super. Ich wollte einfach nur einen Container mit Nginx statt Apache ausprobieren. Dazu passend wollte ich mir noch anschauen, wie man selber Container in Unraid erstellt und Vorlagen verwendet.
  12. War mir ebenfalls aufgefallen. Das ist nicht einheitlich festgehalten. Hatte aber beides probiert, hat nur nichts geändert. Vielen Dank für diese Erklärung! Das ist die Lösung. Mir war diese Variable ebenfalls aufgefallen und ich hatte mich schon gefragt, was sie bedeuten soll und ebenfalls einige Male geändert. Aber ich hatte nicht den Zusammenhang verstanden. Des Weiteren war mein Port 8080 schon in Nutzung. Was vermutlich das Hauptproblem war. Einen eigenen Port auf 8080 und 8443 zu verlinken, macht ja eigentlich keinen Sinn. Das wäre dann ja doppelt gemoppelt (8090 > 8080 > 80). Ich habe ein bisschen herumprobiert und nur die Nginx Ports anzugeben hat nicht funktioniert. Also muss man wohl beides angeben. NGINX_HTTP_PORT_NUMBER 8090 Port 8090:8090 Nochmals vielen Dank für die Hilfe! Und hier noch die funktionierende Version: <?xml version="1.0"?> <Container version="2"> <Name>bitnami-wordpress-nginx</Name> <Repository>bitnami/wordpress-nginx</Repository> <Registry>https://hub.docker.com/r/bitnami/wordpress-nginx</Registry> <Network>bridge</Network> <MyIP/> <Shell>sh</Shell> <Privileged>false</Privileged> <Support/> <Project/> <Overview/> <Category/> <WebUI>http://[IP]:[PORT:8090]/</WebUI> <TemplateURL/> <Icon>https://s.w.org/style/images/about/WordPress-logotype-wmark.png</Icon> <ExtraParams/> <PostArgs/> <CPUset/> <DateInstalled>1650058396</DateInstalled> <DonateText/> <DonateLink/> <Description/> <Networking> <Mode>bridge</Mode> <Publish> <Port> <HostPort>8090</HostPort> <ContainerPort>8090</ContainerPort> <Protocol>tcp</Protocol> </Port> <Port> <HostPort>4390</HostPort> <ContainerPort>4390</ContainerPort> <Protocol>tcp</Protocol> </Port> </Publish> </Networking> <Data> <Volume> <HostDir>/mnt/user/appdata/wordpress/</HostDir> <ContainerDir>/bitnami</ContainerDir> <Mode>rw</Mode> </Volume> </Data> <Environment> <Variable> <Value>8090</Value> <Name>NGINX_HTTP_PORT_NUMBER</Name> <Mode/> </Variable> <Variable> <Value>4390</Value> <Name>NGINX_HTTPS_PORT_NUMBER</Name> <Mode/> </Variable> <Variable> <Value>192.168.178.xx</Value> <Name>WORDPRESS_DATABASE_HOST</Name> <Mode/> </Variable> <Variable> <Value>3306</Value> <Name>WORDPRESS_DATABASE_PORT_NUMBER</Name> <Mode/> </Variable> <Variable> <Value>bitnami_wordpress</Value> <Name>WORDPRESS_DATABASE_NAME</Name> <Mode/> </Variable> <Variable> <Value>bn_wordpress</Value> <Name>WORDPRESS_DATABASE_USER</Name> <Mode/> </Variable> <Variable> <Value>******</Value> <Name>WORDPRESS_DATABASE_PASSWORD</Name> <Mode/> </Variable> <Variable> <Value>256M</Value> <Name>PHP_MEMORY_LIMIT</Name> <Mode/> </Variable> <Variable> <Value>512M</Value> <Name>PHP_UPLOAD_MAX_FILESIZE</Name> <Mode/> </Variable> <Variable> <Value>no</Value> <Name>ALLOW_EMPTY_PASSWORD</Name> <Mode/> </Variable> </Environment> <Labels/> <Config Name="http nginx" Target="NGINX_HTTP_PORT_NUMBER" Default="" Mode="" Description="Container Variable: NGINX_HTTP_PORT_NUMBER" Type="Variable" Display="always" Required="false" Mask="false">8090</Config> <Config Name="http" Target="8090" Default="" Mode="tcp" Description="Container Port: 8090" Type="Port" Display="always" Required="false" Mask="false">8090</Config> <Config Name="https nginx" Target="NGINX_HTTPS_PORT_NUMBER" Default="" Mode="" Description="Container Variable: NGINX_HTTPS_PORT_NUMBER" Type="Variable" Display="always" Required="false" Mask="false">4390</Config> <Config Name="https" Target="4390" Default="" Mode="tcp" Description="Container Port: 4390" Type="Port" Display="always" Required="false" Mask="false">4390</Config> <Config Name="/bitnami" Target="/bitnami" Default="" Mode="rw" Description="Container Path: /bitnami" Type="Path" Display="always" Required="true" Mask="false">/mnt/user/appdata/wordpress/</Config> <Config Name="WORDPRESS_DATABASE_HOST" Target="WORDPRESS_DATABASE_HOST" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_HOST" Type="Variable" Display="always" Required="true" Mask="false">192.168.178.50</Config> <Config Name="WORDPRESS_DATABASE_PORT_NUMBER" Target="WORDPRESS_DATABASE_PORT_NUMBER" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_PORT_NUMBER" Type="Variable" Display="always" Required="true" Mask="false">3306</Config> <Config Name="WORDPRESS_DATABASE_NAME" Target="WORDPRESS_DATABASE_NAME" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_NAME" Type="Variable" Display="always" Required="true" Mask="false">bitnami_wordpress</Config> <Config Name="WORDPRESS_DATABASE_USER" Target="WORDPRESS_DATABASE_USER" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_USER" Type="Variable" Display="always" Required="true" Mask="false">bn_wordpress</Config> <Config Name="WORDPRESS_DATABASE_PASSWORD" Target="WORDPRESS_DATABASE_PASSWORD" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_PASSWORD" Type="Variable" Display="always" Required="true" Mask="true">******</Config> <Config Name="PHP_MEMORY_LIMIT" Target="PHP_MEMORY_LIMIT" Default="" Mode="" Description="Container Variable: PHP_MEMORY_LIMIT" Type="Variable" Display="always" Required="false" Mask="false">256M</Config> <Config Name="PHP_UPLOAD_MAX_FILESIZE" Target="PHP_UPLOAD_MAX_FILESIZE" Default="" Mode="" Description="Container Variable: PHP_UPLOAD_MAX_FILESIZE" Type="Variable" Display="always" Required="false" Mask="false">512M</Config> <Config Name="ALLOW_EMPTY_PASSWORD" Target="ALLOW_EMPTY_PASSWORD" Default="" Mode="" Description="Container Variable: ALLOW_EMPTY_PASSWORD" Type="Variable" Display="advanced" Required="false" Mask="false">no</Config> </Container>
  13. Hallo zusammen, ich versuche aktuell bitnami/wordpress-nginx über Unraid / Docker zu installieren. Es ist der erste Docker Container, welchen ich in Unraid erstelle. Vorher hatte ich Portainer auf einem Pi genutzt. Ich bin mir nicht ganz sicher, wo mein Problem liegt. Ich gehe davon aus, dass mir eine grundlegende Sache nicht bewusst ist, oder mir eine essenzielle Sache in diesem sehr umfangreiche dokumentierten Container nicht aufgefallen ist. Mein Problem, kurz und knapp: Ich komme nicht auf das Frontend. (ERR_CONNECTION_REFUSED) Das bisherige Vorgehen: Datenbank über Adminer in der externen MariaDB anlegen. Nutzer anlegen und Rechte für die Datenbank zuweisen. Der offiziellen docker-compose.yml folgen und den Container so in Unraid anlegen. Das habe ich natürlich schon mit diversen Änderungen probiert. Die folgende Konfiguration müsste nach meinem Verständnis korrekt sein. <?xml version="1.0"?> <Container version="2"> <Name>wordpress-nginx</Name> <Repository>bitnami/wordpress-nginx</Repository> <Registry>https://hub.docker.com/r/bitnami/wordpress-nginx</Registry> <Network>bridge</Network> <MyIP/> <Shell>sh</Shell> <Privileged>false</Privileged> <Support/> <Project/> <Overview>WordPress Nginx</Overview> <Category/> <WebUI>http://[IP]:[PORT:8090]/</WebUI> <TemplateURL/> <Icon>https://s.w.org/style/images/about/WordPress-logotype-wmark.png</Icon> <ExtraParams/> <PostArgs/> <CPUset/> <DateInstalled>1650036972</DateInstalled> <DonateText/> <DonateLink/> <Description>Beschreibung</Description> <Networking> <Mode>bridge</Mode> <Publish> <Port> <HostPort>8090</HostPort> <ContainerPort>80</ContainerPort> <Protocol>tcp</Protocol> </Port> <Port> <HostPort>4390</HostPort> <ContainerPort>443</ContainerPort> <Protocol>tcp</Protocol> </Port> </Publish> </Networking> <Data> <Volume> <HostDir>/mnt/user/appdata/wordpress</HostDir> <ContainerDir>/bitnami/wordpress</ContainerDir> <Mode>rw</Mode> </Volume> </Data> <Environment> <Variable> <Value>192.168.178.xx</Value> <Name>WORDPRESS_DATABASE_HOST</Name> <Mode/> </Variable> <Variable> <Value>3306</Value> <Name>WORDPRESS_DATABASE_PORT_NUMBER</Name> <Mode/> </Variable> <Variable> <Value>bitnami_wordpress</Value> <Name>WORDPRESS_DATABASE_NAME</Name> <Mode/> </Variable> <Variable> <Value>bn_wordpress</Value> <Name>WORDPRESS_DATABASE_USER</Name> <Mode/> </Variable> <Variable> <Value>******</Value> <Name>WORDPRESS_DATABASE_PASSWORD</Name> <Mode/> </Variable> <Variable> <Value>no</Value> <Name>ALLOW_EMPTY_PASSWORD</Name> <Mode/> </Variable> <Variable> <Value>256M</Value> <Name>PHP_MEMORY_LIMIT</Name> <Mode/> </Variable> <Variable> <Value>512M</Value> <Name>PHP_UPLOAD_MAX_FILESIZE</Name> <Mode/> </Variable> </Environment> <Labels/> <Config Name="Container Port" Target="80" Default="" Mode="tcp" Description="Connects to internal port 80 (Ex. 8090:80)" Type="Port" Display="always" Required="false" Mask="false">8090</Config> <Config Name="https" Target="443" Default="" Mode="tcp" Description="Container Port: 443" Type="Port" Display="always" Required="false" Mask="false">4390</Config> <Config Name="www" Target="/bitnami/wordpress" Default="" Mode="rw" Description="Container Path: /path/to/wordpress-persistence:/bitnami/wordpress" Type="Path" Display="always" Required="false" Mask="false">/mnt/user/appdata/wordpress</Config> <Config Name="WORDPRESS_DATABASE_HOST" Target="WORDPRESS_DATABASE_HOST" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_HOST" Type="Variable" Display="always" Required="false" Mask="false">192.168.178.xx</Config> <Config Name="WORDPRESS_DATABASE_PORT_NUMBER" Target="WORDPRESS_DATABASE_PORT_NUMBER" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_PORT_NUMBER" Type="Variable" Display="always" Required="false" Mask="false">3306</Config> <Config Name="WORDPRESS_DATABASE_NAME" Target="WORDPRESS_DATABASE_NAME" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_NAME" Type="Variable" Display="always" Required="false" Mask="false">bitnami_wordpress</Config> <Config Name="WORDPRESS_DATABASE_USER" Target="WORDPRESS_DATABASE_USER" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_USER" Type="Variable" Display="always" Required="false" Mask="false">bn_wordpress</Config> <Config Name="PHP_MEMORY_LIMIT" Target="PHP_MEMORY_LIMIT" Default="" Mode="" Description="Container Variable: PHP_MEMORY_LIMIT" Type="Variable" Display="always" Required="false" Mask="false">256M</Config> <Config Name="PHP_UPLOAD_MAX_FILESIZE" Target="PHP_UPLOAD_MAX_FILESIZE" Default="" Mode="" Description="Container Variable: PHP_UPLOAD_MAX_FILESIZE" Type="Variable" Display="always" Required="false" Mask="false">512M</Config> <Config Name="WORDPRESS_DATABASE_PASSWORD" Target="WORDPRESS_DATABASE_PASSWORD" Default="" Mode="" Description="Container Variable: WORDPRESS_DATABASE_PASSWORD" Type="Variable" Display="always" Required="false" Mask="false">******</Config> <Config Name="ALLOW_EMPTY_PASSWORD" Target="ALLOW_EMPTY_PASSWORD" Default="" Mode="" Description="Container Variable: ALLOW_EMPTY_PASSWORD" Type="Variable" Display="advanced" Required="false" Mask="false">yes</Config> </Container> Ich versuche verzweifelt eine Fehlermeldung zu finden, um der Ursache auf die Spur zu kommen. Die Container Logs zeigen keinen Fehler. Der Container verbindet sich mit der Datenbank und es werden auch die typischen Tabellen angelegt. Frontend weder per https noch per http aufrufbar. Ich weiß nicht mehr, wo ich noch ansetzen kann. Hat jemand eine Idee für mich?