Jump to content

aptalca

Community Developer
  • Content Count

    3050
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by aptalca

  1. passwd username won't work because it's not using pam See the readme instructions about disabling the "admin" user, reverse that to re-enable admin user, restart container, log in with "admin/password", make your changes to your main user, and then disable admin user again.
  2. Create a cname in cloudflare with just an asterisk as the name "*", pointing to the A record for your domain and that's it. Then in swag docker settings, set the subdomains variable to "wildcard" without the quotes.
  3. It's code server functionality and it's explained in their docs. Our image supports the domain name setup via env var and swag's built-in proxy conf allows it by default. You just need to add "*.code-server.yourdomain.com" to extra domains in swag so your cert covers the sub-subdomains of code server. (Or XXXX.code-server.yourdomain.com of your doing http validation and can't do wildcard)
  4. There is only ever one cert generated with this image and it contains all the names as SANs
  5. I use authelia and it works great. There is no webui for user management yet (I hear it's in the works), but you can set up the users in a number of ways including ldap (I use a simple yaml file). See here: https://blog.linuxserver.io/2020/08/26/setting-up-authelia/ For accessing the domain on lan, you need either a hairpin nat or nat loopback (if your router supports it), or you can set up a split dns (where you tell your local dns to resolve the domain to the unraid lan ip). The main caveat is that swag has to use port 443 on the host, which means you'll have to change unraid's https port to a different one first. Afterwards all requests for https://yourdomain.com will resolve to unraid and the client will connect to swag directly on lan (for http to https redirect, you'd need to change unraid's port 80 as well, so swag can use it, but I don't do that and instead only use the https endpoint so only port 443 goes to swag). Google the three terms I mentioned above and you'll find plenty of info for your router/setup.
  6. You probably had cloudflare cache/proxy turned on, which we recommend against. It's explained in the docs article linked in the first post
  7. Looks like you modified your confs and referenced a custom cert. Our image does not use such a cert out of the box.
  8. You shouldn't need that. The latest updates to nginx.conf and proxy.conf auto enable websockets when needed.
  9. Did you add your network subnet to the routing section in the gui settings?
  10. Everything's up to date. It's explained in the readme
  11. Both would work, but simply copying the mapped folders is sufficient (don't forget mariadb data if you're using that)
  12. If you already reverse proxied, you don't need to connect via host ip. Just use the domain
  13. No, only subfolder. The subdomain one is for serving it at https://heimdall.mydomain.com Try connecting to your domain on a cell phone with wifi turned off
  14. If swag and heimdall are on the same custom bridge network, you don't even need to map ports for heimdall as swag will connect directly to the heimdall container over the custom docker bridge network.
  15. Can you exec into the container and install the package "ocl-icd-opencl-dev", restart and see if it works?