Jump to content

aptalca

Community Developer
  • Content Count

    2493
  • Joined

  • Last visited

Community Reputation

170 Very Good

5 Followers

About aptalca

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Either your ip is incorrect on your dns, or your port forwarding is incorrect. Try this: https://blog.linuxserver.io/2019/07/10/troubleshooting-letsencrypt-image-port-mapping-and-forwarding/
  2. There are three types of networking for docker: host, bridge and macvlan. Host and bridge networks use the same ip as the host machine. Macvlan let's the container get its own ip. In this case you're using macvlan, and it has that security feature where it blocks communications between the container and the host ip (and everything that's using that ip). I don't know what your other containers are on so can't comment on them.
  3. Our image doesn't use acme, which is a third party script. We use the official client, certbot. Honestly, GoDaddy is not very good at DNS services. I'd take cloudflare over any of those domain registrar provided DNS service any day. Cloudflare is free, very easy to switch to and propagates changes almost instantly. You're better off using cloudflare as your dns provider. I have domains bought from various providers like dynadot and name cheap, but they all point the name servers to cloudflare, which handles dns for me
  4. If sonarr and radarr are on macvlan, and others are on a custom bridge, they won't be able to connect to each other. That's a docker security feature to prevent connections between the host (and the host networks) and macvlan
  5. You need to disable your http to https redirect in your default site config. You can't have both http and stream listening on port 80
  6. Add this to the bottom of your nginx.conf file, put in your ip and port for openvpn stream { log_format basic '$remote_addr [$time_local] ' '$protocol $status $bytes_sent $bytes_received ' '$session_time'; access_log /config/log/nginx/streamaccess.log basic; error_log /config/log/nginx/streamerror.log; server { listen 80; proxy_pass serverip:port; } }
  7. You likely have double auth, once through htpasswd and once through sonarr/radarr Two solutions: 1) remove internal auth in sonarr/radarr and only rely on http auth, or 2) make sure the user pass are exactly the same for htpasswd and the app's internal auth
  8. GitHub readme and the docker hub pages both have changelogs
  9. Do not manually run commands inside the container. Create a fresh container with an empty appdata folder, follow the directions in the readme
  10. Only the city one is provided by the alpine package, but it contains country info as well
  11. Everything's already installed. You just edit the nginx config to enable it however you like
  12. Did you forward port 53444 on your router to port 53444 on unraid and also map port 53444 to port 53444 in container settings?
  13. Take a step back. What exactly are you trying to achieve? Are you trying to be able to access nextcloud at https://yourdomain.com:53444 ?