Jump to content

lewispm

Members
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

0 Neutral

About lewispm

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have a debian 10 vm running on my unraid box and one app (within debian) complains that there's not enough lockable memory: the output of ulimit -l is 64. Google tells me to change the "max locked memory" limit in /etc/security/limits.conf, but after doing this and rebooting it doesn't change. Is this a setting in the way I set up the VM on unraid, or is this just a debian setting?
  2. I did this and the document_consumer would run, but the webserver wasn't running. There was an error in the log about /etc/passwd being locked, not sure if that was the problem. I switched the two lines in the entry.sh (listing the webserver first, then the document_consumer second, as below) and it works now. #! /bin/bash /sbin/docker-entrypoint.sh runserver 0.0.0.0:8000 --insecure --noreload & /sbin/docker-entrypoint.sh document_consumer & wait And I also had to make the file executable (chmod +x).
  3. what is "that field" in this case? I put document_consumer in "Post_arguments"
  4. Does the consumer reach into directories in the consume directory or just consume in the root? (/consume) ScannerPro added a (/ScannerPro) directory in my /consume directory and I can't figure out how to remove it. And paperless hasn't consumed it yet, I assume thats why.
  5. reverse proxy worked for me just fine. I use NginxProxyManager
  6. I changed mine to look like yours. I can't restart nextcloud right now, but I'm sure that will fix me up. Thanks for the help!
  7. Both of the headers I have listed in my advanced tab are NOT set according to https://securityheaders.com
  8. This didn't work. Here's my advanced tab. The warning remains. I restarted npm docker (not sure if that needs to be done or not) and it still persists. Do I need to restart nextcloud?
  9. I am getting a couple security warnings on nextcloud, same as I've seen on here. The project instructions at: say to set the variables thusly: After doing this the security headers scan shows the same result, that x_frame_options and referrer policy are still not set. Is the attached screen shot the way to accomplish this? Because it didn't work. How should I do this?
  10. Ok, just tried it again, and actually read the subdomain conf comments at the top and I figured it out. Here's what I did, in case you want to do the same: 1. under the config for the letsencrypt docker, add plex as a subdomain. Apply, then check the logs that it accepted it, and says "server ready" at the bottom. 2. config for plex docker, select proxynet as network. ( I think you already have this) 3. edit /appdata/letsencrypt/nginx/proxy-confs/plex.subdomain.conf.sample # make sure that your dns has a cname set for plex, if plex is running in bridge mode, the below config should work as is, for host mode, # replace the line "proxy_pass https://$upstream_plex:32400;" with "proxy_pass https://HOSTIP:32400;" HOSTIP being the IP address of plex # in plex server settings, under network, fill in "Custom server access URLs" with your domain (ie. "https://plex.yourdomain.url:443") server { listen 443 ssl; listen [::]:443 ssl; server_name plex.*; include /config/nginx/ssl.conf; client_max_body_size 0; proxy_redirect off; proxy_buffering off; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /login; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_plex plex; proxy_pass http://$upstream_plex:32400; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_set_header X-Plex-Client-Identifier $http_x_plex_client_identifier; proxy_set_header X-Plex-Device $http_x_plex_device; proxy_set_header X-Plex-Device-Name $http_x_plex_device_name; proxy_set_header X-Plex-Platform $http_x_plex_platform; proxy_set_header X-Plex-Platform-Version $http_x_plex_platform_version; proxy_set_header X-Plex-Product $http_x_plex_product; proxy_set_header X-Plex-Token $http_x_plex_token; proxy_set_header X-Plex-Version $http_x_plex_version; proxy_set_header X-Plex-Nocache $http_x_plex_nocache; proxy_set_header X-Plex-Provides $http_x_plex_provides; proxy_set_header X-Plex-Device-Vendor $http_x_plex_device_vendor; proxy_set_header X-Plex-Model $http_x_plex_model; } } I didn't have to change this file, but if your plex docker is different than "plex" (i.e. binhex-plex) you'll have to edit that under "set $upstream_plex" 4. Save this file BUT REMOVE THE .sample from the file name. 5. As per the last line in the comments of this file - go into plex settings and : # in plex server settings, under network, fill in "Custom server access URLs" with your domain (ie. "https://plex.yourdomain.url:443") Then I navigated to plex.mydomain.com and it worked. Hope it helps!
  11. Thanks for the info, this is exactly what I am trying to do. I have a question about your solution for Plex. Doesn't this bypass the nginx proxy and just go to the plex instance on the unraid server? I got emby to work with the following nginx proxy conf: # make sure that your dns has a cname set for emby, if emby is running in bridge mode, the below config should work as is, although, # the container name is expected to be "emby", if not, replace the line "set $upstream_emby emby;" with "set $upstream_emby <containername>;" # for host mode, replace the line "proxy_pass http://$upstream_emby:8096;" with "proxy_pass http://HOSTIP:8096;" HOSTIP being the IP address of emby # in emby settings, under "Advanced" change the public https port to 443, leave the local ports as is, set the "external domain" to your url, # and set the "Secure connection mode" to "Handled by reverse proxy" # to enable password access, uncomment the two auth_basic lines server { listen 443 ssl; server_name emby.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { auth_basic "Restricted"; auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_emby binhex-emby; proxy_pass http://$upstream_emby:8096; proxy_set_header Range $http_range; proxy_set_header If-Range $http_if_range; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; } } I'm trying to do the same with plex, but when I do, it doesn't remotely connect.
  12. You are right, it worked. Now I switched it back to use cache:no. Thanks, I misunderstood a reply earlier.
  13. That was my plan, but a reply above says mover won't do this move. And I can confirm this, as I already set cache =yes and run the mover,and it's still orphaned
  14. Ok, now I need help fixing this problem. The data is in the correct share, but orphaned, and won't be moved. Is it safe to move the files disk share to disk share? So I copy from the correct share on the cache drive to the correct share on one of the array drives? Then I can delete the orphaned directory on the cache drive, right? That seems like my only option.
  15. I would love preview generator to work, but haven't gotten it to work for me yet either. The command to run an occ command from docker console is: # sudo -u abc php /config/www/nextcloud/occ yourcommand if you get it to generate your previews for you, let me know how you did it!