Anne

Members
  • Posts

    31
  • Joined

  • Last visited

Everything posted by Anne

  1. Hello,,, anybody have an idea??
  2. SQUID and ljm42 I started out with the login as "root" with a password as "asdf" and was able to log into unraid through the IP or the name TOWER I added 4 family users with their own passwords. Everything seemed to be fine. Then I added a new user , lets say user "X", to unraid through the USERS setting.. entered a password for user "X", as "xyz" When I did that it changed all user passwords , root and family users, to the password "xyz" that I had entered for the new user "X" As a test I changed user "Y" password to "abc" and all passwords were changed to the "abc" "Y" password, including the root password At this point I could still login with "root" and whatever password was used last to change a password. I shut down the server to attend to a family emergency and when I returned and turned on the server, NONE of the passwords work with "root" to login with the IP or Tower I erased the two files in password recovery and was able to login. I UPDATED to newest OS version 6.9.2 and updated all apps and dockers. THEN logged off and did a reboot and am now back to not being able to login..... the new password does not work. Hope that helps.....
  3. Changing browser did not make a difference and I do not use chrome. Thanks for the suggestions.
  4. I have the "can not change the password" problem also !!!! I added a new user and a password for the new user and clicked to complete the action.. The unraid server replaced my chosen password for the new user with the password for the ROOT user.. I tried to change the password for the new user many times, and the process fails to change the password, replacing the desired password for the new user with the ROOT user password. ...... All my user accounts have had their password changed to the root user password I tried to correct the other user passwords, but the system will not change the data, replacing the entered information with the password from the root user account I am also not able to change the ROOT password ! ....... I have updated to Unraid 69.0.0 and still have the same problem........
  5. How to Recover Deleted Files from an UNRAID server running the XFS file system I deleted about 1.9TB of data consisting of several directories and their contents and multiple individual files, I was told there was no way to "undelete" the data in a XFS file system in unraid. I found a program called Recovery Explorer 8.4 which recovered all of my data. https://www.sysdevlabs.com/product.php?id=rxs6 REMEMBER... do NOT do ANYTHING that will write to the array after the files are deleted or you may write over the files you want to recover Below are the steps I took to recover my data 1. Stopped doing anything that might write to the array 2. Determined which HD the deleted data had been on 3. Stopped array 4. Power off server 5. Removed the HD determined in step 2, from the server 6. Connect the server HD to a different computer 7. Install Recovery Explorer software on this computer, not the server 8. Run the recover software and when the scan is finished the data is recovered. 9. Do a COPY of the recovered directories and files from the software to a hard drive 10. Install the hard drive with the recovered data in the server as an Unassigned Device 11. Reinstall the server array HD 12. Power the server back on 13. Mounted the Unassigned drive 13. Transferred the recovered data from the unassigned drive to the array , in my case back to HD it had been deleted from WARNING the scan process is LONG .. The array HD I scanned was a 10TB drive and it took about 22 hours BUT the program recovered ALL my data
  6. The problem; Can not delete a folder left in the ALL FILES section of NC by the NC App called "External Storages" The folder was created and then deleted in the "External Storages App" leaving the folder active in the ALL FILES section of NC This is what I have found so far, ----- - when a folder created by the External Storages App is NOT successful,,, ie: ( get the red ball instead of the green check ball ) - the External Storages App creates the folder in the "ALL FILES" section of NextCloud. - Deleting the problem folder using the External Storages App, seems successful as the entry is removed from the External Storages App. - However, the deleted problem folder is active in the "ALL FILES" section of NextCloud in that files and Sub-Folders can be added or deleted - Clicking on the 3 horizontal dots associated with the "deleted folder", reveals no DELETE available as in other folder menus. I visited the Next Cloud FORUM and found several people seem to have this same problem. Could someone please help with this problem .... Anne
  7. NextCloud - External Storages App - I am unable to "delete" FOLDERS that I created using the External Storages App . When I delete a FOLDER using the External Storages App, the FOLDER seems to be deleted as it is no longer visible within the App. However, The deleted Folder is still available in the ALL FILES section of Next Cloud, The folder in the All Files section still functions as I can add / remove files and sub-folders. The folder menu associated with the deleted folder does not have a delete function available SO.... how do I DELETE a folder created by the External Storages App as the External Sorages App does not show the folder exists? I have restarted NextCloud and MariaDB several times.. I have restarted the Unraid server, no changes.... I have visited the Next Cloud forum and several people seem to have this same problem. Could someone please fix this problem .... Anne This is what I have found so far, ----- - when a folder created by the External Storages App is NOT successful,,, ie: ( get the red ball instead of the green check ball ) - the External Storages App creates the folder in the "ALL FILES" section of NextCloud. - Deleting the folder using the External Storages App, seems successful as the entry is removed from the External Storages App. - However, the deleted folder is active in the "ALL FILES" section of NextCloud in that files and subfolders can added or deleted - Clicking on the 3 horizontal dots associated with the "deleted folder", reveals no DELETE available as in other folder menus.
  8. THANKS to CHBMB, Squid, & Chrysen With you all pointing me in the right direction, I have it working !!!! All that is left is fine tuning Anne
  9. Thank you, I will go look at your URL. IF I still have problems, should I repost my question in the area you pointed too...? (The "support" button within the docker)
  10. But I did not see any existing topics that addressed anything to do with my problem.... As I said, did I miss a topic under NextCloud that addresses accessing an unraid share via folders in NextCloud ?????
  11. I already looked through the thread for NextCloud and found nothing related to my question.. Did I miss something ??
  12. Yes it should... BUT, I can not ask a question there ... just respond to topics already existing......
  13. I have NextCloud up and running and so far so good. What I need to find out is ... ..... How do I get a folder in NextCloud to show data (files), located in a unraid disk directory, or unraid share, Thanks, Anne I have tried using the add on "external storage" and can not get it to recognize the "path" to the directory that contains my files Still trying.... any help ?? MORE DETAILS.......................................... I have NextCloud installed with the NextCloud data container as a share called 'cloud' Data entered into NextCloud goes into this area and is great. WHAT I WOULD LIKE ............................................ --- I would like to have a FOLDER in NextCloud "point" to a unraid share OR a specific directory on the unraid server. The result would be that opening the NextCloud folder gives access to the data within the disk or share external to NextCloud. example: I would like the unraid share on my server called "UNRAID-A " to be visible through the NextCloud Folder called "NextCloud-A" WHAT I HAVE DONE SO FAR ............................................... I added the App "External Storages" to NextCloud. I entered the following information into the NextCloud App called External Storages Folder Name NextCloud-A External Storage LOCAL Authentication Left Blank (No Authentication) Configuration This box is where I added the "path" information - I tried to add the "path" to the unraid share called UNRAID-A - I tried to add the "path" to the unraid server disk directory, called UNRAID-A on the hard disk... Available For Left Blank (All Users) The External Storages App created the Folder called "NextCloud-A" within NextCloud, however the folder does not show any files. and when entering the folder I get the error message: There was an error with message: Empty response from the server. Do you want to review mount point config in admin settings page? I assume the error message refers to the "path" information in the "configuration" box of the External Storages app I hope that is clear enough for someone to help.. Thanks, Anne ========================================================================================================== [SOLVED] THANKS to CHBMB, Squid, & Chrysen With you all pointing me in the right direction, I have it working !!!! All that is left is fine tuning Anne
  14. Re-installed from beginning and everything looks good now.
  15. been through all that to the point I am almost ready to delete it all ( nextcloud, letsencrypt, ddns) and start again.
  16. I have nextcloud installed and am NOT able to access it via the unraid docker WebUI but I CAN access nextcloud via the internet via https, a subdomain, a DDNS service, and letsencrypt Any ideas?? Thanks Anne [SOLVED] Started over ( reinstalled Nextcloud, and Maria database) and now it works.....
  17. After installing letsencrypt I checked the log and it "appears" as if letsencrypt installed.. as services started, and server ready, is displayed.. HOWEVER , I am getting continuous errors about (21: is a directory) part of log below.. Can someone point me in the right direction please.. Anne part of LOG showing install complete , and the errors [cont-init.d] done. [services.d] starting services [services.d] done. nginx: [crit] pread() "/config/nginx/site-confs/default2" failed (21: Is a directory) Server ready nginx: [crit] pread() "/config/nginx/site-confs/default2" failed (21: Is a directory) nginx: [crit] pread() "/config/nginx/site-confs/default2" failed (21: Is a directory) nginx: [crit] pread() "/config/nginx/site-confs/default2" failed (21: Is a directory)
  18. thanks, but when I went to do it unraid said I had an update available, so I updated LE and now I can not open it... guess something else is wrong now... Thanks again for the tip
  19. I installed letsencrypt on my unraid server to use with duckdns , and I thought I set it up to auto-renew the certificate. I guess I didn't or they would not be sending me an email reminding me to renew as my certificate would expire in 22 days SO.. could someone tell me what to look for, point to, whatever, to see if my install of letsencrypt is or is not set to auto-renew my certificate and I guess if it is not I will have to come back and ask how to renew a certificate.... Thanks, Anne
  20. Thanks, but I would rather stay with a docker app if there might be one, for a solution.. Do not want to go off in too many directions.
  21. High John_M, Yes it works, however without some form of automation in the selection of what link paths to attribute to a specific user, it would take hours and hours and wear out my kybd. but for my purpose I think it would be a maintenance nightmare, unless I can script something that just asks what location to link to what user or what link location to remove from a user..... Thanks for the idea.. and the script does the work... hmmmm
  22. No, it was restricted to an 8TB array size, and FTP was inadequate at best and it had no capabilities for hosting a website. Plex, Emby and software like that is not available. And I did ask a lot of questions. I was told my solution to FTP was Owncloud or Nextcloud, and that I could host my own web site on unraid and Plex or Emby would take care of the media. I have not even finished loading software for Plex but already I like it. I am having problems with Nextcloud but that is on hold until I figure a way to arrange files that will allow me more flexibility with security, thus the problem I have with no user groups. Unraid seems to be working well for me until I encountered this problem of groups Just to say where I am going with all this... My primary usage will be that of a NAS File Server, then website server, then the Plex goodies, I hope that helps you understand what I am trying to do
  23. My prior server had "user groups" built in and access to the data was smb or nfs. The server was linux based as is unraid. The use of groups made permissions down to the file level an easy task. I do not seem to be able to change either the user or the group in unraid.