Madhouse

Members
  • Posts

    66
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed

Madhouse's Achievements

Rookie

Rookie (2/14)

0

Reputation

  1. So - maybe i'm just not getting it - but is there a easy way to upgrade from the 'old' pi-hole with DOH to the new one? Thanks for a lovely docker - I can't imagine living without it. /Mads
  2. Thank, I went to see if i could figure it out and for some odd reason transmission started with no problems. Go figure.
  3. Anyone else has transmission_vpn docker failing to start? since last night I've had problems. Not sure what happened - i havent updated the docker for some time and still it started to fail - I have updated now and i still cant get it running. Any help would be greatly appreciated. Using OpenVPN provider: PUREVPN Supplied config Netherlands.ovpn could not be found. Using default OpenVPN gateway for provider purevpn Setting OPENVPN credentials... adding route to local network 192.168.0.0/23 via 192.168.0.1 dev eth0 Mon Jun 15 20:15:36 2020 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Sep 5 2019 Mon Jun 15 20:15:36 2020 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10 Mon Jun 15 20:15:36 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts Mon Jun 15 20:15:36 2020 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Jun 15 20:15:36 2020 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Jun 15 20:15:36 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]178.170.137.4:80 Mon Jun 15 20:15:36 2020 Socket Buffers: R=[87380->87380] S=[65536->65536] Mon Jun 15 20:15:36 2020 Attempting to establish TCP connection with [AF_INET]178.170.137.4:80 [nonblock] Mon Jun 15 20:15:37 2020 TCP connection established with [AF_INET]178.170.137.4:80 Mon Jun 15 20:15:37 2020 TCP_CLIENT link local: (not bound) Mon Jun 15 20:15:37 2020 TCP_CLIENT link remote: [AF_INET]178.170.137.4:80 Mon Jun 15 20:15:37 2020 TLS: Initial packet from [AF_INET]178.170.137.4:80, sid=0234ad6c 6203b276 Mon Jun 15 20:15:37 2020 VERIFY OK: depth=1, C=HK, ST=Central, L=HK, O=Secure-ServerCA, OU=IT, CN=Secure-ServerCA, name=Secure-ServerCA, emailAddress=mail@host.domain Mon Jun 15 20:15:37 2020 VERIFY KU OK Mon Jun 15 20:15:37 2020 Validating certificate extended key usage Mon Jun 15 20:15:37 2020 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication Mon Jun 15 20:15:37 2020 VERIFY EKU OK Mon Jun 15 20:15:37 2020 VERIFY OK: depth=0, C=HK, ST=Central, L=HK, O=Secure-Server, OU=IT, CN=Secure-Server, name=changeme, emailAddress=mail@host.domain Mon Jun 15 20:15:37 2020 Control Channel: TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 2048 bit RSA Mon Jun 15 20:15:37 2020 [Secure-Server] Peer Connection Initiated with [AF_INET]178.170.137.4:80 Mon Jun 15 20:15:39 2020 SENT CONTROL [Secure-Server]: 'PUSH_REQUEST' (status=1) Mon Jun 15 20:15:39 2020 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 178.170.137.3,dhcp-option DNS 178.170.137.5,sndbuf 393216,rcvbuf 393216,comp-lzo no,route-gateway 178.170.137.129,topology subnet,ping 10,ping-restart 120' Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: timers and/or timeouts modified Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: compression parms modified Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified Mon Jun 15 20:15:39 2020 Socket Buffers: R=[87380->786432] S=[130560->786432] Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: --ifconfig/up options modified Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: route options modified Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: route-related options modified Mon Jun 15 20:15:39 2020 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified Mon Jun 15 20:15:39 2020 Outgoing Data Channel: Cipher 'AES-256-CBC' initialized with 256 bit key Mon Jun 15 20:15:39 2020 Outgoing Data Channel: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Jun 15 20:15:39 2020 Incoming Data Channel: Cipher 'AES-256-CBC' initialized with 256 bit key Mon Jun 15 20:15:39 2020 Incoming Data Channel: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Jun 15 20:15:39 2020 ROUTE_GATEWAY 192.168.0.1/255.255.255.0 IFACE=eth0 HWADDR=02:42:c0:a8:00:0f Mon Jun 15 20:15:39 2020 TUN/TAP device tun0 opened Mon Jun 15 20:15:39 2020 TUN/TAP TX queue length set to 100 Mon Jun 15 20:15:39 2020 /etc/openvpn/tunnelUp.sh tun0 1500 1560 init Up script executed with tun0 1500 1560 init ERROR, unable to obtain tunnel address killing 18 Mon Jun 15 20:15:39 2020 WARNING: Failed running command (--up/--down): external program did not exit normally Mon Jun 15 20:15:39 2020 Exiting due to fatal error
  4. Hello, i'm using Purevpn and i cant seem to get transmission started. My guess is that no2 server, which si the default server has been shutdown. Now, I may have missed something regarding Tranmission_VPN. Am I supposed to opy the openvpn config file somewhere? That would explain the error I'm getting. This is what i see in the Log. Thanks
  5. Thank you so much, I wasn't aware of that..
  6. Transmission: Is there anyway to disable downloading to incomplete folder? I tried editing the settings.json, but when i start the docker et defaults back to true. Or maybe a way to separate download folder and configuration folder. (maybe I'm getting it all worng)
  7. Strangest thing. after messing around a bit, moving ombi to host and then back to br0, it suddenly connected. both plex and ombi is running on br0.
  8. Thanks a lot. I'll dig into it then thanks for taking time to help me out.
  9. Thanks. I see, i have no problem connecting to Sonarr and Medusa though. and i have no idea what how to reverse proxy the dockes, although i should be able to use my google fu for that.
  10. Hello.. Anyone else having trouble connecting to plex? Below is my logs for when i test connection, which results in 'We could not connect to plex' 018-10-30 20:56:09.889 +01:00 [Error] Could not test Plex System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.IO.IOException: The server returned an invalid or unrecognized response. at System.Net.Http.HttpConnection.FillAsync() at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed) at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken) --- End of inner exception stack trace --- at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken) at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken) at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken) at System.Net.Http.HttpClient.FinishSendAsyncBuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts) at Ombi.Api.OmbiHttpClient.SendAsync(HttpRequestMessage request) in C:\projects\requestplex\src\Ombi.Api\OmbiHttpClient.cs:line 61 at Ombi.Api.Api.Request[T](Request request) in C:\projects\requestplex\src\Ombi.Api\Api.cs:line 38 at Ombi.Api.Plex.PlexApi.GetStatus(String authToken, String uri) in C:\projects\requestplex\src\Ombi.Api.Plex\PlexApi.cs:line 97 at Ombi.Controllers.External.TesterController.Plex(PlexServers settings) in C:\projects\requestplex\src\Ombi\Controllers\External\TesterController.cs:line 246 Both plex and ombi are running br0 on seperate IP's. not sure if that could cause a problem? Thanks
  11. Maybe I've gotten it all wrong - my intentions was to run dockers like Radarr, Medusa and Transmission securely though openvpn, so that my own public IP was hidden. is that at all possible with this plugin?
  12. Sorry, but it is still not clear how to route specific dockers through openvpn. I've tried added the IP for the docker (which is running br0) but even though i have addd the ip adress to webbadress.txt all traffic seems to be routed through openvpn. any help would be greatly appreciated.
  13. ahh yes.. now i see. Thanks To be able to use "Route specific IP through VPN tunnel" you first need to create this file webbadress.txt in /boot/openvpn
  14. Hello.. Nice plugin, working fine with all traffic routed through but I'd like to only route traffic from specific IP's. I have enabled the 'route only specific ip adresses' but where to I add the IPs to route through openvpn client?