Jump to content

neow

Members
  • Content Count

    53
  • Joined

  • Last visited

Everything posted by neow

  1. hello thanks first i tried 1000-82545em -> no network at all after this then i looked at screen fix, this is way to much complicated for me but thank you sir i will wait a macinabox for noob
  2. hello everyone i installed catalina on a nuc8i3beh eveything work fine except appleid and adding more ram: https://d.pr/i/JkQkCJ i tried the instructions in youtube video to modify xml, when i do this, my screen bug on relaunch/startup with multiple apple if anybody have an idea thanks in advance
  3. Dear all, i try ton create a vm win 10 pro for my nuc i get a static screen all the screenshot here : https://d.pr/i/PTzdGM https://d.pr/i/2vLGaO https://d.pr/i/rkUNaB https://d.pr/i/FCtwkh any idea? ubuntu vm work very well thanks in advance
  4. i checked tuto i am not sure to understand this : "To get the best performance out of mergerfs, map dockers to /user --> /mnt/user Then within the docker webui navigate to the relevant folder within the mergerfs share e.g. /user/mount_unionfs/downloads or /user/mount_unionfs/movies. These are the folders to map to plex, radarr, sonarr,nzbget etc DO NOT MAP any folders from local or the rclone mount DO NOT create mappings like /downloads or /media for your dockers. Only use /user --> /mnt/user if you want to ensure the best performance from mergerfs when moving and editing files within the mount" am i right to do this in plex? https://d.pr/i/16qg8V since i changed scripts to new one, i have errors in plex like this : https://d.pr/i/HTC0dc https://d.pr/i/Wtn2ml in krusader i have new files : https://d.pr/i/uWHUmZ mount union_fs is empty https://d.pr/i/lzg2kj mount mergerfs has two files https://d.pr/i/EaEId6 one has the files in the cloud(gdrive_media_vfs file) , one is empty gdrive_vfs thanks in advance
  5. hello, i just changed old scripts by new ones. seems working now except upload message error: 08.03.2020 11:48:50 INFO: *** Rclone move selected. Files will be moved from /mnt/user/local/gdrive_media_vfs for gdrive_upload_vfs *** 08.03.2020 11:48:50 INFO: *** Starting rclone_upload script for gdrive_upload_vfs *** 08.03.2020 11:48:50 INFO: Script not running - proceeding. 08.03.2020 11:48:50 INFO: Checking if rclone installed successfully. 08.03.2020 11:48:50 INFO: rclone installed successfully - proceeding with upload. 08.03.2020 11:48:50 INFO: Uploading using upload remote gdrive_upload_vfs 08.03.2020 11:48:50 INFO: *** Using rclone move - will add --delete-empty-src-dirs to upload. 2020/03/08 11:48:50 DEBUG : --min-age 15m0s to 2020-03-08 11:33:50.704339109 +0100 CET m=-899.989103786 2020/03/08 11:48:50 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone/.rclone.conf" "move" "/mnt/user/local/gdrive_media_vfs" "gdrive_upload_vfs:" "--user-agent=gdrive_upload_vfs" "-vv" "--buffer-size" "512M" "--drive-chunk-size" "512M" "--tpslimit" "8" "--checkers" "8" "--transfers" "4" "--order-by" "modtime,ascending" "--min-age" "15m" "--exclude" "downloads/**" "--exclude" "*fuse_hidden*" "--exclude" "*_HIDDEN" "--exclude" ".recycle**" "--exclude" ".Recycle.Bin/**" "--exclude" "*.backup~*" "--exclude" "*.partial~*" "--drive-stop-on-upload-limit" "--bwlimit" "01:00,off 08:00,15M 16:00,12M" "--bind=" "--delete-empty-src-dirs"] 2020/03/08 11:48:50 DEBUG : Using config file from "/boot/config/plugins/rclone/.rclone.conf" 2020/03/08 11:48:50 INFO : Starting bandwidth limiter at 15MBytes/s 2020/03/08 11:48:50 INFO : Starting HTTP transaction limiter: max 8 transactions/s with burst 1 2020/03/08 11:48:50 Failed to create file system for "gdrive_upload_vfs:": didn't find section in config file 08.03.2020 11:48:50 INFO: Not utilising service accounts. 08.03.2020 11:48:50 INFO: Script complete Script Finished Sun, 08 Mar 2020 11:48:50 +0100 2020/03/08 11:48:50 Failed to create file system for "gdrive_upload_vfs:": didn't find section in config file
  6. Hello i updated unraid yesterday with 6.8.0 version (basic) plex is not working anymore, the container starts but is unreachable anymore. here is the report plex : [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... Plex Media Server first run setup complete [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. connect: Connection refused connect: Connection refused [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. Critical: libusb_init failed [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. connect: Connection refused [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. Critical: libusb_init failed [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. Plex Media Server is already running. Will not start... Starting Plex Media Server. Connection to 178.79.142.46 closed by remote host. Connection to 213.219.36.78 closed by remote host. Connection to 176.58.109.167 closed by remote host. Connection to 139.162.247.112 closed by remote host. Connection to 139.162.199.116 closed by remote host. connect: Connection refused connect: Connection refused [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. Critical: libusb_init failed [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. Critical: libusb_init failed [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. Plex Media Server is already running. Will not start... Starting Plex Media Server. [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. Critical: libusb_init failed [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 40-plex-first-run: executing... [cont-init.d] 40-plex-first-run: exited 0. [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing... [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0. [cont-init.d] 50-plex-update: executing... [cont-init.d] 50-plex-update: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Starting Plex Media Server. thanks for helping
  7. hello thanks for your reply i copy files via krusader from a share called archives to a share called unionfs (google drive rclone) please find enclosed the diagnostic file towerpen-diagnostics-20190709-1230.zip
  8. Hello, i need to copy some files from a share to another share, but this is very slow with up and down writing (up 50mo/sec down 5 mo/sec) this is large files, i don't understand why this is slow like this. When i copy from a syno to unraid i got 80 mo/sec, so why from a share to another one this is slow like this? my config : - last unraid version - ryzen 1800x - turbo write mode activated - 2 parity disks - 2 ssd cache thanks for your ideas
  9. neow

    Preclear

    i find the solution -> enable destructive mode thanks problem solved
  10. neow

    Preclear

    hello, i changed yesterday my ssd cache- everything work fine. Now i have ssd unassigned for vm i pre cleared them but impossible to format them or mount them : https://d.pr/i/7bj2Rz any solution? thanks
  11. Ok i will try. Just one question: when you start the array you mount check and the mount script work fine?
  12. Krusader. i can affirm i can wait 1hour. Without this manipulation unionfs will never mount i don’t have a cron task for mounting script like many if you. It’s just run at the array mounting
  13. 1h14 it’s the array mounted. The script stops here 16.06.2019 01:14:37 INFO: Exiting script already running. Script Finished Sun, 16 Jun 2019 01:14:37 +0200  Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_mount_plugin/log.txt  After my manipulation 1h16 everything work fine 16.06.2019 01:16:51 INFO: Check successful, unionfs mounted.
  14. The problem is that when i turn on my array and after the mount check it doesn’t work. Impossible to see unionfs i have to do the procedure i wrote just before and then everything work. When you turn on your server everything work automatically after mountcheck? Or you have to do the same procedure as me?
  15. root@Tower:~# touch mountcheck root@Tower:~# rclone copy mountcheck gdrive_media_vfs: -vv --no-traverse 2019/06/16 01:17:02 DEBUG : rclone: Version "v1.48.0-001-g4549305f-beta" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone-beta/.rclone.conf" "copy" "mountcheck" "gdrive_media_vfs:" "-vv" "--no-traverse"] 2019/06/16 01:17:02 DEBUG : Using config file from "/boot/config/plugins/rclone-beta/.rclone.conf" 2019/06/16 01:17:03 DEBUG : mountcheck: Modification times differ by -1m49.823031434s: 2019-06-16 01:17:01.382031434 +0200 CEST, 2019-06-15 23:15:11.559 +0000 UTC 2019/06/16 01:17:04 INFO : mountcheck: Copied (replaced existing) 2019/06/16 01:17:04 INFO : Transferred: 32 / 32 Bytes, 100%, 14 Bytes/s, ETA 0s Errors: 0 Checks: 0 / 0, - Transferred: 1 / 1, 100% Elapsed time: 2.2s 2019/06/16 01:17:04 DEBUG : 5 go routines active 2019/06/16 01:17:04 DEBUG : rclone: Version "v1.48.0-001-g4549305f-beta" finishing with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone-beta/.rclone.conf" "copy" "mountcheck" "gdrive_media_vfs:" "-vv" "--no-traverse"] #!/bin/bash ####### Check if script is already running ########## if [[ -f "/mnt/user/appdata/other/rclone/rclone_mount_running" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Exiting script already running." exit else touch /mnt/user/appdata/other/rclone/rclone_mount_running fi ####### End Check if script already running ########## ####### Start rclone mounts ########## # create directories for rclone mount and unionfs mount mkdir -p /mnt/user/appdata/other/rclone mkdir -p /mnt/user/mount_rclone/google_vfs mkdir -p /mnt/user/mount_unionfs/google_vfs mkdir -p /mnt/user/rclone_upload/google_vfs ####### Start rclone gdrive mount ########## # check if rclone mount already created if [[ -f "/mnt/user/mount_rclone/google_vfs/mountcheck" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Check rclone vfs mount success." else echo "$(date "+%d.%m.%Y %T") INFO: mounting rclone vfs." rclone mount --rc --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 256M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs & # check if mount successful # slight pause to give mount time to finalise sleep 10 if [[ -f "/mnt/user/mount_rclone/google_vfs/mountcheck" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Check rclone gdrive vfs mount success." else echo "$(date "+%d.%m.%Y %T") CRITICAL: rclone gdrive vfs mount failed - please check for problems." rm /mnt/user/appdata/other/rclone/rclone_mount_running exit fi fi ####### End rclone gdrive mount ########## ####### End rclone mounts ########## ####### Start unionfs mount ########## if [[ -f "/mnt/user/mount_unionfs/google_vfs/mountcheck" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Check successful, unionfs mounted." else unionfs -o cow,allow_other,direct_io,auto_cache,sync_read /mnt/user/rclone_upload/google_vfs=RW:/mnt/user/mount_rclone/google_vfs=RO /mnt/user/mount_unionfs/google_vfs if [[ -f "/mnt/user/mount_unionfs/google_vfs/mountcheck" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Check successful, unionfs mounted." else echo "$(date "+%d.%m.%Y %T") CRITICAL: unionfs Remount failed." rm /mnt/user/appdata/other/rclone/rclone_mount_running exit fi fi ####### End Mount unionfs ########## ############### starting dockers that need unionfs mount ###################### # only start dockers once if [[ -f "/mnt/user/appdata/other/rclone/dockers_started" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: dockers already started" else touch /mnt/user/appdata/other/rclone/dockers_started echo "$(date "+%d.%m.%Y %T") INFO: Starting dockers." docker start plex docker start ombi docker start tautulli docker start radarr docker start sonarr fi ############### end dockers that need unionfs mount ###################### # populate rclone dir-cache echo "$(date "+%d.%m.%Y %T") Info: populating dir cache - this could take a while." rclone rc --timeout=1h vfs/refresh recursive=true echo "$(date "+%d.%m.%Y %T") Info: populating dir cache complete." exit results (see the difference at the boot and when i do it manually) Script Starting Sun, 16 Jun 2019 01:14:37 +0200 Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_mount_plugin/log.txt 16.06.2019 01:14:37 INFO: Exiting script already running. Script Finished Sun, 16 Jun 2019 01:14:37 +0200 Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_mount_plugin/log.txt Script Starting Sun, 16 Jun 2019 01:16:41 +0200 Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_mount_plugin/log.txt 16.06.2019 01:16:41 INFO: mounting rclone vfs. 2019/06/16 01:16:41 NOTICE: Serving remote control on http://127.0.0.1:5572/ 16.06.2019 01:16:51 INFO: Check rclone gdrive vfs mount success. 16.06.2019 01:16:51 INFO: Check successful, unionfs mounted. 16.06.2019 01:16:51 INFO: Starting dockers. Error response from daemon: No such container: plex Error: failed to start containers: plex Error response from daemon: No such container: ombi Error: failed to start containers: ombi Error response from daemon: No such container: tautulli Error: failed to start containers: tautulli Error response from daemon: No such container: radarr Error: failed to start containers: radarr Error response from daemon: No such container: sonarr Error: failed to start containers: sonarr 16.06.2019 01:16:51 Info: populating dir cache - this could take a while. { "result": { "": "OK" } } 16.06.2019 01:16:52 Info: populating dir cache complete. Script Finished Sun, 16 Jun 2019 01:16:52 +0200 Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_mount_plugin/log.txt For the containers no problem i didn't install them for the moment thanks for your help, i appreciate
  16. yes i solved 95% of the problems tonight we had an mounting of the unionfs everything worked fine but when i restart the server everything is mounted no error with the scripts but no visibility of the unionfs everytime i restart the server i do the mount check after the mounting but no connection with unionfs i don't understand why . Maybe it's krusader... the procedure to solve this for each reboot is: 1- erase the mount launched by the script at the start of the array 2- close krusder 3- relaunch the mount script 4- do the mountcheck 5- relaunch krusader All the other manipulations didn't work
  17. actually this is very strange i explain my self when i erase all the mounted files union/upload/rclone and erase theconfig file and after relaunch the script to mount it works but when i reboot all the things go bad again and i got to redo the procedure when i erase all the mounted files union/upload/rclone and erase theconfig file and after relaunch the script to mount it works very strange thing
  18. it's not simple as copy cut the script ii think because i tried several times and had several errors most of the time it was my fault because i am a noob but still some errors i can't explain myself
  19. i saw your posts at the beginning of the thread when you were not an expert you were nicer with people sorry for the mp i will not do it again btw i have a prblem with the upload script : 15.06.2019 20:32:55 INFO: rclone not installed - will try again later. Script Finished Sat, 15 Jun 2019 20:32:55 +0200 Full logs for this script are available at /tmp/user.scripts/tmpScripts/rclone_custom_plugin/log.txt upload script is : #!/bin/bash ####### Check if script already running ########## if [[ -f "/mnt/user/appdata/other/rclone/rclone_upload" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: Exiting as script already running." exit else touch /mnt/user/appdata/other/rclone/rclone_upload fi ####### End Check if script already running ########## ####### check if rclone installed ########## if [[ -f "/mnt/user/mount_rclone/google_vfs/mountcheck" ]]; then echo "$(date "+%d.%m.%Y %T") INFO: rclone installed successfully - proceeding with upload." else echo "$(date "+%d.%m.%Y %T") INFO: rclone not installed - will try again later." rm /mnt/user/appdata/other/rclone/rclone_upload exit fi ####### end check if rclone installed ########## # move files rclone move /mnt/user/rclone_upload/google_vfs/ gdrive_media_vfs: -vv --drive-chunk-size 512M --checkers 3 --fast-list --transfers 2 --exclude .unionfs/** --exclude *fuse_hidden* --exclude *_HIDDEN --exclude .recycle** --exclude *.backup~* --exclude *.partial~* --delete-empty-src-dirs --fast-list --bwlimit 9500k --tpslimit 3 --min-age 30m # remove dummy file rm /mnt/user/appdata/other/rclone/rclone_upload exit thanks for any help
  20. Is anybody can share is settings for docker for folders etc... plex radar sonarr? thanks Other question, can i use two servers unraid with the same scripts, same token, same folders?
  21. ok i didn't understand the main objective of your scripts sorry
  22. ok if i put files to mount_unionfs (not rclone_upload), it's still store locally even after the upload? (like dropbox with local copy synchronized?) i understood if i put directly my files to upload_rclone they will be erased once the upload is complete i am just afraid google close my account g drive and i lost everything
  23. To be understandable i wanted : 1- to update all my files to gdrive and keep them in local for secure them and shut down my big unraid server to save electricity 2- use a small nuc server connected to gdrive crypted to use with plex server (with unraid server shutted down) 3- if i see everything is ok erase my unraid files without erase gdrive crypted files When you say this : "All your 'media' dockers - plex, radarr, sonarr etc should be mapped to the unionfs folder" you talk about this file ? : root-> unraid->user->mount_unionfs->google_vfs i don't understand this sentence : "1. I think yes - as above this is the file 'view' that is what your dockers etc need to use" i don't have a file named "view" i think i understand the process : 1- mount_unionfs is gdrive decrypted ( store locally) 2- mount_rclone is gdrive encrypted (not stored locally) 3- Rclone_upload is the files who are updated to mount_rclone 1- which folder can i erase once it uploaded to earn space on unraid but keep the files in Gdrive as you did with your server? 2- A contrario, if i want to uploaded and keep files in unraid in just move plex files to mount_unionfs and i will keep them locally once it has been updated?