Jump to content
binhex

[Support] binhex - Krusader

178 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Overview: Support for Docker image arch-krusader in the binhex repo.

Application: Deluge - https://krusader.org/

Docker Hub: https://hub.docker.com/r/binhex/arch-krusader/

GitHub: https://github.com/binhex/arch-krusader

 

If you appreciate my work, then please consider buying me a beer  :D

 

btn_donate_SM.gif

 

For other Docker support threads and requests, news and Docker template support for the binhex repository please use the "General" thread here

Edited by binhex
  • Like 2
  • Upvote 3

Share this post


Link to post

reserved

Share this post


Link to post
Posted (edited)

There isnt a progress bar when I do any transfers. I did some digging around and any similar issues I found were how kde plasma would have them in the notification tray, which I cant find to save my life here. So it possibly has something to do with that. 

Edited by wisemanofhyrule
I hit enter a bit too early.

Share this post


Link to post
10 hours ago, wisemanofhyrule said:

There isnt a progress bar when I do any transfers. I did some digging around and any similar issues I found were how kde plasma would have them in the notification tray, which I cant find to save my life here. So it possibly has something to do with that. 

 

i see the problem, its now fixed and the new image is building, do a check for updates in around an hour.

Share this post


Link to post
3 hours ago, binhex said:

 

i see the problem, its now fixed and the new image is building, do a check for updates in around an hour.

Updated and progress is showing up. Thanks!

Share this post


Link to post

brilliant, had tons of issues with Krusader recently and i stopped using it.

 

super happy Binhex, thank you.

Share this post


Link to post
brilliant, had tons of issues with Krusader recently and i stopped using it.
 
super happy Binhex, thank you.
Are all the issues you had with the previous one fixed with this docker image or is it too early to say yet?

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Well considering the previous krusader docker i had installed would crash after a few minutes id say 100% improvement as its working great.

 

I will keep you updated, there are lots more options with this docker?

Share this post


Link to post
Well considering the previous krusader docker i had installed would crash after a few minutes id say 100% improvement as its working great.
 
I will keep you updated, there are lots more options with this docker?
It's a later version so it might have a few more features, I've included a lot of the optional packages so most features shown in the UI should work.

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
Posted (edited)

Does anyone know how to reverse proxy this with the letsencrypt container?

Edited by unabletoconnect
did the dumb and called a container "docker"

Share this post


Link to post
On 5/21/2018 at 6:16 PM, dockerPolice said:

Sparklyballs' old version has now been deprecated in favour of yours.

 

@gridrunner might be worth putting a sticky on your youtube video pointing them at this one, otherwise people are going to be wondering why they cant see the sparklyballs docker image (deprecated docker images are hidden by default in CA).

Share this post


Link to post

Good Job!  I did edit/change the Host Path 2 to look like this:

 

Host_Path2.JPG.eac153095c9de3a9b83f348e48065622.JPG

 

I also added another Host Path to point to the Flash Drive.  There is a very good video on how to do this and further configure this Docker to be a very powerful and easy-to-use tool.  You can find it here:

 

     https://www.youtube.com/watch?v=I0XCFPAsWZE

 

I found out that you should not use a Ctrl-Q (or F-10) to exit Krusader.  You should just close the Tab that is is running in the browser.  (Otherwise, it does not restart unless you restart the Krusader Docker.)  

 

Share this post


Link to post
39 minutes ago, Frank1940 said:

I found out that you should not use a Ctrl-Q (or F-10) to exit Krusader.  You should just close the Tab that is is running in the browser.  (Otherwise, it does not restart unless you restart the Krusader Docker.)  

 

you can start krusader again by simply right clicking the desktop and select "Krusader".

 

warning - right clicking the krusader icon shown in the taskbar will force krusader to exit!

Share this post


Link to post
5 hours ago, binhex said:

 

@gridrunner might be worth putting a sticky on your youtube video pointing them at this one, otherwise people are going to be wondering why they cant see the sparklyballs docker image (deprecated docker images are hidden by default in CA).

Awesome work @binhex  thanks for making this container.

Only had a moment to have look but from what I have seen a great improvement over the previous one. Love that we can manage compressed files in this. I think I will try and make a new video on this new container when I can. :)

Share this post


Link to post
4 minutes ago, gridrunner said:

Awesome work @binhex  thanks for making this container.

Only had a moment to have look but from what I have seen a great improvement over the previous one. Love that we can manage compressed files in this. I think I will try and make a new video on this new container when I can. :)

 

glad you like my work :-), i'm def enjoying your videos!, i was watching your 3 part pfsense vids only the other day, awesome stuff, very clear and concise. 

 

cheers for the beers!.

Share this post


Link to post
Posted (edited)

Good work on Krusader, binhex.

 

Unfortunately, I'm having problems with the mouse cursor. When I open the web interface on my main computer in either Chrome or Firefox, the mouse cursor doesn't work. It's visible, but doesn't follow my mouse movements or clicks. I tried incognito to make sure no extensions were interfering, but same issue of no mouse control. I have also removed the Krusader docker and its appdata settings and reinstalled, but the results are the same.

 

However, when I open in Edge or Internet Explorer, the mouse does work (but who wants to use those browsers? Yuck!). Also, if I open Krusader on a different computer in Chrome, the mouse works there. In fact, if I have Krusader open on both computers, the mouse movement on the secondary computer shows on my main computer (but not vice versa because the main still can't control the mouse).

 

Connections on both computers are set to True Color, Clip to Window, Shared Mode, websockify, and Remote Resizing (although I have tried numerous other setting combinations). Both computers are Windows 10 Pro 1803.17134.48 and Chrome 66.0.3359.181 64-bit synced with the same Chrome account and settings.

 

Any ideas on the problem or troubleshooting?

 

EDIT: SOLVED! A little more research solved my own problem. Touchscreen currently breaks noVNC in Chrome. Open chrome://flags/#touch-events and set Touch Events API to Disabled. Unfortunately this breaks some web development I'm working on, so I guess for me it's either toggle Toggle Events API repeatedly or use Edge. Ugh.

Edited by BennTech
SOLVED

Share this post


Link to post
1 hour ago, BennTech said:

EDIT: SOLVED! A little more research solved my own problem. Touchscreen currently breaks noVNC in Chrome. Open chrome://flags/#touch-events and set Touch Events API to Disabled. Unfortunately this breaks some web development I'm working on, so I guess for me it's either toggle Toggle Events API repeatedly or use Edge. Ugh.

 

alternatively you can connect to this using VNC, add a port to the docker container for container port 5900 host port <whatever> (watch out for clashes with VM's) and then connect using something like TightVNC.

Share this post


Link to post

I just updated, and I lost my bookmarks. It's normal ?

Share this post


Link to post

I did but I did delete/remove the old version first.  I do vaguely recall see some sort of a message about losing my settings but I do remember distinctly ignoring that!  ?  Just above I post a link to a video that will help your restore those bookmarks and even help you get them place on the 'Action Bar'.  

Share this post


Link to post

With the old version, I never loose my bookmarks, but with this one I loose it.

 

Any ideas ?

Share this post


Link to post
1 hour ago, Jobine said:

With the old version, I never loose my bookmarks, but with this one I loose it.

 

Describe in some detail how you are setting up a bookmark.  

Share this post


Link to post
  1. On the left side, I select my folder.
  2. I click on the icon "Book Man II", and click on "Add bookmark"
  3. Enter the name and click OK
  4. With Configure toolbars, I add my bookmarks.

Krusader.jpg

Share this post


Link to post
Posted (edited)
10 hours ago, Jobine said:

With Configure toolbars, I add my bookmarks.

 

Are they disappearing from the Bookmarks or from the Action Toolbar?  There is a difference.   (Today, I did have mine disappear from the Action Toolbar.  But I may have had two WebUI's open from the same server at the same time.  I have not been able to make it happen again.  As I recall, when I opened up the 'Config Toolbars', the icons were there.  I shutdown all of the WebUI windows browser tabs --- I have two servers and I was working with both ---  and restarted the Krusader, things were working correctly.)  

Edited by Frank1940
changed "windows" to "browser tabs"...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now