Jump to content

ninthwalker

Community Developer
  • Content Count

    213
  • Joined

  • Last visited

Community Reputation

17 Good

About ninthwalker

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

564 profile views
  1. ninthwalker

    [Support] Ninthwalker - NowShowing

    Sorry, I should have clarified. Don’t run that from inside the docker. Run that from the unraid Server or even from another Linux/windows box that has telnet The idea is to try and verify if that port outgoing is blocked at your internet or local router level.
  2. ninthwalker

    [Support] Ninthwalker - NowShowing

    Thanks for the logs. One possible reason may be a block on the 587 port by your ISP if this is running from your home or from a VPS provider. If you have telnet installed try using that to manually test the port. ‘telnet smtp.mail.yahoo.com 587’ thay should connect and either return a blank screen or a message from their smtp server. If it throws an error about can’t connecting then it’s a port issue. Let me know the outcome of that. Thanks.
  3. ninthwalker

    [Support] Ninthwalker - NowShowing

    Customizing who gets the emails is already possible. Uses a whitelist though, not a blacklist. Instead of selecting ‘yes’ to email Plex users, set that to no. Then in the field below it enter everyone’s email that you do want it to go to seperate by a comma and save. Thats what I do for mine.
  4. ninthwalker

    [Support] Ninthwalker - NowShowing

    Glad you fixed it. Not sure exactly why it behaved like that. Almost seems like it still saw files from the old install even though I know you said you deleted the appdata. Let me know if you need help with anything else. Thanks.
  5. ninthwalker

    [Support] Ninthwalker - NowShowing

    Glad you got it mostly working. You are the first to say the grid/table was funky. I'll have to see if I can replicate the error. This was on the webpage correct? As the tooltip states, that setting is only for the web, the email is always table layout. grid doesn't look good in email. For your html suggestion, where would you want that field to show in the report? Like under the title but before the Movies section for like a special message or something? You can always edit the report file in the appdata directly and put whatever html/css or images or different formatting you want in it that was as well. That's the main way to fully customize how you want the report to look if you don't want the default out-of-box look. I have mine modified that way as well.
  6. ninthwalker

    [Support] Ninthwalker - NowShowing

    Can you provide other logs possibly when sending a report fails? There is the docker log you can get from unraid by clicking on the log icon on the docker settings page. Also the logs from within the app from the tools > Log Viewer menu. Also your smtp settings used? Make sure to replace any username/password/ip type info with redacted versions if you want. It's not liking some setting/configuration you have in there it seems. Thanks.
  7. ninthwalker

    [Support] Ninthwalker - NowShowing

    Great, glad it's all working for you.
  8. ninthwalker

    [Support] Ninthwalker - NowShowing

    Your install is def messed up and missing system files. See my explanation on github to re-install.
  9. ninthwalker

    [Support] Ninthwalker - NowShowing

    Disable the test cron, that's why no emails. The banner at the top is warning that it's on. It is an option under the Plex tab. As the tooltip for it states: For testing cron schedule. See Tools section for On-demand test. Enabling this will test both email and web reports using the email report cron time. Only the admin will be sent an email, users will NOT receive one. Disabling that should let the on-demand and test report functions and everything to work. Let me know after you do that. Try a test one first just so you get one and confirm that email settings are correct. then you can run an on-demand one to see if it goes to your users as expected.
  10. ninthwalker

    [Support] Ninthwalker - NowShowing

    What options have you selected on the email and report tabs? The on demand uses the current email/report settings. To have it email all users on your server you would want to select 'yes' on the email tab for the 'email plex users' option. Is that selected? Also to make sure on the 'report > report type' includes an email option. Also, check the logs, does it say anything else? Logs can be found in 'Tools > Log Viewer' as well as the docker log from the unRAID menu for the docker. For your second question, it will email all users all libraries whether they have access or not. If you want to exclude a library you can do so in the 'Plex > Libraries to Skip' box. So you could put your xxx or 4k section there for example to not have anything there sent out.
  11. ninthwalker

    [Support] Ninthwalker - NowShowing

    I replied to you on your github issue, we can talk about it there. Thanks
  12. ninthwalker

    [Support] Ninthwalker - NowShowing

    Glad you figured out the port part. The tool-tip for the Plex Server Field has details and examples. Let me know if you think I should word it differently. People all have different setups and proxy'ing they do, so tried to make it so it could work for anyone's setup even if the plex server is in a different location than this docker. Currently it states: Uses port 32400 if no 'http/s' protocol specified. ie: 192.168.1.20 http://plex.mydomain.com https://plex.mydomain.com:32400 https://mydomain.com:12345 Haven't had anyone yet tell me the log viewer buttons don't work. None of them do anything? Do you get an error or have an example of what it does when you click one of the buttons?
  13. ninthwalker

    [Support] Ninthwalker - NowShowing

    If your "crontab -u xyz - l" is showing ".. combinedreport -t .." that means it is in test mode. (the "-t" switch). So that is probably what is messing up your cron schedule. You probably at some point set the 'Test Cron Schedule' to 'Yes' on the Report tab. That tool-tip displays the following: For testing cron schedule. See Tools section for On-demand test. Enabling this will test both email and web reports using the email report cron time. Only the admin will be sent an email, users will NOT receive one. Try changing that setting to NO, then save, then check the docker crontab again and it should be showing your 2 entries you set in the GUI. Let me know. Thanks. PS: The "Please go to http://hostIP:hostPort/admin to configure settings" is just shown everytime the docker starts for people to know where to go to for the admin page.
  14. ninthwalker

    [Support] Ninthwalker - NowShowing

    No, time format is hard coded since I have to do a conversion on it. I don't have plans to make a separate conversion/24 hour option, sorry.
  15. ninthwalker

    [Support] Ninthwalker - NowShowing

    Thanks for the report. A couple others have reported some statistics not matching either. From what I've discovered, the Tautulli database structure can vary per user depending on a few factors. I'm looking into doing some extra validation for the stats for the next update so it will verify it's the correct one before reporting. Thanks.