PsiKoTicK

Members
  • Posts

    8
  • Joined

  • Last visited

Everything posted by PsiKoTicK

  1. Reverse Proxy if anyone can help: On local web I get the normal AMP screen: https://psikotick.com/files/amp.png With Reverse Proxy: https://psikotick.com/files/ampbroken.png Second, Larger Issue: I cannot download a game. I started a Minecraft Bedrock instance, set it up, click download/update, and nothing no popup, nada. Can't click update or start, either. I run AMP currently in an Ubuntu VM and was hoping to move on to the docker, but need to figure these out
  2. Huh... guess I just did it wrong, lol, it was easy enough to copy the default, rename, and edit, at least... now I'm trying to figure out wordpress, so thank you, it's like 98% of the way there
  3. Hey, man, thank you. It was not a direct answer, but I was able to find enough to realize I needed a second file in the site-confs for the other server, not just another block in the default (cuz it wouldn't let me, who knew?) - and it's up and going, and my wife is happy, and now I know new things. Appreciate your help.
  4. Ah, I just have default certification, I don't "need" the *. just the main b.com and www.b.com - and it errors if I use *. so I am fine not having it. So should I make a new Proxy Config? My server block seems to only exist in the proxy subdomain/subfolder.conf files - I admit I am a n00b with this stuff but I am a tech guy, just... I still find this hard to wrap my head around, I'm getting there, though!
  5. Hey y'all. I'm trying to add a second domain to my container, and I need a wordpress container to be where www. goes for the new domain. domain a.com is working, and I have both subdomain and subfolder conf files working, and the same subdomains will work with the new b.com domain Wife does not want to have to use wordpress.b.com she wants to just use b.com and/or www.b.com - I am not quite sure how to get this setup in the container and without rebuilding my entire proxynet is there a way to set this up? I have figured out that I cannot use *.b.com in the extra_domains field, so the cert is now good for a.com and b.com - but I am unsure how to force www.b.com and b.com to go to a hosted wordpress container but not have a.com and www.a.com go there - is there a config I can change so it looks at both and routes based on the domain?
  6. I have a subdomain, comics.domain.com. I am using the ubooquity.subdomain.conf.sample, and just updated it to server_name comics.* instead of ubooquity.* The Ubooquity page requires domain.com:2202/ubooquity or domain.com:2203/ubooquity/admin for admin access. I changed the server_name and added the /ubooquity and the /ubooquity/admin in the proxy_pass, but it won't pass that through properly. That is what I'm trying to figure out, I think. With Booksonic, I was able to tell the booksonic server to use no base URL, so it just goes to domain.com:4040/ instead of domain.com:4040/booksonic/ If it would be easier to use the subfolder method, and just a redirect for my subdomain, I'm fine with that as well, I honestly just had that thought, but I'm not quite sure how I'd set that up in my domain provider (which is namecheap, but if I know the methodology to use I can figure that part out)
  7. Alright, I feel really dumb, but I cannot get Ubooquity to work, at all. I get the "welcome to our server" page. server_name comics.*; include /config/nginx/ssl.conf; client_max_body_size 0; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /login; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_ubooquity ubooquity; proxy_pass http://$upstream_ubooquity:2202/ubooquity/; } location /admin { include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_ubooquity ubooquity; proxy_pass http://$upstream_ubooquity:2203/ubooquity/admin/; } I have tried without the /ubooquity, etc, and it does not work. I've gotten it to work by using comics.domain.com/ubooquity/ with only the port listed in proxy_pass instead of the URL, but had no CSS and would show me no actual data, so something is wonky... I own the domain, and use a dynamic dns to update my domain name, all my cnames are pointed to domain.com and other things work (organizr, booksonic as mentioned below), just hung up here on ubooquity currently, but if anything with a base URL doesn't work I don't know how functional this is for me, I was happy with redirects but I would prefer to use an https connection if possible I had a similar issue with Booksonic, and was able to just turn off the /booksonic/ part of that URL so it loads direct without the base URL, I could not get it to work if I had /booksonic in the proxy_pass line either... I cannot determine how to do that with my Ubooquity server, so if I should ask there instead, just let me know Herlp. Please.