Jump to content

Server can no longer connect to Github

Recommended Posts

I'm not sure what's going on, or what has been changed within my server, but I can no longer install anything related to Github, such as community apps page, plugin updates, system updates. I've been running my server for about two months now with no hiccups, haven't changed any network hardware recently. The only thing I have for sure changed was update to 6.9.2, and attemping to login with my forum email and password and failing. I can browse the internet just fine on all my VM's, even pulling up the same Github pages that I was trying to download in the first place. But within the unRAID GUI I have no such luck. I've tried flashing a brand new installation of unRAID, everything ran fine and I could install packages and updates normally. After a while, transferring my old unRAID flash installation to my new one, it stopped working again. (copying over my plugins, appdata, etc)



It's not a hardware issue. Can't be.

I've triple checked my IP Address and DNS servers multiple times, on my server and my router settings, it was all the same before this all occurred. 

There was one occurrence where I got it working when I logged in to my roommates computer, everything was fine for 10 minutes, then its gone again. Tried mine and my girlfriends computer, tablets, etc, nothing. (How does this even make sense??) 

When uninstalling the community apps plugin, and reinstalling, fails to download, network error

There's only so much hair I can pull out of my head, anybody have a clue?


Link to comment

Something is weird with your flash drive.  (Corrupt?)  On boot up, it was downloading every plugin over again (which it shouldn't be as they're all stored on the flash).  That happened until it looks like the network got completely initialized at which point it started doing network failures.


Quite honestly, I'd switch your DNS servers from the ones your ISP wants you to use to something like / to bypass any problems that they might be having (my experience has always been that ISP's DNS servers suck at the best of times, even beyond that fact that by using them you're simply helping them track where and what you're doing)


Might not solve the problem, but after that I'd suggest deleting /config/network.cfg (or renaming) on the flash drive to see if things work via the defaults.

Link to comment
15 minutes ago, Squid said:

Might not solve the problem, but after that I'd suggest deleting /config/network.cfg (or renaming) on the flash drive to see if things work via the defaults.

Hey Squid! Thanks for the reply, interestingly enough, switching back to my ISP's DNS Servers didn't help, but deleting the network.cfg and rebooting did make a change! Checked the network config on unRAID and its set to bonding (which I don't want) but I'm able to download and update everything again. Tested by adding your community apps plugin. Removing the bond setting gives me no internet access whatsoever (any clues why? I wasn't using it before, and I don't want to.)


Link to comment
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...