Jump to content

Server decided to not detect array until hard reboot


Recommended Posts

Hey all,

So last night around 21:50 I had a couple people asking me if there was anything wrong with my Plex server because they weren't able to access my content.

I immediately opened up a local Plex client and loaded up a movie, and it played instantly.

Thinking the problem was on their end, I insisted they rebooted their device/router and I logged into Unraid and was immediately alarmed when I saw that NOTHING was showing in the 'main' tab - no disks, array, nothing.

Also the Dashboard had no stats on it at all. No docker apps, no CPU loads, system info, nothing.

There was also zero error messages, and I was able to navigate the Unraid web OS through my browser flawlessly, however I noticed that I was only able to access it internally, and using my DDNS to access it externally returned an error.

I rebooted it from the Dashboard menu, and when it came back after a few mins I logged in to find no change.

It's only when I went to the basement and physically pressed the shutdown button on the machine that it eventually went through the shutdown sequences and powered off. I then physically turned it back on and it seemed to boot normally, albeit with a parity check - which is still in progress.

The 'Fix Common Problems' plugin shows no errors, however I've attached the diagnostics file.

The server is kept in a well-ventilated (and cold) cellar. Since the case is also well-ventilated, CPU temps never really get higher than 50deg C and HDDs don't get hotter than 38dec C.

Can someone give me an idea of what caused this? No point having a server if I have to manually reboot it occasionally.

nas-diagnostics-20210828-1209.zip

Link to comment

It just happened again!

This time, I was actually browsing the webUI while it happened. The weird thing is - even though I cannot access any of my network shares (including my media content) I'm still able to stream that content from the Plex server from those same shares, while both from inside and outside my LAN. How is this possible if all the content is located on the array which it isn't detecting??

I haven't rebooted the server yet, but I'm noticing while navigating between pages of the WebUI, that the status on the bottom left status bar occasionally switched from 'array undefined' to 'array started', and then without a few seconds switches back to 'array undefined' again.

Eventually, about 10 mins later, the webUI became unresponsive altogether - however Plex still worked!

What is going on?

Could this be a problem with the flash drive? Or are we looking at something else here?

Also, I had previously set the local syslog files to be saved in my 'downloads' share, however I can't find any in there.

I have completely no idea what to do. CAN SOMEBODY PLEASE HELP ME, BECAUSE I FEEL LIKE THIS IS FALLING ON DEAF EARS!!!

Edited by Corvus
Link to comment

Unfortunately there's nothing relevant logged before the crash, this usually suggest a hardware problem, one thing you can try it to boot the server in safe mode with all docker/VMs disable, let it run as a basic NAS for a few days, if it still crashes it's most likely hardware, if it doesn't start turning on the other services one by one.

Link to comment
10 minutes ago, JorgeB said:

Unfortunately there's nothing relevant logged before the crash, this usually suggest a hardware problem, one thing you can try it to boot the server in safe mode with all docker/VMs disable, let it run as a basic NAS for a few days, if it still crashes it's most likely hardware, if it doesn't start turning on the other services one by one.


When you say hardware, does that include a USB flash malfunction?
I'd rather not have to disable my Plex docker, as where I am, we are still in lockdown and I have over a dozen people depending on my Plex server.

Edited by Corvus
Link to comment
1 hour ago, ChatNoir said:

You can always set up Unraid on a new flashdrive a see if it is better.

Well I mean, I'm trying to see whether or not we've just ruled that out. Have we or haven't we?

If we've ruled it out 100%, there's no point in me doing that, is there?

If I do, I'm definitely not starting from scratch, I'll be transferring my backup and license so that my array is intact.

Link to comment
18 minutes ago, JorgeB said:

Very unlikely that the flash drive is the problem, but can't say 100%.

How else can I go about narrowing down which component it is? I don't want to take the server offline for multiple days because I have people relying on it during lockdown - which unfortunately my entire country is still in.

Link to comment
24 minutes ago, JorgeB said:

It's very difficult to diagnose hardware issues, especially remotely, you can try using a different computer as Unraid server, if you have one, key is tied to the flash drive, not the hardware.

I don't see how that would help, given that a different computer would have completely different hardware specs. It would be impossible to isolate the fault to a specific component.

I know that all of the Unraid OS (including my settings) are stored on the flash, but hypothetically, if I were to replace the RAM, motherboard, CPU and PSU, would I lose the array? What would I need to do to preserve the array and all of its related config?

Link to comment
3 minutes ago, JorgeB said:

It's plug and play, as long as you don't use RAID controllers.

Really? So I wouldn't need to do anything special to 'bring back' the array or anything? No special order in how they're plugged in? Just built and boot into Unraid?

What about VMs and how they're configured? Surely I'd have to completely rebuild them to work on the new hardware, right?

Edited by Corvus
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...